Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 382411 - Please stabilize kde-base/kdepimlibs-4.7.3-r1
Summary: Please stabilize kde-base/kdepimlibs-4.7.3-r1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard: fixed in 4.7.4, was: kdepim-4.4 incom...
Keywords: STABLEREQ
: 395915 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-09 17:24 UTC by Johannes Hirte
Modified: 2011-12-26 19:06 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Hirte 2011-09-09 17:24:14 UTC
Since KDE SC 4.7 old kmail-1 produces errors with imap-accounts and local filters. Mails are moved correctly into local folders, but with remote folders it fails and loses the mails.

There is an upstream bug open and it seems it won't be fixed by the KDE devs:
https://bugs.kde.org/show_bug.cgi?id=279432

I would prefer a fix, as kmail2 doesn't work for me. But until a fix is available, kdepim-4.4 should be masked for KDE SC 4.7 and later cause of the possible mail loss.

Reproducible: Always
Comment 1 Andreas K. Hüttel gentoo-dev 2011-09-09 18:41:30 UTC
Do you use disconnected imap or online imap?
Do I understand this correctly, the bug only relates to local filters?

(I am testing and using both imap versions, and have not seen any problems yet- but I do not use local filters.)
Comment 2 Johannes Hirte 2011-09-09 19:02:15 UTC
(In reply to comment #1)
> Do you use disconnected imap or online imap?
> Do I understand this correctly, the bug only relates to local filters?
> 
> (I am testing and using both imap versions, and have not seen any problems yet-
> but I do not use local filters.)

I'm using online imap with local filters. The bug appears when the filter is pushing mail into imap-folders, for example a spamfilter. I've local filters for sorting the mails into local folders by mailinglist. Also spam is sorted into a local folder. The remaining mails are kept in the imap folder. Thus, the ham mails are pushed back on the server normaly, and this fails. I get the error message and the mails are lost.
Comment 3 Andreas K. Hüttel gentoo-dev 2011-09-09 20:02:34 UTC
Could you please try something for me? 

* mark a message in a local folder as "unread"
* move it manually to an imap folder

what happens?
Comment 4 Johannes Hirte 2011-09-09 21:37:21 UTC
(In reply to comment #3)
> Could you please try something for me? 
> 
> * mark a message in a local folder as "unread"
> * move it manually to an imap folder
> 
> what happens?

Marking message as new results in the same error message as reported, but without loosing the mail.
Comment 5 Andreas K. Hüttel gentoo-dev 2011-09-09 21:53:03 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > Could you please try something for me? 
> > 
> > * mark a message in a local folder as "unread"
> > * move it manually to an imap folder
> > 
> > what happens?
> 
> Marking message as new results in the same error message as reported, but
> without loosing the mail.

Sigh. Then we're seeing the same problem (just it's not so dramatic for me). I cannot upload unread mails either.

One more thing- could you please try rebuilding the whole kdepim and check if the problem remains? 

emerge -a1 akonadi akregator blogilo kabcclient kaddressbook kalarm kdepim-icons kdepim-kresources kdepim-meta kdepim-strigi-analyzer kdepim-runtime kdepim-wizards kjots kleopatra kmail knode knotes konsolekalendar kontact korganizer ktimetracker libkdepim libkleo libkpgp

You can remove packages that are not installed on your system from your commandline, but it's important that you rebuild all *installed* kdepim-4.4 packages with a *single emerge command* since the rebuild order matters.
Comment 6 Johannes Hirte 2011-09-09 22:20:24 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #3)
> > > Could you please try something for me? 
> > > 
> > > * mark a message in a local folder as "unread"
> > > * move it manually to an imap folder
> > > 
> > > what happens?
> > 
> > Marking message as new results in the same error message as reported, but
> > without loosing the mail.
> 
> Sigh. Then we're seeing the same problem (just it's not so dramatic for me). I
> cannot upload unread mails either.
> 
> One more thing- could you please try rebuilding the whole kdepim and check if
> the problem remains?

Did so, I installed a complete system new with KDE SC 4.7 and kdepim-4.4 a week ago. I was switching between kdepim-4.4 and kdepim-4.7 several times the last two days. If you wish, I can do a rebuild of kdepim again. But I doubt this will change something.
Comment 7 Andreas K. Hüttel gentoo-dev 2011-09-09 22:26:29 UTC
(In reply to comment #6)

> Did so, I installed a complete system new with KDE SC 4.7 and kdepim-4.4 a week
> ago. I was switching between kdepim-4.4 and kdepim-4.7 several times the last
> two days. If you wish, I can do a rebuild of kdepim again. But I doubt this
> will change something.

Just tried myself. Does not help.
Comment 8 riepernet 2011-09-20 21:17:06 UTC
actually i dont experience mail loss since the mails get sorted into the dimap folders and just dont make it to the server. during next sync cycle these mails get uploaded just fine.
dont know whether my setup is special: i use a kolab server.
Comment 9 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-10-28 22:19:21 UTC
what's your kdepim-runtime version?
Comment 10 Andreas K. Hüttel gentoo-dev 2011-10-28 22:42:38 UTC
(In reply to comment #9)
> what's your kdepim-runtime version?

4.4.11.1 here (should be the same as the rest of kdepim)

not sure if combining kdepim-4.4 with kdepim-runtime-4.7 is possible
Comment 11 Andreas K. Hüttel gentoo-dev 2011-12-15 23:22:54 UTC
See https://bugs.kde.org/show_bug.cgi?id=289084 for a possible fix
Comment 12 Andreas K. Hüttel gentoo-dev 2011-12-16 00:00:04 UTC
This is fixed in kdepimlibs-4.7.4-r1. Backport to 4.7.3 follows tomorrow.
Comment 13 Andreas K. Hüttel gentoo-dev 2011-12-24 19:05:00 UTC
*** Bug 395915 has been marked as a duplicate of this bug. ***
Comment 14 Andreas K. Hüttel gentoo-dev 2011-12-25 23:40:13 UTC
Arches, sorry for the extra work but this fixes a super-annoying bug. It would be great if we could squeeze it in quickly so stable users also already benefit.

Please stabilize kde-base/kdepimlibs-4.7.3-r1
Target "amd64 ppc x86"

(but I'll handle ppc separately, they are not cc'ed here)
Comment 15 Agostino Sarubbo gentoo-dev 2011-12-26 17:11:38 UTC
amd64/x86 stable, fixed