Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 381887 - net-fs/nfs-utils-1.2.4: nfs init script should change opts variable to use either extra_commands or extra_started_commands
Summary: net-fs/nfs-utils-1.2.4: nfs init script should change opts variable to use ei...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Network Filesystems
URL: http://linux-nfs.org/
Whiteboard:
Keywords:
: 388391 (view as bug list)
Depends on:
Blocks: init.d-depr-opts
  Show dependency tree
 
Reported: 2011-09-05 08:01 UTC by teidakankan
Modified: 2011-10-24 22:09 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge info (emerge_info.txt,15.80 KB, text/plain)
2011-09-05 08:01 UTC, teidakankan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description teidakankan 2011-09-05 08:01:14 UTC
/etc/init.d/nfs  restart
 * Use of the opts variable is deprecated and will be
 * removed in the future.
 * Please use extra_commands or extra_started_commands.
 * Stopping NFS mountd ...                                                                                                 [ ok ]
 * Stopping NFS daemon ...                                                                                                 [ ok ]
 * Unexporting NFS directories ...                                                                                         [ ok ]
 * Use of the opts variable is deprecated and will be
 * removed in the future.
 * Please use extra_commands or extra_started_commands.
 * Exporting NFS directories ...                                                                                           [ ok ]
 * Starting NFS mountd ...                                                                                                 [ ok ]
 * Starting NFS daemon ...                                                                                                 [ ok ]
 * Starting NFS smnotify ... 

Reproducible: Always




Reference Bug #381635
Comment 1 teidakankan 2011-09-05 08:01:35 UTC
Created attachment 285595 [details]
emerge info
Comment 2 iGentoo 2011-09-06 12:28:18 UTC
I have the same problem:

 * Use of the opts variable is deprecated and will be
 * removed in the future.
 * Please use extra_commands or extra_started_commands.
 * Invalidating stale software suspend images ...
 [ ok ]
sys-power/hibernate-script-2.0-r3 (/etc/init.d/hibernate-cleanup)

 * Use of the opts variable is deprecated and will be
 * removed in the future.
 * Please use extra_commands or extra_started_commands.
 * Loading ALSA modules ...
 [ ok ]
media-sound/alsa-utils-1.0.24.2-r1 (/etc/init.d/alsasound)

 * Use of the opts variable is deprecated and will be
 * removed in the future.
 * Please use extra_commands or extra_started_commands.
 * Loading ip6tables state and starting firewall ...
 [ ok ]
 * Use of the opts variable is deprecated and will be
 * removed in the future.
 * Please use extra_commands or extra_started_commands.
 * Loading iptables state and starting firewall ...
 [ ok ]
net-firewall/iptables-1.4.12.1 (/etc/init.d/iptables)
net-firewall/iptables-1.4.12.1 (/etc/init.d/ip6tables)

 * Use of the opts variable is deprecated and will be
 * removed in the future.
 * Please use extra_commands or extra_started_commands.
 * Exporting NFS directories ...
 [ ok ]
 * Starting NFS mountd ...
 [ ok ]
 * Starting NFS daemon ...
 [ ok ]
 * Starting NFS smnotify ...
 [ ok ]
net-fs/nfs-utils-1.2.4 (/etc/init.d/nfs)

 * Use of the opts variable is deprecated and will be
 * removed in the future.
 * Please use extra_commands or extra_started_commands.
 * Starting D-BUS system messagebus ...
 [ ok ]
sys-apps/dbus-1.4.14 (/etc/init.d/dbus)

 * Use of the opts variable is deprecated and will be
 * removed in the future.
 * Please use extra_commands or extra_started_commands.
 * samba -> start: smbd ...
 [ ok ]
 * samba -> start: nmbd ...
 [ ok ]
net-fs/samba-3.5.11 (/etc/init.d/samba)

 * Use of the opts variable is deprecated and will be
 * removed in the future.
 * Please use extra_commands or extra_started_commands.
 * Starting spindownd ...
 [ ok ]
sys-block/spindown-0.4.0-r1 (/etc/init.d/spindownd)

 * Use of the opts variable is deprecated and will be
 * removed in the future.
 * Please use extra_commands or extra_started_commands.
 * Starting xinetd ...
 [ ok ]
sys-apps/xinetd-2.3.14 (/etc/init.d/xinetd)



find /etc/init.d/ -type f | sort | xargs grep -Hn --color "^opts="

/etc/init.d/acct:6:opts="report reload"
/etc/init.d/alsasound:9:opts="save restore"
/etc/init.d/clamd:6:opts="logfix"
/etc/init.d/dbus:6:opts="reload"
/etc/init.d/dhcpd:6:opts="configtest"
/etc/init.d/dnsmasq:6:opts="reload"
/etc/init.d/ebtables:6:opts="save reload panic"
/etc/init.d/hibernate-cleanup:101:opts="reload"
/etc/init.d/ip6tables:6:opts="save reload panic"
/etc/init.d/iptables:6:opts="save reload panic"
/etc/init.d/libvirtd:3:opts="start stop status reload restart"
/etc/init.d/nfs:6:opts="reload"
/etc/init.d/proftpd:6:opts="reload"
/etc/init.d/reboot.sh:4:opts="-dpk"
/etc/init.d/samba:6:opts="reload"
/etc/init.d/shutdown.sh:4:opts="-d"
/etc/init.d/spindownd:10:opts="reload"
/etc/init.d/squid:6:opts="${opts} reload"
/etc/init.d/sshd:6:opts="${opts} reload checkconfig gen_keys"
/etc/init.d/tor:6:opts="${opts} checkconfig reload"
/etc/init.d/transmission-daemon:6:opts="start stop reload"
/etc/init.d/xinetd:6:opts="reload dump check"



Portage 2.2.0_alpha53 (default/linux/amd64/10.0, gcc-4.6.1, glibc-2.14-r0, 3.0.4-custom x86_64)
=================================================================
System uname: Linux-3.0.4-custom-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9300_@_2.50GHz-with-gentoo-2.0.3
Timestamp of tree: Tue, 06 Sep 2011 11:15:01 +0000
ccache version 3.1.6 [enabled]
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r2, 3.2-r2
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.2
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.6.1-r1
sys-devel/gcc-config:     1.5-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.0.4::custom (virtual/os-headers)
sys-libs/glibc:           2.14
Repositories: gentoo gnome geki-overlay systemd custom
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -mtune=core2 -msse4.1 -O3 -fno-tree-vectorize -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=core2 -mtune=core2 -msse4.1 -O3 -fno-tree-vectorize -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox selinux sesandbox sfperms split-elog split-log strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync webrsync-gpg"
FFLAGS=""
GENTOO_MIRRORS="http://mirrors.163.com/gentoo http://mirrors.ustc.edu.cn/gentoo http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US zh zh_CN"
MAKEOPTS="-j10"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_COMPRESS_FLAGS="-9 -e -f"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/gnome /var/lib/layman/openoffice-geki /var/lib/layman/systemd /usr/local/portage"
SYNC="rsync://mirrors.xmu.edu.cn/gentoo-portage"
USE="X acl alsa amd64 audit bash-completion berkdb bzip2 cairo cli cracklib crypt cups cxx dbus dri fortran gdbm gnome gpm gtk gtk3 iconv ipv6 jpeg jpeg2k mmx modules mudflap multilib ncurses nls nptl nptlonly opengl openmp pam pcre perl png pppd pulseaudio python readline selinux session sse sse2 ssl svg sysfs tcpd tiff unicode vim-syntax xattr xinetd xorg zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US zh zh_CN" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_RSYNC_EXTRA_OPTS
Comment 3 SpanKY gentoo-dev 2011-09-18 01:52:03 UTC
should be all set now in the tree; thanks for the report!

Commit message: Convert to extra_started_commands
http://sources.gentoo.org/net-fs/nfs-utils/files/nfs.initd?r1=1.25&r2=1.26
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2011-10-24 22:09:32 UTC
*** Bug 388391 has been marked as a duplicate of this bug. ***