Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 381451 - app-misc/screen - add an init script to run multiple screen instances as a system service
Summary: app-misc/screen - add an init script to run multiple screen instances as a sy...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Sven Wegener
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-01 15:43 UTC by Ilya Dmitrichenko
Modified: 2014-10-30 01:30 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/etc/init.d/screen (screen,2.00 KB, text/plain)
2011-09-01 15:45 UTC, Ilya Dmitrichenko
Details
misc improvements (screen,2.26 KB, text/plain)
2011-09-08 12:17 UTC, Ilya Dmitrichenko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ilya Dmitrichenko 2011-09-01 15:43:49 UTC
I got quite curious what's USE=rtorrentd is and noticed that it installs an init
script which runs rotrrent inside of screen.

I had been using screen quite a lot and had it set-up in my login scripts ...
However I just realized that it would be much nice to have the screens available
without loging it, i.e - you reboot the box and don't have to worry about torrents
and other things ... etc. Hope someone will share my idea on that :)

The way it works is quite simple - it starts an instance for each file
found in /etc/screen.d/, the files a custom screenrc's for whatever you
wish to do with it :)

I have done the best I could to avoid problems (i.e. having multiple sessions
with the same name and trying to kill exited sessions ... etc.
It realise on pid files, but doesn't use them the usual way - it uses
`screen -S MySession -X quit` for killing (see the script for more details).

It would be nice to add USE=initscript (or anything you wish to call it)
to app-misc/screen ebuild. Perhaps it's best to include the init script
in files dir ... or I can host it somewhere.



Reproducible: Always

Steps to Reproduce:
wrote the script



perhaps by adding this we can get rid of USE=rtorrentd, because that is quite a basic script and doesn't allow much ... I usually start multiple rtorrent sessions ... and that requires having custom screenrc files anyway.
Also that was just for rtorrent, my approach fits all purposes :)

there are a few things one may wish to extend it with, e.g. add support for USE=multiuser  functionality and perhpas some other cool things ;()
Comment 1 Ilya Dmitrichenko 2011-09-01 15:45:28 UTC
Created attachment 285271 [details]
/etc/init.d/screen
Comment 2 Ilya Dmitrichenko 2011-09-08 12:17:13 UTC
Created attachment 285849 [details]
misc improvements

Added ${SVCNAME}, so no one can do this create `/etc/screen.extra.d/`
and populate it with config files, then symlink the init script:
`cd /etc/init.d/; ln -s screen screen.extra`.
Comment 3 Jeroen Roovers gentoo-dev 2014-10-30 01:30:40 UTC
(In reply to Ilya Dmitrichenko from comment #0)
> I got quite curious what's USE=rtorrentd is and noticed that it installs an
> init
> script which runs rotrrent inside of screen.

What rtorrent does there is bad enough already.