Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 381375 - app-portage/gentoolkit- equery doesn't show proper package keywording status
Summary: app-portage/gentoolkit- equery doesn't show proper package keywording ...
Status: VERIFIED DUPLICATE of bug 375311
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Tools (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Portage Tools Team
Depends on:
Reported: 2011-09-01 00:34 UTC by Christopher Head
Modified: 2011-09-23 06:52 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Head 2011-09-01 00:34:28 UTC
I installed app-benchmarks/i7z-0.26 on an AMD64 system. I run a mostly-stable system with unstable exceptions. Looking in /var/db/pkg/app-benchmarks/i7z-0.26/i7z-0.26.ebuild shows that it was keyworded ~amd64 when installed. Looking in /usr/portage/app-benchmarks/i7z/i7z-0.26.ebuild and on shows it is still keyworded ~amd64. In order to be allowed to install this package, I added this line to /etc/portage/package.accept_keywords:


According to the man page for equery, under the list command:

Mask-status field ([ ~M-??]):
... A ~ means the package is masked by keyword, e.g., you are running a stable system and the package is marked testing)...


# equery l app-benchmarks/i7z
 * Searching for i7z in app-benchmarks ...
[IP-] [  ] app-benchmarks/i7z-0.26:0

There is no tilde! I am most definitely running a (mostly-) stable system, and this package is most definitely unstable. I seem to remember a time in the past when this worked: I could use equery list to find out whether a package was still unstable or whether it had become stable and hence no longer needed listing in package.accept_keywords. It seems more recently that this is no longer the case.

Is this change intentional? The man page doesn't seem 100% clear. It could be argued that "you are running a stable system" means 100% stable, so this would only ever apply to packages that aren't installed anyway or that were installed with a temporary environment variable override. It could also mean what I expected it to mean, and what it seems to have meant in the past, which is simply that ACCEPT_KEYWORDS doesn't have a tilde in it (a stable *system*, but with a small handful of unstable exceptions). Either way perhaps this should be clarified a bit more?

Reproducible: Always
Comment 1 Paul Varner (RETIRED) gentoo-dev 2011-09-03 17:47:32 UTC

*** This bug has been marked as a duplicate of bug 375311 ***