Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 380693 - dev-lisp/clisp-2.48 - hangs in ./lisp.run -B . -N locale -E UTF-8 -Epathname 1:1 -Emisc 1:1 -norc -m 2MW -lp ../src/ -x '(and (load "../src/init.lisp") (sys::%saveinitmem) (ext::exit)) (ext::exit t)'
Summary: dev-lisp/clisp-2.48 - hangs in ./lisp.run -B . -N locale -E UTF-8 -Epathname ...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Common Lisp Bugs
URL:
Whiteboard:
Keywords:
Depends on: 638942
Blocks:
  Show dependency tree
 
Reported: 2011-08-25 22:35 UTC by Joel
Modified: 2019-06-15 11:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (info,4.90 KB, text/plain)
2011-08-26 17:34 UTC, Joel
Details
Build of clisp (clisp,88.83 KB, text/plain)
2011-08-26 17:35 UTC, Joel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joel 2011-08-25 22:35:36 UTC
I'm trying to install clisp on gentoo-hardened amd64, but I get a freeze when compiling it:

gcc -march=native -O2 -pipe -mno-avx -Wa,--noexecstack -I/usr/include/db4.5 -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type -Wmissing-declarations -Wno-sign-compare -Wno-format-nonliteral -O -falign-functions=4 -pthread -DUNICODE -DMULTITHREAD -DPOSIX_THREADS -DDYNAMIC_FFI -I. -Wl,-O1 -Wl,--as-needed  gllib/uniwidth/width.o gllib/uniname/uniname.o gllib/localcharset.o spvw.o spvwtabf.o spvwtabs.o spvwtabo.o eval.o control.o encoding.o pathname.o stream.o socket.o io.o funarg.o array.o hashtabl.o list.o package.o record.o weak.o sequence.o charstrg.o debug.o error.o misc.o time.o predtype.o symbol.o lisparit.o i18n.o foreign.o unixaux.o zthread.o built.o modules.o /usr/lib64/libreadline.so -lncurses -ldl /usr/lib64/libavcall.a /usr/lib64/libcallback.a  -L/usr/lib64 -lsigsegv -L/usr/lib64 -lc -o lisp.run
./lisp.run -B . -N locale -E UTF-8 -Epathname 1:1 -Emisc 1:1 -norc -m 2MW -lp ../src/ -x '(and (load "../src/init.lisp") (sys::%saveinitmem) (ext::exit)) (ext::exit t)'

And the compilation doesn't move from here. I've tried the 2.48-r2 with the same result. I've also changed MAKEOPTS="-j5" to -j1, without changes.

Reproducible: Always
Comment 1 Jeroen Roovers gentoo-dev 2011-08-26 17:21:10 UTC
1) Please post your `emerge --info' output.
2) Please attach the entire build log to this bug report.
Comment 2 Joel 2011-08-26 17:34:04 UTC
Created attachment 284725 [details]
emerge --info
Comment 3 Joel 2011-08-26 17:35:14 UTC
Created attachment 284727 [details]
Build of clisp

Tried for hours and doesn't change. I've tried with -j1, -O1 and the same result happens.
Comment 4 Jeroen Roovers gentoo-dev 2011-08-27 14:54:53 UTC
Looks like it doesn't respect CC either.
Comment 5 Joel 2011-08-28 21:49:06 UTC
Build ends fine without threads USE flag
Comment 6 Cyprien Nicolas (fulax) 2019-06-15 11:22:19 UTC
Per bug #638942 it should be fixed in newer versions