Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 380637 - app-misc/byobu with app-misc/screen - /etc/screenrc: termcapinfo xterm 'k1=\E[11~:k2=\E[12~:k3=\E[13~:k4=\E[14~' breaks F2-F4 functions keys
Summary: app-misc/byobu with app-misc/screen - /etc/screenrc: termcapinfo xterm 'k1=\E...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sven Wegener
Depends on:
Reported: 2011-08-25 11:43 UTC by Thomas Kahle (RETIRED)
Modified: 2022-04-14 12:20 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Kahle (RETIRED) gentoo-dev 2011-08-25 11:43:30 UTC
The keys F2-F4 in byobu are disfunction in Gentoo.
I found the reason and a fix.  Appearently the section 
XTERM TWEAKS in /etc/screenrc does something to these keys via

  termcapinfo xterm 'k1=\E[11~:k2=\E[12~:k3=\E[13~:k4=\E[14~'

Replacing that with 

termcapinfo xterm 'k1=\EOP:k2=\EOQ:k3=\EOR:k4=\EOS'

fixed it.
Comment 1 Thomas Dickey 2011-11-20 00:52:36 UTC
It might also work properly if you simply deleted the line.
Comment 2 Aniruddha Shankar 2022-04-14 12:20:47 UTC
in /etc/screenrc , commenting out 

#  termcapinfo xterm* 'k1=\E[11~:k2=\E[12~:k3=\E[13~:k4=\E[14~'

seems to have fixed it -- word of warning is that this is strictly a console-only install as of now and I don't have xterm