Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 380411 - www-client/icecat-6.0: Web pages with flash objects are causing freezes
Summary: www-client/icecat-6.0: Web pages with flash objects are causing freezes
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Low major (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 381245
  Show dependency tree
 
Reported: 2011-08-23 20:13 UTC by xiando
Modified: 2012-04-23 18:11 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description xiando 2011-08-23 20:13:48 UTC
My www-client/icecat 6.0 hangs on all pages with flash content on them.

This does not work in www-client/firefox 6.0.

Clean or normal profile makes no difference.

www-plugins/adobe-flash 11.0.1.60_beta201108082 64bit kde multilib -32bit -bindist -vdpau

Firefox and Icecat have the same use flags (alsa dbus ipc libnotify linguas_be linguas_de linguas_en linguas_fr linguas_nb linguas_nb_NO linguas_nn linguas_nn_NO linguas_sv linguas_sv_SE methodjit webm), so I find it strange that flash completely hangs icecat and still works fine in firefox.

This bug means you (or atleast I) can not use flash in icecat.

Please let me know if there is any way I can provide more relevant information.
Comment 1 xiando 2011-08-24 10:49:13 UTC
re-read, "This does not work in www-client/firefox 6.0.", wrong, flash hangs icecat 6, flash does not hang firefox 6. flash works with ff6, doesn't with icecat6
Comment 2 waynedpj 2011-08-26 01:04:34 UTC
i am seeing a similar/possibly same issue: icecat-6.0 will freeze for about 25-30 seconds or so, every 2-3 minutes maybe.  i thought it may have to do with Flash, but i only have Gnash installed, and i have Flashblock stopping all Flash (i think).

relevant info:

$ emerge -avp icecat gnash

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ~] www-client/icecat-6.0  USE="alsa crashreporter dbus ipc libnotify methodjit startup-notification system-sqlite webm wifi -custom-cflags -custom-optimization -debug -pgo" LINGUAS="en es fr it -af -ak -ar -ast -be -bg -bn -bn_BD -bn_IN -br -bs -ca -cs -cy -da -de -el -eo -es_ES -et -eu -fa -fi -fy -fy_NL -ga -ga_IE -gd -gl -gu -gu_IN -he -hi -hi_IN -hr -hu -hy -hy_AM -id -is -ja -kk -kn -ko -ku -lg -lt -lv -mai -mk -ml -mr -nb -nb_NO -nl -nn -nn_NO -nso -or -pa -pa_IN -pl -pt -pt_PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv -sv_SE -ta -ta_LK -te -th -tr -uk -vi -zu" 0 kB
[ebuild   R   ~] www-plugins/gnash-0.8.9  USE="agg cairo dbus ffmpeg gnome gstreamer gtk nls nsplugin opengl python sdl-sound ssh ssl vaapi (-aqua) -cygnal -doc -fbcon -kde (-kdeenablefinal) (-lirc) -mysql -openvg -sdl -test" 0 kB

please let me know what other info i can provide.  note that WebKit-based browsers like Midori are working fine.

thanks.
Comment 3 Christophe Philemotte 2011-09-08 07:13:52 UTC
same for me on ~amd64

Icecat reports on console:
** (icecat-bin:22822): WARNING **: Serious fd usage error 17

** (icecat-bin:22822): WARNING **: Serious fd usage error 11

After googling those errors, it is linked to addon. Indeed, it always happens when webpage contains flash.

I've read that a possible workaround is to set dom.ipc.plugins.enabled to false. Not yet tried.

For the moment, I've not noticed the same crash/freeze with fx6

www-client/firefox-6.0  USE="alsa crashreporter custom-optimization dbus ipc libnotify methodjit startup-notification webm -bindist -custom-cflags -debug -pgo -system-sqlite -wifi"
www-client/icecat-6.0  USE="alsa crashreporter custom-optimization dbus ipc libnotify methodjit startup-notification webm -custom-cflags -debug -pgo -system-sqlite -wifi"
Comment 4 Frédéric Barthelery 2011-09-08 07:22:35 UTC
I confirm that settting dom.ipc.plugins.enabled to false fix the problem.
Comment 5 waynedpj 2011-09-08 12:55:21 UTC
(In reply to comment #3)
> same for me on ~amd64
> 
> Icecat reports on console:
> ** (icecat-bin:22822): WARNING **: Serious fd usage error 17
> 
> ** (icecat-bin:22822): WARNING **: Serious fd usage error 11
> 
> After googling those errors, it is linked to addon. Indeed, it always happens
> when webpage contains flash.
> 
> I've read that a possible workaround is to set dom.ipc.plugins.enabled to
> false. Not yet tried.
> 
> For the moment, I've not noticed the same crash/freeze with fx6
> 
> www-client/firefox-6.0  USE="alsa crashreporter custom-optimization dbus ipc
> libnotify methodjit startup-notification webm -bindist -custom-cflags -debug
> -pgo -system-sqlite -wifi"
> www-client/icecat-6.0  USE="alsa crashreporter custom-optimization dbus ipc
> libnotify methodjit startup-notification webm -custom-cflags -debug -pgo
> -system-sqlite -wifi"

so far having disabled the installed Flash plug-ins (Gnash & Lightspark) seems to have stopped the freeze from happening for about 95% of the original problem pages.

also, as you have said, as well as reported here http://us.generation-nt.com/answer/bug-639837-ui-hangs-30s-while-loading-pages-help-204628871.html#r , when the freeze happens variations on this warning appear on the console:

** (icecat-bin:22822): WARNING **: Serious fd usage error 15
 
** (icecat-bin:22822): WARNING **: Serious fd usage error 19

thanks
Comment 6 waynedpj 2011-09-08 13:15:44 UTC
(In reply to comment #4)
> I confirm that settting dom.ipc.plugins.enabled to false fix the problem.

ditto here.  thanks for the fix.

  does this change cause any lost functionality?

peace
Comment 7 xiando 2011-09-08 17:25:02 UTC
Thanks for the WORKAROUND fix. I can now use the evil propietary flash technology in Icecat. 

I added new bolean dom.ipc.plugins.enabled.libflashplayer.so and set it to false in about:config. My dom.ipc.plugins.enabled is true, this somehow also works.
Comment 8 waynedpj 2011-09-09 00:47:41 UTC
(In reply to comment #7)
> Thanks for the WORKAROUND fix. I can now use the evil propietary flash
> technology in Icecat. 
> 
> I added new bolean dom.ipc.plugins.enabled.libflashplayer.so and set it to
> false in about:config. My dom.ipc.plugins.enabled is true, this somehow also
> works.

this was also a problem with the non-evil FLOSS Flash players as well ;)  and i can report that the following booleans in about:config set to false also work:

dom.ipc.plugins.enabled.libgnashplugin.so
dom.ipc.plugins.enabled.liblightsparkplugin.so


thanks again to everyone for the workaround fix ... now any news if this is an actual upstream bug?

peace
Comment 9 Lars Wendler (Polynomial-C) gentoo-dev 2011-10-08 19:12:05 UTC
Is this still a problem with icecat-7.0.1?
Comment 10 Alexander Weber 2011-10-09 14:32:01 UTC
Yes, the problem exists in 7.0.1 too.

I tested it on "~amd64" system with www-client/icecat-7.0.1 and www-plugins/adobe-flash-11.0.1.152 (USE="-32bit 64bit")

Console-Output is:
** (icecat:3908): WARNING **: Serious fd usage error 24

** (icecat:3908): WARNING **: Serious fd usage error 22


www-client/firefox-7.0.1-r1 at the same system works fine.
Comment 11 xiando 2011-10-15 17:44:04 UTC
This is still a problem with icecat-7.0.1. Both gecko-mediaplayer and adobe-flash hangs icecat. Does not happen with dom.ipc.plugins.enabled set to false. Settings specific flags like dom.ipc.plugins.enabled.libgnashplugin.so also work, but it looks like _all_ plugins (at least those I tried) bug like this.
Comment 12 Nirbheek Chauhan (RETIRED) gentoo-dev 2012-01-28 05:25:33 UTC
Still happens with 9.0? If the problem is persisting, you folks are going to have to report this bug with the debian maintainers since they're the ones who patch it.
Comment 13 Alexander Weber 2012-02-19 18:42:00 UTC
The Issue is still happen in the current stable www-client/icecat-10.0-r1
Comment 14 Pacho Ramos gentoo-dev 2012-04-23 18:11:02 UTC
dropped