Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 380197 - x11-wm/emerald pollutes pkg-config Libs space
Summary: x11-wm/emerald pollutes pkg-config Libs space
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Desktop-Effects herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: libpng-1.5
  Show dependency tree
 
Reported: 2011-08-22 08:32 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2011-09-14 20:48 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2011-08-22 08:32:57 UTC
As per summary: the EMERALD_LIBS and EMERALD_CFLAGS variables substituted in the .pc files are the expansion of what is found by Require:

The problem is that by doing this, -lpng14 is written to emeraldengine.pc and nothing will build against it until rebuilt, when updating to libpng 1.5 (and so on).
Comment 1 Samuli Suominen gentoo-dev 2011-09-14 20:48:07 UTC
I hope I got it right.

+  14 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> emerald-0.8.4-r2.ebuild,
+  +files/emerald-0.8.4-pkgconfig-pollution.patch:
+  Use Requires.private and Libs.private instead of Requires and Libs wrt
+  #380197 by Diego Elio Pettenò

Without revbump, I don't really expect emerald to cause any real problems, with only 1-2 reverse deps (likely not using the engine at all)