Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 379491 - repoman should warn or throw an error if new phases are defined in old EAPI ebuilds
Summary: repoman should warn or throw an error if new phases are defined in old EAPI e...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Repoman (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: 484436
  Show dependency tree
 
Reported: 2011-08-16 23:37 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2014-08-04 02:03 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
repoman_check_undefined_funcs.patch (repoman_check_undefined_funcs.patch,1.42 KB, patch)
2014-01-14 15:12 UTC, Chris Reffett (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2011-08-16 23:37:10 UTC
It happened before that a developer added an epatch line to a newly-added src_prepare on an ebuild that is using EAPI < 2. While people should test their ebuild I would rather start with the idea that repoman should catch this beforehand.
Comment 1 Chris Reffett (RETIRED) gentoo-dev Security 2014-01-14 15:12:03 UTC
Created attachment 367838 [details, diff]
repoman_check_undefined_funcs.patch

Working on this one, sent a patch to the portage-dev list. Attached is an updated version of that patch based on list feedback. Patch also checks for pkg_pretend in EAPI<4.
Comment 2 Chris Reffett (RETIRED) gentoo-dev Security 2014-01-27 21:47:37 UTC
Pushed a revised version to git, commit 00560e0b22059ffb42d965b4ef625950ab987afc
Comment 3 Brian Dolbec gentoo-dev 2014-08-04 02:03:30 UTC
released in portage-2.2.11