Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 379441 - x11-apps/xinit: startx leaks .serverauth.???? files
Summary: x11-apps/xinit: startx leaks .serverauth.???? files
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
: 316597 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-08-16 16:45 UTC by Helmuth Schmelzer
Modified: 2019-05-15 18:51 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
xinit-1.3.1-r1.ebuild (xinit-1.3.1-r1.ebuild,1.69 KB, text/plain)
2011-08-16 16:47 UTC, Helmuth Schmelzer
Details
startx_no_serverauth.patch (startx_no_serverauth.patch,559 bytes, patch)
2011-08-16 16:51 UTC, Helmuth Schmelzer
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Helmuth Schmelzer 2011-08-16 16:45:44 UTC
If you run X from startx, you'll accumulate large numbers of files in $HOME named .serverauth.????, one for each time you ever ran startx
The problem: /usr/bin/startx creates a file called $HOME/.serverauth.$$, runs xinit, then removes the file. If startx exits ungracefully

Reproducible: Always

Steps to Reproduce:
1.runs startx, runs fine, but with each time, ran startx
2.accumulate large numbers of files in home directory
3.

Actual Results:  
accumulate large numbers of files in $HOME named .serverauth.????
Comment 1 Helmuth Schmelzer 2011-08-16 16:47:56 UTC
Created attachment 283577 [details]
xinit-1.3.1-r1.ebuild

xinit ebuild with the startx_no_serverauth.patch
Comment 2 Helmuth Schmelzer 2011-08-16 16:51:00 UTC
Created attachment 283579 [details, diff]
startx_no_serverauth.patch

patch for deactivate accumulation of .serverauth.???? in home directory
Comment 4 Matt Turner gentoo-dev 2019-03-03 22:35:14 UTC
*** Bug 316597 has been marked as a duplicate of this bug. ***
Comment 5 Larry the Git Cow gentoo-dev 2019-05-15 18:51:38 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=491cd4d5509dd2f6866a5aaa6184c68915eb9652

commit 491cd4d5509dd2f6866a5aaa6184c68915eb9652
Author:     Matt Turner <mattst88@gentoo.org>
AuthorDate: 2019-03-03 22:34:37 +0000
Commit:     Matt Turner <mattst88@gentoo.org>
CommitDate: 2019-05-15 18:51:14 +0000

    x11-apps/xinit: Version bump to 1.4.1
    
    Use a patch from Debian to resolve bug 379441.
    
    Closes: https://bugs.gentoo.org/379441
    Signed-off-by: Matt Turner <mattst88@gentoo.org>

 x11-apps/xinit/Manifest                            |  1 +
 .../xinit-1.4.1-move-serverauthfile-into-tmp.patch | 22 +++++++
 x11-apps/xinit/xinit-1.4.1.ebuild                  | 76 ++++++++++++++++++++++
 3 files changed, 99 insertions(+)