Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 379177 - dev-tex/pdftex-1.40.10 ttf2afm.c:(.text+0x35e1): undefined reference to `kpse_set_progname'
Summary: dev-tex/pdftex-1.40.10 ttf2afm.c:(.text+0x35e1): undefined reference to `kpse...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: x86 Linux
: Normal normal with 1 vote (vote)
Assignee: TeX project
URL: http://tim32.org/~muzer/build.log
Whiteboard:
Keywords:
Depends on:
Blocks: old-mask
  Show dependency tree
 
Reported: 2011-08-14 16:19 UTC by Murray Colpman
Modified: 2015-03-17 11:15 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (build.log,99.24 KB, text/plain)
2011-08-15 10:43 UTC, François Valenduc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Murray Colpman 2011-08-14 16:19:35 UTC
After a reasonable period of disuse, I updated my system. I got through the update with a few minor problems, but when trying to run revdep-rebuild, pdftex is chosen to be rebuilt. However, it receives that error every time. I've tried re-emerging kpathsea, checking to ensure there are no updates, and various other things.

Reproducible: Always

Steps to Reproduce:
1. Try to compile pdftex via emerge -av pdftex, or through revdep-rebuild, or however
2. 
3. 
Actual Results:  
Errors (build log attached).

Expected Results:  
No errors; the application compiles successfully.
Comment 1 Murray Colpman 2011-08-14 16:28:32 UTC
Sorry, I can't attach the build log, because KDE is lying in pieces around me, and attempting to open a file dialogue causes my browser to crash and burn (hopefully a good old-fashioned reboot will fix that, but I'm too scared to do so until I can get revdep-rebuild to run, and that won't work while this bug still exists, so it's a bit of a problem). So, I'll just post the build log as a web attachment.


emerge --info =dev-tex/pdftex-1.40.10 :

Portage 2.1.10.11 (default/linux/x86/10.0/desktop/kde, gcc-4.4.5, glibc-2.12.2-r0, 2.6.36-gentoo-r5 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.36-gentoo-r5-i686-Intel-R-_Core-TM-2_Duo_CPU_E7300_@_2.66GHz-with-gentoo-2.0.3
Timestamp of tree: Sun, 14 Aug 2011 14:15:01 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
ccache version 2.4 [disabled]
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.1.3-r1
dev-util/ccache:          2.4-r9
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.4.5
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo kde-sunset kde sunrise roslin multimedia muzerlocal
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.1 PUEL skype-eula dlj-1.1"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe -fomit-frame-pointer -msse4.1"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=core2 -pipe -fomit-frame-pointer -msse4.1"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.qubenet.net/mirror/gentoo/ http://mirrors.linuxant.fr/distfiles.gentoo.org/ ftp://mirror.leaseweb.com/gentoo/ ftp://212.219.56.139/sites/www.ibiblio.org/gentoo/ http://91.121.125.139/gentoo-distfiles/"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_GB"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/kde-sunset /var/lib/layman/kde /var/lib/layman/sunrise /var/lib/layman/roslin /var/lib/layman/multimedia /usr/local/portage"
SYNC="rsync://rsync.uk.gentoo.org/gentoo-portage"
USE="X a52 aac aacs aalib acl acpi aim alsa amr audiofile bash-completion berkdb bluetooth bluray branding bzip2 cairo caps cdda cddb cdparanoia cdr chm clamdtop cli consolekit cracklib crypt css cups cxx dbus declarative dirac djvu doc dri dts dv dvb dvd dvdr dvi ebook emboss encode epos epydoc examples exif expat extensions extras fam fat festival ffmpeg firefox flac flite fluidsynth fontconfig foomaticdb fortran freetts ftp fuse gdbm gdu geoip ggi gif gimp git glut gme gmp gnutls google-gadgets gpm grammar gsm gstreamer gtk gzip handbook hddtemp iconv icotools icq id3tag ieee1394 imagemagick imap ipv6 jabber jadetex java javascript jingle joystick jpeg jsapi kate kde kerberos kipi ladspa lame lcms ldap libass libcaca libdsk libmodplug libnotify libsamplerate libv4l libv4l2 live lm_sensors lzo mad math matroska mbrola melt memlimit midi mikmod mime mmx mng modplug modules mono moonlight mp3 mp4 mpeg mplayer msn mudflap multimedia musepack musicbrainz ncurses nls nocd nptl nptlonly nsplugin ntfs nut offensive ogg openal opengl openmp openxml optimization pam pango pcre pda pdf perl phonon plasma plugins png policykit ppds pppd private-headers projectm pulseaudio python qt3support qt4 qthelp quicktime radio rdesktop readline reiser4 reiserfs reports rss samba sasl scanner schroedinger sdl sdl-image sdl-sound semantic-desktop server session shorten skype smp sndfile soundtouch sox speex spell sqlite sse sse2 ssl ssse3 startup-notification static-libs stream subversion svg sysfs t1lib taglib tcpd theora thesaurus threads thumbnail tiff timidity tk truetype twolame udev unicode usb utils v4l v4l2 vcd vdpau video videos vnc vorbis wavpack webkit wifi win32codecs winbind winetools wmf wordperfect wxwidgets x264 x86 xanim xattr xcb xcomposite xface xine xinerama xml xorg xrandr xscreensaver xulrunner xv xvid yahoo zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="samsung canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

dev-tex/pdftex-1.40.10 was built with the following:
USE=""





---------------------



emerge -pqv =dev-tex/pdftex-1.40.10 :

[ebuild   R   ] dev-tex/pdftex-1.40.10
Comment 2 François Valenduc 2011-08-15 10:43:42 UTC
Created attachment 283403 [details]
Build log

I can confirm the bug. pdftex has to be recompiled after an upgrade of poppler to version 0.16.7. You can find the whole build log in  the attachment.
Comment 3 Jesper Saxtorph 2011-08-15 11:15:52 UTC
Ran into the same problem on amd64 arch.

Tried to reinstall kpathsea, but it made no difference.

Added accept_keyword for dev-tex/pdftex-1.40.11
1.40.11 installed fine.

Some notes for Murray:

If your revdep-rebuild fail on a package, you can continue with the rest of the packages with: emerge --resume --skip-first
You can also have the same effect by given the option --keep-going to emerge like this:
revdep-rebuild -- --keep-going

If you have rebuild the rest of the system (using the option above or the like), you should be safe to reboot. On my system the only dependency on pdftex was ufo-ai, so I suspect that you do not have any essential dependencies on pdftex. You can check with:
equery depends pdftex
Comment 4 Paul Jewell 2011-08-19 21:14:54 UTC
I have spent a bit of time looking into this bug. It looks like the function name has changed from kpse_setprogname() to kpse_set_program_name(), and the number of variables changed from one to two. However, there is some tangle magic going on during the make phase, and a simple change of the names (with a null string parameter appended) didn't produce results. 

What I did identify is that texlive includes pdftex, so it shouldn't be necessary to have this package separately installed if you have texlive. I have, so I removed the package, and pdftex is still present from texlive.
Comment 5 Ulrich Müller gentoo-dev 2014-11-01 23:42:52 UTC
dev-tex/pdftex is in package.mask since a long time:

# Alexis Ballier <aballier@gentoo.org> (20 Aug 2011)
# dev-tex/pdftex-1.40.11 is 100% identical to the one in TeX Live 2010;
# TeX Live 2011 has a newer version, which makes the standalone package useless;
# mask it for now, we'll see about removing it later.
dev-tex/pdftex

Was there any new release of the standalone version in the mean time (HOMEPAGE still refers to 1.40.10)? If not, maybe it is time to remove this package?

CCing QA, because cleaning up old package.mask entries is on our agenda.
Comment 6 Pacho Ramos gentoo-dev 2014-12-01 10:39:31 UTC
CCing treecleaners then
Comment 7 Alexis Ballier gentoo-dev 2015-03-17 11:15:38 UTC
removed; use the pdftex provided by texlive-core