Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 378987 - vim.eclass's unmatched useflags of perl and libperl message is outdated
Summary: vim.eclass's unmatched useflags of perl and libperl message is outdated
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Vim Maintainers
: 423137 (view as bug list)
Depends on:
Reported: 2011-08-12 21:56 UTC by Marco Napetti
Modified: 2014-01-25 21:08 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

Error log (build.log,31.72 KB, text/plain)
2011-08-13 03:09 UTC, Roby

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Napetti 2011-08-12 21:56:29 UTC
This is similar to old bug

I have sys-devel/libperl-5.10.1 installed and this ebuild has no USE flags.
To find an ebuild with USE flags I have to downgrade to sys-devel/libperl-5.8.8-r2

emerge --info
Portage (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.13-r4, 3.0.0-gentoo x86_64)
System uname: Linux-3.0.0-gentoo-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5600+-with-gentoo-2.0.3
Timestamp of tree: Fri, 12 Aug 2011 09:00:01 +0000
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.2-r2
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1
sys-devel/gcc:            4.4.6, 4.5.3
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.38 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA skype-eula dlj-1.1 PUEL AdobeFlash-10.1"
CFLAGS="-march=native -pipe -O2"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -pipe -O2"
FEATURES="assume-digests binpkg-logs candy distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow 3dnowext X a52 aac aalib acl addbookmarks alias alsa amd64 amr amuled apache2 audiofile autoreplace avi bash-completion berkdb bluetooth boost branding browserplugin bzip2 cdaudio cdb cdda cddb cdinstall cdio cdparanoia cdr cleartype cli clucene codecs connectionstatus contactnotes cpudetection cracklib crypt css ctype cups curl custom-optimization cxx dbus decibel dga divx4linux dlloader dri dts dv dvb dvd dvdr dvdread dxr3 edl emul-linux-x86 encode exif extensions faad fam fame ffmpeg filter firefox flac fontconfig fortran ftp gadu gcj gd gdbm ggi gif gimp gimpprint git glib glitz gnutls gpm groupwise gstreamer highlight history hou iconv idn ieee1394 imagemagick imap imlib inquisitio insecure-drivers ipv6 irc ithreads jack java javascript jingle jpeg jpeg2k kde lame lcd lcdfilter libcaca libnotify live lm_sensors lzo mad matroska messenger mikmod mime mjpeg mmx mmxext modules monkey moodbar mozbranding mozdevelop mozilla mp3 mp4 mpeg msn msword mudflap multilib musepack musicbrainz mysql mysqli mythtv ncurses nepomuk netmeeting nls nodrm nowin nowlistening nptl nptlonly nsplugin objc objc++ objc-gc offensive ogg oggvorbis opengl openmp pam pcre pdf perl phonon php plasma png ppds pppd python qt qt-copy qt3support qt4 quicktime rar rdesktop readline remote replytolist samba sametime scanner sdl semantic-desktop sensord session slp smp sms sndfile sou sound speex sqlite sse sse2 ssl startup-notification statistics subversion svg sysfs taglib tcpd telepathy texteffect tga theora threads tidy tiff tokenizer translator truetype truetype-fonts udev unicode upnp usb v4l v4l2 vcd video videos visualization vnc vorbis wavpack webdav webpresence wifi winpopup wlm xanim xattr xcb xcomposite xine xinerama xml xmlpatterns xmlreader xmlwriter xorg xscreensaver xv xvid xvmc yahoo zip zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DVB_CARDS="tda10046" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" LIRC_DEVICES="livedrive_midi" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" SANE_BACKENDS="epson2" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 

Reproducible: Always
Comment 1 Rafał Mużyło 2011-08-12 23:46:34 UTC
[ebuild   R    ] sys-devel/libperl-5.10.1  0 kB
[ebuild   R   ~] dev-lang/perl-5.12.4-r1  USE="berkdb doc gdbm ithreads -build -debug" 0 kB
[ebuild   R   ~] app-editors/vim-7.3.219  USE="X acl bash-completion cscope gpm nls perl python ruby vim-pager -debug -minimal" 0 kB

From this "report" it's hard to tell what your problem is, but somehow I suspect it's INVALID.
Comment 2 Roby 2011-08-13 03:09:35 UTC
Created attachment 283099 [details]
Error log

Exactly the same error as the original poster's. I think the error message can be very misleading.
Comment 3 Rafał Mużyło 2011-08-13 03:52:46 UTC
(In reply to comment #2)
> Exactly the same error as the original poster's. I think the error message can
> be very misleading.

How do you know ?
Any psi powers you posses ?

Seriously though, if that's the message, there's already a bug about it.

IIRC, perl-5.12.4-r1, followed by rebuild of ExtUtils-ParseXS should help a bit there.
Comment 4 Torsten Veller (RETIRED) gentoo-dev 2011-08-13 04:25:54 UTC

eerror "If the above messages seem to be talking about perl"
eerror "and undefined references, please try re-emerging both"
eerror "perl and libperl with the same USE flags. For more"
eerror "information, see:"
eerror ""

This is only problem of <dev-lang/perl-5.10. Since 5.10 libperl and perl are installed by dev-lang/perl. You can drop this message.

Marco, if your problem is the "Undefined subroutine &ExtUtils::ParseXS::errors called at..." then go to bug #378107.
Comment 5 Tim Harder gentoo-dev 2014-01-25 20:59:56 UTC
The eclass isn't used for recent versions anymore and the message isn't in newer ebuilds.
Comment 6 Tim Harder gentoo-dev 2014-01-25 21:08:18 UTC
*** Bug 423137 has been marked as a duplicate of this bug. ***