Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 378837 - games-puzzle/crayon - new ebuild for Crayon Physics Deluxe: a 2D physics puzzle
Summary: games-puzzle/crayon - new ebuild for Crayon Physics Deluxe: a 2D physics puzzle
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: All Linux
: Normal enhancement with 4 votes (vote)
Assignee: Gentoo Games
URL: http://www.crayonphysics.com
Whiteboard:
Keywords: EBUILD
: 379901 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-08-11 21:28 UTC by Zorzo Luca
Modified: 2013-03-21 22:03 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
crayon-55.3.ebuild - Main ebuild (crayon-55.3.ebuild,2.12 KB, text/plain)
2011-08-11 21:29 UTC, Zorzo Luca
Details
License file (crayon,589 bytes, text/plain)
2011-08-11 21:30 UTC, Zorzo Luca
Details
games-puzzle/crayon-55.ebuild (crayon-55.ebuild,2.31 KB, text/plain)
2012-06-01 04:26 UTC, Jared B.
Details
games-puzzle/crayon-55.ebuild (crayon-55.ebuild,2.35 KB, text/plain)
2013-03-10 17:22 UTC, Jared B.
Details
games-puzzle/crayon-physics-deluxe-55.ebuild (crayon-physics-deluxe-55.ebuild,2.05 KB, text/plain)
2013-03-18 00:32 UTC, Jared B.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zorzo Luca 2011-08-11 21:28:34 UTC
Crayon Physics Deluxe is a 2D physics puzzle / sandbox game, in which you get to experience what it would be like if your drawings would be magically transformed into real physical objects. Solve puzzles with your artistic vision and creative use of physics. 

Reproducible: Always
Comment 1 Zorzo Luca 2011-08-11 21:29:40 UTC
Created attachment 282953 [details]
crayon-55.3.ebuild - Main ebuild
Comment 2 Zorzo Luca 2011-08-11 21:30:54 UTC
Created attachment 282955 [details]
License file
Comment 3 Wiehann Matthysen 2011-08-19 22:29:41 UTC
*** Bug 379901 has been marked as a duplicate of this bug. ***
Comment 4 Reinis Danne 2012-01-02 18:41:25 UTC
In HIB#4 the tarball is named differently: crayon-physics-deluxe_55_i386.tar.gz
Renamed it and ebuild worked. To run it needed to install libGLEW.so.1.5:
doexe "lib32/libGLEW.so.1.5" || die "doexe libs failed"

Portage 2.1.10.44 (default/linux/amd64/10.0/desktop/gnome, gcc-4.6.2, glibc-2.14.1-r2, 3.1.6-gentoo x86_64)
=================================================================
System uname: Linux-3.1.6-gentoo-x86_64-Intel-R-_Core-TM-_i7-2630QM_CPU_@_2.00GHz-with-gentoo-2.1
Timestamp of tree: Mon, 02 Jan 2012 08:15:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.6.7-r2, 2.7.2-r3, 3.1.4-r3, 3.2.2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.7
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.10.3, 1.11.2
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2, 4.6.2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r2
Repositories: gentoo x11 science local
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS=""
FEATURES="assume-digests binpkg-logs compress-build-logs distlocks ebuild-locks fixlafiles news parallel-fetch parallel-install protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-march=native -O2 -pipe -ggdb"
GENTOO_MIRRORS="ftp://trumpetti.atm.tut.fi/gentoo/ http://trumpetti.atm.tut.fi/gentoo/ http://gentoo.tups.lv/source/ "
LANG="lv_LV.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="lv en"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/science /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 avx bash-completion berkdb bluetooth branding bzip2 cairo cdda cdio cdr cjk cleartype cli colord consolekit cracklib crypt cups cxx dbus dirac djvu dri dts dvd dvdr eds emboss encode evo exif fam ffmpeg fftw firefox flac fontconfig fortran gdbm gdu gif gnome gnome-keyring gnome-online-accounts gphoto2 gpm gsm gstreamer gtk gtk3 iconv idn ipv6 jpeg kate lcms ldap libcaca libnotify live mad matroska mmx mng modules mp3 mp4 mpeg mtp mudflap multilib musepack nautilus ncurses networkmanager nls nptl nptlonly ogg openexr opengl openmp pam pango pcre pdf png policykit ppds pppd pulseaudio qt3support qt4 raw readline schroedinger sdl session smp socialweb speex spell sse sse2 sse4_1 ssl ssse3 startup-notification svg sysfs system-sqlite tcpd theora tiff truetype udev unicode usb v4l v4l2 vaapi vorbis wmf x264 xcb xetex xml xmp xorg xpm xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" FOO2ZJS_DEVICES="hp1018" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="lv en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev nvidia i965 intel vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 5 Jared B. 2012-06-01 04:26:37 UTC
Created attachment 313785 [details]
games-puzzle/crayon-55.ebuild

Attaching updated ebuild with three changes:

* Updated to new filename in SRC_URI, since any new downloads will use this name
* Includes libGLEW,so,1,5 as recommended by My
* Includes amd64 support (which required adding some emulation library dependencies)
Comment 6 Jared B. 2013-03-10 17:22:30 UTC
Created attachment 341572 [details]
games-puzzle/crayon-55.ebuild

small dep update to handle the QT category move
Comment 7 Jared B. 2013-03-18 00:32:23 UTC
Created attachment 342440 [details]
games-puzzle/crayon-physics-deluxe-55.ebuild

One more update.  This most noticeable changes the package names to "crayon-physics-deluxe", which I feel is more appropriate as that's the actual name of the application.  I also made a few other tweaks:

* Uses latest release of the game provided by HIB; same underlying version, but rebuilt to address a couple Linux issues.  Also uses a different package name.
* Updated dependencies - all of the x86 stuff is now under x86?()
* Removed bundled libs - libglew no longer appears to be required, and the game seems to work perfectly fine with the libstdc+++ included with GCC 4.6.3.  If this is indeed required for some users I'll be happy to add it back.
Comment 8 Julian Ospald 2013-03-21 22:03:45 UTC
+*crayon-physics-55 (21 Mar 2013)
+
+  21 Mar 2013; Julian Ospald <hasufell@gentoo.org> +crayon-physics-55.ebuild,
+  +metadata.xml:
+  initial import wrt #378837