Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 378753 - Please stabilize =dev-util/qt-creator-2.3.1
Summary: Please stabilize =dev-util/qt-creator-2.3.1
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: qt-4.7.4-stable
Blocks:
  Show dependency tree
 
Reported: 2011-08-11 10:57 UTC by Markos Chandras (RETIRED)
Modified: 2012-03-18 14:37 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Documenation page not found (Unix_Test9.jpeg,90.61 KB, image/jpeg)
2011-08-13 04:51 UTC, Elijah "Armageddon" El Lazkani (amd64 AT)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markos Chandras (RETIRED) gentoo-dev 2011-08-11 10:57:25 UTC
Please stabilize =dev-util/qt-creator-2.2.1.

Thank you
Comment 1 Agostino Sarubbo gentoo-dev 2011-08-11 15:27:45 UTC
amd64 ok.
Comment 2 Elijah "Armageddon" El Lazkani (amd64 AT) 2011-08-11 23:40:14 UTC
amd64 works, but documentation pages online seem to have changed links. Displaying "The page could not be found"
Comment 3 Elijah "Armageddon" El Lazkani (amd64 AT) 2011-08-13 04:51:41 UTC
Created attachment 283101 [details]
Documenation page not found

I've been asked about the issue I mentioned earlier so I'll explain more.

On the welcome screen of qt-creator if you click on one of the tutorial, let's say "The Qt Creator User Interface" then in the "Qt Reference Documentation" under "API Lookup" we click on "Class index" we will get the following page.

qt-creator was built with all USE flags enabled.
Comment 4 Markos Chandras (RETIRED) gentoo-dev 2011-08-13 08:50:24 UTC
I don't understand how to reproduce it. Anyway, ignoring the said issue, the documentation works as expected (offline and online). This does not block the stabilization. And like I said many times, please avoid flooding stabilization bugs with bug reports. Open separate bugs instead ( not in this case, the patch has to be reported upstream )
Comment 5 Ian Delaney (RETIRED) gentoo-dev 2011-08-16 13:50:13 UTC
Markos relax,

I followed his path.  The Trolltech site apprears to be not up to date.
Could well be due to qt no longer owned by Trolltech or some such.  So I have to disagree with your finding that the docs working on-line.   See 

http://doc.trolltech.com/qtcreator-2.2/classes.html

Then I suspect you don't care.  It's totally trivial.

So far no other issues
Comment 6 Markos Chandras (RETIRED) gentoo-dev 2011-08-17 15:58:40 UTC
(In reply to comment #5)
> Markos relax,
I am relaxed. amd64 done. Thank you all
Comment 7 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2011-08-21 03:36:51 UTC
x86 stable
Comment 8 Davide Pesavento gentoo-dev 2011-11-13 15:33:02 UTC
Markos, we could move to 2.3.1 and skip stabilization of 2.2.1 for ppc{,64}... what do you think?
Comment 9 Markos Chandras (RETIRED) gentoo-dev 2011-11-13 16:38:18 UTC
Yeah makes sense

Arches, please test and stabilize
=dev-util/qt-creator-2.3.1

Ta
Comment 10 Agostino Sarubbo gentoo-dev 2011-11-13 19:24:10 UTC
it needs qt-4.7.4
Comment 11 Markos Chandras (RETIRED) gentoo-dev 2011-11-13 19:26:19 UTC
@Qt. Is 4.7.4 ready to go stable?

Removing arches for now. Sorry guys
Comment 12 Davide Pesavento gentoo-dev 2011-11-18 23:08:50 UTC
(In reply to comment #11)
> @Qt. Is 4.7.4 ready to go stable?
> 
> Removing arches for now. Sorry guys

bug #390963
Comment 13 Agostino Sarubbo gentoo-dev 2011-12-21 00:25:00 UTC
Re-adding arches since qt-4.7.4 is ready to go stable.

Arches, please test and mark stable:
=dev-util/qt-creator-2.3.1
Target keywords : "amd64 ppc ppc64 x86"
Comment 14 Agostino Sarubbo gentoo-dev 2011-12-22 12:16:30 UTC
amd64 stable
Comment 15 Markus Meier gentoo-dev 2011-12-27 21:45:14 UTC
x86 stable
Comment 16 Davide Pesavento gentoo-dev 2012-03-18 14:37:45 UTC
ppc & ppc64, you can skip this one and proceed to stabilize 2.4.1 directly in bug #408711. Thanks.