Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 378197 - media-gfx/graphicsmagick-1.3.12-r1 - .../xsubpp -typemap /usr/lib64/perl5/5.12.4/ExtUtils/typemap Magick.xs > Magick.xsc && mv Magick.xsc Magick.c Could not find a typemap for C type 'Graphics::Magick' in Magick.xs, line 2085
Summary: media-gfx/graphicsmagick-1.3.12-r1 - .../xsubpp -typemap /usr/lib64/perl5/5....
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ExtUtils-ParseXS-3
  Show dependency tree
 
Reported: 2011-08-08 08:31 UTC by Juergen Rose
Modified: 2012-06-17 19:36 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/tmp/portage/media-gfx/graphicsmagick-1.3.12-r1/temp/build.log (build.log,474.62 KB, text/plain)
2011-08-08 08:36 UTC, Juergen Rose
Details
buildlog from failed build with with ExtUtils-ParseXS-3.150.0 (build.log,355.22 KB, text/plain)
2012-06-17 19:03 UTC, Leo Laursen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2011-08-08 08:31:27 UTC
'emerge graphicsmagick' fails with:
...
libtool: link: x86_64-pc-linux-gnu-gcc -std=gnu99 -fopenmp -O2 -march=k8 -Wall -pthread -Wl,-O1 -Wl,--as-needed -Wl,-O1 -Wl,--as-needed -o utilities/.libs/gm utilities/gm.o  -L/usr/lib magick/.libs/libGraphicsMagick.so -L/usr/lib64 -llcms -lfreetype -lXext /usr/lib64/libSM.so -luuid /usr/lib64/libICE.so -lX11 -lbz2 -lz -lm /usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/libgomp.so -lrt -lpthread /usr/lib64/libltdl.so -ldl -pthread
make[1]: Leaving directory `/var/tmp/portage/media-gfx/graphicsmagick-1.3.12-r1/work/GraphicsMagick-1.3.12'
make -j1 perl-build 
Makefile:11334: warning: overriding recipe for target `PerlMagick/Magick.pm'
Makefile:5375: warning: ignoring old recipe for target `PerlMagick/Magick.pm'
cd PerlMagick && /usr/bin/perl Makefile.PL INSTALLDIRS=vendor
Checking if your kit is complete...
Looks good
Unrecognized argument in LIBS ignored: '-Wl,-O1'
Unrecognized argument in LIBS ignored: '-Wl,--as-needed'
Note (probably harmless): No library found for -lgomp
Writing Makefile for Graphics::Magick
Writing MYMETA.yml and MYMETA.json
( cd PerlMagick && make CC='x86_64-pc-linux-gnu-gcc -std=gnu99' )
make[1]: Entering directory `/var/tmp/portage/media-gfx/graphicsmagick-1.3.12-r1/work/GraphicsMagick-1.3.12/PerlMagick'
cp Magick.pm blib/lib/Graphics/Magick.pm
AutoSplitting blib/lib/Graphics/Magick.pm (blib/lib/auto/Graphics/Magick)
/usr/bin/perl5.12.4 /usr/lib64/perl5/vendor_perl/5.12.4/ExtUtils/xsubpp  -typemap /usr/lib64/perl5/5.12.4/ExtUtils/typemap  Magick.xs > Magick.xsc && mv Magick.xsc Magick.c
Could not find a typemap for C type 'Graphics::Magick' in Magick.xs, line 2085
make[1]: *** [Magick.c] Error 1
Comment 1 Juergen Rose 2011-08-08 08:32:15 UTC
root@grizzly:/root(33)# emerge --info =media-gfx/graphicsmagick-1.3.12-r1
Portage 2.1.10.10 (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.13-r4, 2.6.39-gentoo-r3 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.39-gentoo-r3-x86_64-AMD_Athlon-tm-_64_Processor_3200+-with-gentoo-2.0.3
Timestamp of tree: Mon, 08 Aug 2011 02:00:01 +0000
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r2, 3.2-r2
dev-util/cmake:           2.8.5-r2::science
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1
sys-devel/gcc:            4.5.3
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.38 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo java-overlay lordvan science x11 sunrise arcon local x-cpan g-octave
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 skype-eula googleearth AdobeFlash-10.1 cadsoft"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=k8"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.0/conf /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.2/ext-active/ /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.2/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.2/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=k8"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=k8"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://ftp.tu-clausthal.de/pub/linux/gentoo ftp://ftp.easynet.nl/mirror/gentoo/ "
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de fr"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages/"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/java-overlay /var/lib/layman/lordvan /var/lib/layman/science /var/lib/layman/x11 /var/lib/layman/sunrise /var/lib/layman/arcon /usr/local/portage /var/lib/cpan /var/lib/g-octave"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 64bit R X Xaw3d a52 aac abiword acl acpi admin afs alsa amd64 ao apache2 applet archive arpack asf aspell assistant audacious audiofile automap automount bash-completion beagle berkdb blas blast bluetooth boo boost branding bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cgi chm cli consolekit corba cracklib crypt css cups curl cxx daap db dbase dbi dbm dbus declarative designer devhelp device-mapper dga dia djvu doc dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds elf emacs emboss emf encode epiphany evo examples exif expat extensions extra extras fam fame ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpx fts3 fuse galago garmin gd gdal gdbm gdu gedit geoip geolocation geos gfortran gif gimp ginac git glade glib gml gmp gmtsuppl gnome gnome-keyring gnome-print gnuplot gnutls gphoto2 gpm grammar graphics graphtft graphviz grass gs gsl gsm gstreamer gtk gudev guile harness hddtemp hdf hdf5 hdri http httpd hwdb iconv icq icu id3 ide imagemagick imap innodb inotify ipod ipv6 irda ithreads jabber jadetex java java6 jbig john jpeg jpeg2k kde kdrive kerberos kpathsea ladspa lame lapack latex latex3 lcms ldap lensfun libffi libgda libnotify libsamplerate lirc lm_sensors lua lzo mad mail maildir mapnik math matroska mkl mmx mmxext mng modules mono moonlight motif mozilla mp3 mp4 mpeg mpi mplayer mtp mudflap multilib musicbrainz mysql mysqli nautilus ncurses neXt netcdf netpbm network networking networkmanager nfs nls nntp nptl nptlonly nsplugin ntfs ntp numpy obex objc ocaml octave odbc ogdi ogg ole openexr opengl openmp overview pae pam pango pcre pda pdf perl plotutils plugins png podcast policykit portaudio posix postgres postscript ppds pppd preview-latex proj projectx pstricks pulseaudio python python-bindings q16 q32 qemu qhull qt3support qt4 quicktime readline reiserfs reports rle romio rpc rrdcgi rrdtool samba sasl science sdk sdl secure-delete semantic-desktop server session sip slang slp smbclient sms sndfile snmp soup sox speex spell sql sqlite sse sse2 ssl startup-notification stlport subtitles subversion suexec svg svm swig sysfs szip t1lib tcl tcpd tex tex4ht texmacs tgif theora threads thunderbird tidy tiff tk tntc tools truetype udev unicode usb userlocales utempter v4l2 video virtualbox vorbis wav webdav webdav-serf webkit wmf wxwidgets x264 xattr xcb xemacs xext xine xml xmlreader xmlrpc xorg xpm xulrunner xv xvid xvmc yaml zlib zvbi" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DVB_CARDS="tda10046 saa7134" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de fr" LIRC_DEVICES="hauppauge_dvb" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler ruby websvccommon xml" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386 ppc ppc64 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



root@grizzly:/root(34)# emerge -pqv =media-gfx/graphicsmagick-1.3.12-r1
[ebuild     U ] media-gfx/graphicsmagick-1.3.12-r1 [1.3.12] USE="X bzip2 cxx doc fpx jbig jpeg jpeg2k lcms modules openmp perl png q16 q32 svg threads tiff truetype wmf zlib -debug -imagemagick"
Comment 2 Juergen Rose 2011-08-08 08:36:02 UTC
Created attachment 282535 [details]
/var/tmp/portage/media-gfx/graphicsmagick-1.3.12-r1/temp/build.log
Comment 3 Ivan Iraci 2011-08-08 08:39:26 UTC
Same here.
Comment 4 Giuseppe Vitillaro 2011-08-08 09:00:26 UTC
Identical problem here:

AutoSplitting blib/lib/Graphics/Magick.pm (blib/lib/auto/Graphics/Magick)
Could not find a typemap for C type 'Graphics::Magick' in Magick.xs, line 2085
make[1]: *** [Magick.c] Error 1

Tried to reemrge 1.3.12, masking 1.3.12-r1: again the same problem. but graphicsmagick-1.3.12 was compiled and installed correctly on my machine on June 26:

gm version
GraphicsMagick 1.3.12 2010-03-08 Q8 http://www.GraphicsMagick.org/

Hope it helps.
Comment 5 Roby 2011-08-08 12:05:24 UTC
I can confirm this. Workaround: Compile with USE="-perl".
Comment 6 Rafał Mużyło 2011-08-08 15:12:16 UTC
There might be something odd going on here.
See the forum thread bug 378131 refers to - it's about imagemagick, but the error there seems to be:
Could not find a typemap for C type 'Image::Magick' in Magick.xs, line 2404

It might be coincidence, still were there any significant perl changes on the affected machine(s) ?
Comment 7 Reinis Danne 2011-08-09 10:23:05 UTC
The problem is in perl-ExtUtils-ParseXS-3.20.0, downgrading it to 2.22.06 solves the issue.
Comment 8 Giuseppe Vitillaro 2011-08-09 10:50:31 UTC
(In reply to comment #7)
> The problem is in perl-ExtUtils-ParseXS-3.20.0, downgrading it to 2.22.06
> solves the issue.

Yep. I masked 3.20.0 and now I'm able to update graphicsmagick. It compiled and installed correctly.

Enough to temporary mask 3.20.0? Can't be cause of further troubles in the future?
Comment 9 Reinis Danne 2011-08-09 11:26:25 UTC
(In reply to comment #8)
> Enough to temporary mask 3.20.0? Can't be cause of further troubles in the
> future?

No idea, I think it is fine for now. It probably depends on how exactly 3.20.0 breaks. But right now it affects the builds of:
media-gfx/graphicsmagick
media-gfx/imagemagick
app-editors/vim
Comment 10 Alexandre Rostovtsev (RETIRED) gentoo-dev 2011-08-09 22:21:03 UTC
Upstream bug report: https://rt.cpan.org/Public/Bug/Display.html?id=70150
Comment 11 Todd Rinaldo 2011-08-10 22:17:22 UTC
(In reply to comment #10)
> Upstream bug report: https://rt.cpan.org/Public/Bug/Display.html?id=70150

I got Steffen to look at it and it turned out to be a bug in Image::Magick. They weren't supplying a typemap file. 
https://rt.cpan.org/Public/Bug/Display.html?id=70188

I reported the RT directly to them today. A test fix for it exists on CPAN as 6.71-1

http://search.cpan.org/~jcristy/PerlMagick-6.71-1/
Comment 12 PetaMem R&D 2011-08-17 15:12:23 UTC
 * The following 2 packages have failed to build or install:
 * 
 *  (dev-db/postgresql-server-9.0.4-r2::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-db/postgresql-server-9.0.4-r2/temp/build.log'
 *  (app-editors/vim-7.3.266::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/app-editors/vim-7.3.266/temp/build.log'


I was about to add a new bug, but it boils down to the same problem root:


"/usr/bin/perl" /usr/lib64/perl5/5.12.4/ExtUtils/xsubpp -typemap /usr/lib64/perl5/5.12.4/ExtUtils/typemap SPI.xs >SPI.c
Undefined subroutine &ExtUtils::ParseXS::errors called at /usr/lib64/perl5/5.12.4/ExtUtils/xsubpp line 41.

It all occurs, because there are two versions of ExtUtils::ParseXS

/usr/lib64/perl5/vendor_perl/5.12.4/ExtUtils/ParseXS.pm
/usr/lib64/perl5/5.12.4/ExtUtils/ParseXS.pm


The one in vendor_perl is a 3.xx and the one in 5.12.4 is a 2.xx

# equery b /usr/lib64/perl5/vendor_perl/5.12.4/ExtUtils/ParseXS.pm
 * Searching for /usr/lib64/perl5/vendor_perl/5.12.4/ExtUtils/ParseXS.pm ... 
perl-core/ExtUtils-ParseXS-3.20.0 (/usr/lib64/perl5/vendor_perl/5.12.4/ExtUtils/ParseXS.pm)

# equery b /usr/lib64/perl5/5.12.4/ExtUtils/ParseXS.pm
 * Searching for /usr/lib64/perl5/5.12.4/ExtUtils/ParseXS.pm ... 
dev-lang/perl-5.12.4-r1 (/usr/lib64/perl5/5.12.4/ExtUtils/ParseXS.pm)

as does also

equery b /usr/lib64/perl5/5.12.4/ExtUtils/xsubpp
 * Searching for /usr/lib64/perl5/5.12.4/ExtUtils/xsubpp ... 
dev-lang/perl-5.12.4-r1 (/usr/lib64/perl5/5.12.4/ExtUtils/xsubpp)

xsubpp wants the 2.xx version, but hits the 3.xx module 1st


=> boom

Unmasking the 3.xx ExtUtils will probably help. But the p5p should be informed about this.

One glitch in Gentoo - IMHO - is that virtual/perl-ExtUtils-ParseXS
requires perl-core/ExtUtils-ParseXS, where it should be possible to satisfy it with dev-lang/perl
Comment 13 Kent Fredric (IRC: kent\n) (RETIRED) gentoo-dev 2011-08-18 12:14:47 UTC
(In reply to comment #12)

As far as I can tell, your bug is a different one, this bug is about missing typemap entries, yours is about missing methods. 

Bug #378897 seems to be what you are looking for.
Comment 14 PetaMem R&D 2011-08-18 12:21:17 UTC
nevertheless, the root cause (different versions of a Perl module) is the same.
Comment 15 PetaMem R&D 2011-08-18 12:23:06 UTC
and yes, the analysis in 378865 comes to the same conclusion.
Comment 16 Dennis Schridde 2011-08-29 09:49:41 UTC
It seems fixed here now.
Comment 17 Samuli Suominen gentoo-dev 2011-12-28 21:05:01 UTC
not seeing this problem with graphicsmagick-1.3.13 -> closing
Comment 18 Leo Laursen 2012-06-17 07:56:11 UTC
(In reply to comment #17)
> not seeing this problem with graphicsmagick-1.3.13 -> closing

I still see the same error with all versions; graphicsmagick-1.3.{13,14,15}
Comment 19 Samuli Suominen gentoo-dev 2012-06-17 08:06:54 UTC
(In reply to comment #18)
> (In reply to comment #17)
> > not seeing this problem with graphicsmagick-1.3.13 -> closing
> 
> I still see the same error with all versions; graphicsmagick-1.3.{13,14,15}

I doubt that since it works fine here on every box.

I bet you upgraded to >=dev-lang/perl-5.16 and forgot to run `perl-cleaner --all` or `perl-cleaner --reallyall`
Comment 20 Leo Laursen 2012-06-17 11:32:33 UTC
(In reply to comment #19)
> (In reply to comment #18)
> > (In reply to comment #17)
> > > not seeing this problem with graphicsmagick-1.3.13 -> closing
> > 
> > I still see the same error with all versions; graphicsmagick-1.3.{13,14,15}
> 
> I doubt that since it works fine here on every box.
> 
> I bet you upgraded to >=dev-lang/perl-5.16 and forgot to run `perl-cleaner
> --all` or `perl-cleaner --reallyall`

That would be a convenient assumption, but unfortunately not correct.
Just to be on the safe side I ran perl-cleaner --reallyall just now, which reemerged 78 packages. Still all three versions fail with the same error. =media-gfx/graphicsmagick-1.3.15 is installed with USE="-perl" for now, since perl-cleaner tried (and failed) to install graphicsmagick every time.
Comment 21 Leo Laursen 2012-06-17 17:06:55 UTC
(In reply to comment #20)
It seems to be a problem with ExtUtils-ParseXS-3.150.0. I masked it (and the virtual), and reverted to ExtUtils-ParseXS-2.22.06. Now all seems fine.
Comment 22 Samuli Suominen gentoo-dev 2012-06-17 17:16:44 UTC
CC perl@ so they can take a look
Comment 23 Rafał Mużyło 2012-06-17 18:09:45 UTC
(In reply to comment #22)

Well, there's a catch here: ExtUtils-ParseXS-2.22.06 just doesn't work with perl 5.16 - the moment xsubpp runs, it just spits out a failure notice.

So, could you *perhaps* emerge ExtUtils-ParseXS-3.150.0, rebuild graphicsmagick and *if* it fails, attach build log ?
Comment 24 Torsten Veller (RETIRED) gentoo-dev 2012-06-17 19:00:51 UTC
Just copy the fix from imagemagick:
http://trac.imagemagick.org/browser/ImageMagick/trunk/PerlMagick/typemap?rev=4950

it compiles after creating the typemap file:
|echo "Graphics::Magick T_PTROBJ" > PerlMagick/typemap
Comment 25 Leo Laursen 2012-06-17 19:03:49 UTC
Created attachment 315619 [details]
buildlog from failed build with with ExtUtils-ParseXS-3.150.0

=dev-lang/perl-5.16.0 and =perl-core/ExtUtils-ParseXS-2.22.06 seems to work here.
Comment 26 Samuli Suominen gentoo-dev 2012-06-17 19:17:02 UTC
reproduced finally here too and applied the fix from comment #24 to tree, thanks tove

http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-gfx/graphicsmagick/graphicsmagick-1.3.15.ebuild?r1=1.3&r2=1.4
Comment 27 Leo Laursen 2012-06-17 19:36:28 UTC
(In reply to comment #26)
> reproduced finally here too and applied the fix from comment #24 to tree,
> thanks tove
> 
> http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-gfx/graphicsmagick/
> graphicsmagick-1.3.15.ebuild?r1=1.3&r2=1.4

Confirm that the fix works here. Nice :-)