Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 377925 - dev-python/docutils-0.[78]: TypeError: can't use a bytes pattern on a string-like object
Summary: dev-python/docutils-0.[78]: TypeError: can't use a bytes pattern on a string-...
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-05 21:50 UTC by Igor
Modified: 2013-05-13 08:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,314.02 KB, text/plain)
2011-08-05 21:50 UTC, Igor
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Igor 2011-08-05 21:50:16 UTC
Installation failed with CPython 3.1 in distutils_installation() function

Reproducible: Always

Steps to Reproduce:
emerge -av dev-python/docutils
Actual Results:  
* ERROR: dev-python/docutils-0.8_pre7038 failed (install phase):
 *   Installation failed with CPython 3.1 in distutils_installation() function
 * 
 * Call stack:
 *     ebuild.sh, line   56:  Called src_install
 *   environment, line 5132:  Called distutils_src_install
 *   environment, line 1326:  Called python_execute_function 'distutils_installation'
 *   environment, line 3491:  Called die
 * The specific snippet of code:
 *                       die "${failure_message}";


Expected Results:  
dev-python/docutils emerged.

# emerge --info =dev-python/docutils-0.8_pre7038
Portage 2.1.10.3 (default/linux/amd64/10.0/desktop, gcc-4.6.1, glibc-2.12.2-r0, 2.6.38.2-zen x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.38.2-zen-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5000+-with-gentoo-2.0.3
Timestamp of tree: Thu, 04 Aug 2011 22:45:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r2, 3.1.4-r2
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.21.1
sys-devel/gcc:            4.4.5, 4.6.1
sys-devel/gcc-config:     1.5-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo x-myoverlay sunrise perl-experimental bircoph
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="http://mirror.yandex.ru/gentoo-distfiles/ rsync://trumpetti.atm.tut.fi/gentoo/ http://mirrors.linuxant.fr/distfiles.gentoo.org/ http://mirror.opteamax.de/gentoo/"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/myoverlay /var/lib/layman/sunrise /var/lib/layman/perl-experimental /var/lib/layman/bircoph"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups curl cxx dbus device-mapper djvu doc dri dts dvd dvdr emacs emboss encode examples exif expat fam fast-cgi ffmpeg fftw firefox flac fontconfig gdbm gdu gif gnome-keyring gpm gsl gstreamer gtk iconv icu idn ipv6 jpeg kpathsea lapack latex lcms libnotify lm_sensors mad matroska mmx mng modules mono mp3 mp4 mpeg mplayer mudflap multilib ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt3support qt4 readline sdl session spell sse sse2 sse3 ssl startup-notification svg sysfs tcpd threads tiff truetype udev unicode usb v4l2 vim-syntax vorbis x264 xcb xetex xft xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Igor 2011-08-05 21:50:52 UTC
Created attachment 282249 [details]
build.log
Comment 2 Igor 2011-08-05 22:18:35 UTC
Same for dev-python/pygments-1.4
Comment 3 Igor 2011-08-05 23:16:18 UTC
Ok, updating dev-python/setuptools to 0.6.19 solves the issue.
Comment 4 Dirkjan Ochtman gentoo-dev 2011-10-07 11:44:44 UTC
So I guess we should restrict docutils to >=setuptools-0.6.19? Any thoughts from other python team members?
Comment 5 Arfrever Frehtes Taifersar Arahesis 2011-10-07 21:22:24 UTC
It was not a bug in dev-python/docutils, so no changes in dev-python/docutils should be made.
Older versions of dev-python/setuptools already block newer versions of dev-lang/python.
Comment 6 Dirkjan Ochtman gentoo-dev 2013-05-13 08:42:28 UTC
Looks like we don't have anything left to do here.