Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 377907 - sys-apps/portage: error messages for packages masked by not fulfilling @system requirements is insufficient
Summary: sys-apps/portage: error messages for packages masked by not fulfilling @syste...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Interface (emerge) (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL: http://archives.gentoo.org/gentoo-dev...
Whiteboard:
Keywords: InVCS
Depends on: 149536
Blocks: 373933
  Show dependency tree
 
Reported: 2011-08-05 19:22 UTC by Sebastian Luther (few)
Modified: 2011-08-12 12:55 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Luther (few) 2011-08-05 19:22:26 UTC
Tried that only with portage-2.1.4.4, where I hit it while I tried to install portage-2.1.6.7. The selected profile was a 10.0 profile which has >=2.1.6.8 in @system. On IRC dwfreed said it would be still the same with recent portage.

The error message was "masked by: profile" and p.unmask didn't help with unmasking it. Took me some time to find the cause. The error should simply be improved (and maybe the handling of such cases too).
Comment 1 Zac Medico gentoo-dev 2011-08-05 23:29:43 UTC
I think we should remove "masked by: profile" support since it's not even part of PMS (see section 5.2.7 where is says atoms without * only appear for "legacy reasons"), and profiles can use package.mask if they need to mask something.
Comment 2 Sebastian Luther (few) 2011-08-06 04:46:52 UTC
If this issue the only one that hides behind "masked by profile", removing it sounds reasonable.
Comment 4 Zac Medico gentoo-dev 2011-08-12 12:55:40 UTC
This is fixed in 2.1.10.11 and 2.2.0_alpha51.