Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 377687 - net-misc/iputils: should remove dependency on sys-fs/sysfsutils
Summary: net-misc/iputils: should remove dependency on sys-fs/sysfsutils
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 377673
  Show dependency tree
 
Reported: 2011-08-04 09:58 UTC by Anthony Basile
Modified: 2011-08-07 20:10 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anthony Basile gentoo-dev 2011-08-04 09:58:47 UTC
sys-fs/sysfsutils is broken and dead upstream.  Dependency on it needs to be
removed so we can remove it from the tree.


Reproducible: Always
Comment 1 Anthony Basile gentoo-dev 2011-08-05 17:17:42 UTC
Okay I looked at the code up to the latest snapshot at

  http://www.linux-ipv6.org/gitweb/gitweb.cgi?p=gitroot/iputils.git;a=summary

and arping.c still #include <sysfs/libsysfs.h>, and makes calls/references to sysfs_* in its set_device_broadcast() function.  Looks like we won't be able to drop this dep without some upstream patching.  On the positive side, it does look like the sysfs dependence is localized, and so maybe I can just lift and refresh that code out of libsysfs and submit a patch upstream.

BTW, git clone git://www.linux-ipv6.org/gitroot/iputils and hence iputils-99999999.ebuild is failing ... looks like they're having some (temporary?) problems with their git daemon.
Comment 2 Samuli Suominen gentoo-dev 2011-08-07 20:10:24 UTC
*iputils-20101006-r1 (07 Aug 2011)

  07 Aug 2011; Samuli Suominen <ssuominen@gentoo.org>
  +files/iputils-20071127-infiniband.patch, +iputils-20101006-r1.ebuild,
  iputils-99999999.ebuild:
  Import Fedora patch to remove sysfsutils depend from arping.c wrt #377687 by
  Anthony Basile