Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 377515 - app-editors/xemacs-21.4.22-r1 fails to emerge on hardened due to [xemacs.dmp] Segmentation fault
Summary: app-editors/xemacs-21.4.22-r1 fails to emerge on hardened due to [xemacs.dmp]...
Status: RESOLVED DUPLICATE of bug 75028
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: XEmacs team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-03 08:41 UTC by Juergen Rose
Modified: 2011-08-07 08:14 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/tmp/portage/app-editors/xemacs-21.4.22-r1/temp/build.log (build.log,90.86 KB, text/plain)
2011-08-03 08:43 UTC, Juergen Rose
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2011-08-03 08:41:03 UTC
'emerge xemacs' fails with:
...
Spawning make-docfile ...done
./xemacs -nd -batch -l /var/tmp/portage/app-editors/xemacs-21.4.22-r1/work/xemacs-21.4.22/src/../lisp/loadup.el dump

Loading /var/tmp/portage/app-editors/xemacs-21.4.22-r1/work/xemacs-21.4.22/src/../lisp/loadup.el...
Using load-path (/var/tmp/portage/app-editors/xemacs-21.4.22-r1/work/xemacs-21.4.22/lisp)
Using module-load-path (/var/tmp/portage/app-editors/xemacs-21.4.22-r1/work/xemacs-21.4.22/modules)
Loading very-early-lisp...
Loading /var/tmp/portage/app-editors/xemacs-21.4.22-r1/work/xemacs-21.4.22/lisp/dumped-lisp.el...
Loading /var/tmp/portage/app-editors/xemacs-21.4.22-r1/work/xemacs-21.4.22/lisp/backquote.elc...
...
Loading /var/tmp/portage/app-editors/xemacs-21.4.22-r1/work/xemacs-21.4.22/lisp/loaddefs.elc...
Loading site-load...
Finding pointers to doc strings...
Finding pointers to doc strings...done
Dumping under the name xemacs
Testing for Lisp shadows ...
make[1]: *** [xemacs.dmp] Segmentation fault
make[1]: *** Deleting file `xemacs.dmp'
make[1]: Leaving directory `/var/tmp/portage/app-editors/xemacs-21.4.22-r1/work/xemacs-21.4.22/src'
make: *** [src] Error 2


Reproducible: Always




root@dolphin:/root(54)# emerge --info =app-editors/xemacs-21.4.22-r1
Portage 2.1.10.3 (hardened/linux/x86, gcc-4.4.5, glibc-2.12.2-r0, 2.6.38.7 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.38.7-i686-Pentium_II_-Deschutes-with-gentoo-2.0.3
Timestamp of tree: Wed, 03 Aug 2011 05:00:01 +0000
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.1.3-r1
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.4.5
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo java-overlay x-portage x-cpan
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 skype-eula"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp.caliu.info/pub/gentoo/ http://ftp.caliu.info/pub/gentoo/ ftp://vlaai.snt.ipv6.utwente.nl/pub/os/linux/gentoo/ http://www.gigaload.org/gentoo.org/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de fr"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/java-overlay /usr/local/portage /var/lib/cpan"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X Xaw3d a52 aac abiword acl acpi admin alsa ao apache2 applet archive arpack asf aspell assistant audacious audiofile automap automount bash-completion beagle berkdb blas blast boo boost bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cgi chm cli consolekit corba cracklib crypt cups curl cxx daap db dbase dbi dbm dbus device-mapper dga dia djvu doc dri ds2490 dv dvb dvd dvdr dvi eds elf emacs emboss empathy encode epiphany evo examples exif expat extensions extra extras fam fame ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fpx fts3 fuse galago gd gdal gdbm geolocation geos gif gimp ginac git glade glib gml gmp gmtsuppl gnokii gnome gnome-keyring gnome-print gnuplot gnutls gphoto2 gpm grammar graphics graphtft graphviz grass gs gsl gsm gstreamer gtk guile hardened harness hddtemp hdf hdf5 hlapi http httpd iconv icq icu id3 ide imagemagick imap innodb inotify ithreads jabber jadetex java java5 java6 jbig john jpeg jpeg2k kdrive kerberos kpathsea ladspa lame lapack latex latex3 lcms ldap libffi libgda libsamplerate lua lzo mad mail maildir math matroska mmx mmxext mng modules mono moonlight motif mozdevelop mozilla mp3 mp4 mpeg mplayer mtp mudflap musicbrainz mysql mysqli nautilus ncurses neXt netcdf netpbm network networking networkmanager nfs nls nntp nptl nptlonly nsplugin ntfs ntp numarray numeric ocaml octave odbc ogdi ogg ole opengl openmp pam pcre pdf perl pic plotutils plugins png policykit posix postgres postscript pppd preview-latex proj pstricks pulseaudio python python-bindings qhull quicktime readline reiserfs rle rpc rrdcgi rrdtool samba sasl science sdl secure-delete semantic-desktop server session sip slang slp smbclient sms sndfile snmp sox speex spell sql sqlite sse sse2 ssl subtitles subversion suexec svg sysfs szip t1lib tcl tcpd tex tex4ht texmacs theora threads thunderbird tidy tiff tk tntc tools truetype udev unicode urandom userlocales utempter v4l2 vorbis wav webdav webdav-serf webkit win32codecs wmf wxwidgets x86 xattr xcb xemacs xext xine xml xmlreader xmlrpc xorg xpm xulrunner xv xvid xvmc zlib zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de fr" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="r128 ati vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



root@dolphin:/root(55)# emerge -pqv =app-editors/xemacs-21.4.22-r1
[ebuild  N    ] app-editors/xemacs-21.4.22-r1  USE="X Xaw3d berkdb gdbm gif gpm jpeg ldap motif mule neXt png postgres tiff -athena -canna -dnd -eolconv -esd -freewnn -nas -pop -xface -xim" 
[ebuild  N    ] app-xemacs/xemacs-base-2.27 
[ebuild  N    ] app-xemacs/fsf-compat-1.19 
[ebuild  N    ] app-xemacs/apel-1.34 
[ebuild  N    ] app-xemacs/mule-base-1.56
Comment 1 Juergen Rose 2011-08-03 08:43:00 UTC
Created attachment 281941 [details]
/var/tmp/portage/app-editors/xemacs-21.4.22-r1/temp/build.log
Comment 2 Hans de Graaff gentoo-dev 2011-08-07 08:14:22 UTC

*** This bug has been marked as a duplicate of bug 75028 ***