Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 377213 - =dev-lang/ruby-1.8.7_p334-r2 does not compile
Summary: =dev-lang/ruby-1.8.7_p334-r2 does not compile
Status: RESOLVED DUPLICATE of bug 370413
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-31 23:20 UTC by David Carlos Manuelda
Modified: 2011-08-01 06:28 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Compile log for ruby (dev-lang:ruby-1.8.7_p334-r2:20110731-231802.log,38.94 KB, text/plain)
2011-07-31 23:21 UTC, David Carlos Manuelda
Details
emerge --info (emergeinfo.txt,14.34 KB, text/plain)
2011-07-31 23:22 UTC, David Carlos Manuelda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Carlos Manuelda 2011-07-31 23:20:47 UTC
It fails with:
callback.func:1:1: aviso: la definición de datos no tiene tipo o clase de almacenamiento [activado por defecto]
callback.func:1:7: error: expected identifier or ‘(’ before ‘long’
In file included from dl.c:104:0:
callback.func:78:33: error: expected ‘)’ before ‘(’ token
callback.func:79:3: aviso: la definición de datos no tiene tipo o clase de almacenamiento [activado por defecto]
callback.func:79:24: error: ‘proc’ no se declaró aquí (no en una función)
callback.func:79:39: error: ‘argc’ no se declaró aquí (no en una función)
callback.func:79:45: error: ‘argv’ no se declaró aquí (no en una función)
callback.func:82:1: error: expected identifier or ‘(’ before ‘}’ token
dl.c:106:1: error: expected ‘;’, ‘,’ or ‘)’ before ‘static’
make[1]: *** [dl.o] Error 1
make[1]: se sale del directorio `/var/tmp/portage/dev-lang/ruby-1.8.7_p334-r2/work/ruby-1.8.7-p334/ext/dl'
make: *** [all] Error 1
emake failed

I'll attach full build log and emerge --info

Reproducible: Always
Comment 1 David Carlos Manuelda 2011-07-31 23:21:44 UTC
Created attachment 281675 [details]
Compile log for ruby
Comment 2 David Carlos Manuelda 2011-07-31 23:22:22 UTC
Created attachment 281677 [details]
emerge --info
Comment 3 David Carlos Manuelda 2011-07-31 23:28:34 UTC
I can't compile 1.8.7_p334 nor 1.8.7_p334-r1, so I seem I can't have any version of ruby (without hard mask) installed on my system.
What can be the cause?
Comment 4 Hans de Graaff gentoo-dev 2011-08-01 06:28:49 UTC

*** This bug has been marked as a duplicate of bug 370413 ***