Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 377 - openssl don't emerge and the system is stopped
Summary: openssl don't emerge and the system is stopped
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Martin Schlemmer (RETIRED)
Depends on:
Reported: 2002-01-27 20:54 UTC by R. Strusberg
Modified: 2003-02-04 19:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description R. Strusberg 2002-01-27 20:54:39 UTC
When I try to emerge openssl the compile stage report:

Patching file:
invalid operand: 0000
CPU : 0

(more regs dumps...) and the system is stopped.

Everything began when I tried to create the rpm file using ebuild
openssl-0.9.6c.ebuild rpm. Now, It is not posible to emerge any ebuild package
that depend from openssl, because I get the same error.

I did copy the and from my another partition (other
Linux distribution) and now I can to get the new openssl.tar.gz files from
Internet, but when emerge go to the compile stage I get the same result. 

Remember, that wget need the openssl library for the emerge download stage.
Comment 1 Daniel Robbins (RETIRED) gentoo-dev 2002-01-28 13:01:36 UTC
this looks like a CPU/memory bug, reassigning to azarah to verify....
Comment 2 Martin Schlemmer (RETIRED) gentoo-dev 2002-02-02 16:01:16 UTC
You have enouth free space ?  Does older versions work ?
You havent had any other kind of problems lately ?  What version
of gcc, binutils, glibc?  You sure your CFLAGS is set properly ?
Other packages (anything but openssl) merge properly?

Just give some general info about your hardware, software, etc.
Comment 3 Martin Schlemmer (RETIRED) gentoo-dev 2002-02-16 19:01:14 UTC
Any new comments yet ?  Fixed you side ?