Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 376681 - sys-apps/portage-2.2.0_alpha47 sets EMERGE_DEFAULT_OPTS="--autounmask=y" by default
Summary: sys-apps/portage-2.2.0_alpha47 sets EMERGE_DEFAULT_OPTS="--autounmask=y" by d...
Status: RESOLVED DUPLICATE of bug 372485
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: autounmask
  Show dependency tree
 
Reported: 2011-07-28 07:44 UTC by Amit Prakash Ambasta
Modified: 2011-09-18 19:49 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge output from paste URL (emerge_autounmask_mysql.txt,2.19 KB, text/plain)
2011-07-28 09:12 UTC, Zac Medico
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Amit Prakash Ambasta 2011-07-28 07:44:03 UTC
Portage 2.2 alpha 47 is enabled with autounmask=y by default which leads to incoherent results while emerging packages and adds to user confusion. Also, it overrides masks in /etc/portage/package.mask

Reproducible: Always

Steps to Reproduce:
1. emerge portage 2.2 alpha 47
2. mask dev-db/mysql and virtual/mysql
3. emerge dev-db/mysql
Actual Results:  
Overrides /etc/portage/package.mask and shows incoherent results.

Expected Results:  
Should respect /etc/portage/package.mask and have saner suggestions!

The attached url is on a system without mysql while using autounmask=y on portage 2.1.10.3.

Moreover, in my opinion it would be wiser to advise user to use auto-unmask in case portage runs into mask issues while emerging packages, than first auto-unmasking and then informing user if issues arise.
Comment 1 Zac Medico gentoo-dev 2011-07-28 09:12:18 UTC
Created attachment 281225 [details]
emerge output from paste URL

I've attached your pasted emerge output here, in case the URL expires.
Comment 2 Sebastian Luther (few) 2011-07-28 09:14:02 UTC
(In reply to comment #0)
> [...] autounmask=y [...] leads to
> incoherent results while emerging packages and adds to user confusion.

Please file bugs for specific cases.

> Also, it
> overrides masks in /etc/portage/package.mask
>
Right, but how is that worse than the old output that told you that it can't proceed because all packages are masked?
 
>Steps to Reproduce:
>1. emerge portage 2.2 alpha 47
>2. mask dev-db/mysql and virtual/mysql
>3. emerge dev-db/mysql
>Actual Results:  
>Overrides /etc/portage/package.mask and shows incoherent results.

What else should it say than it needs to unmask dev-db/mysql?

>Expected Results:  
>Should respect /etc/portage/package.mask and have saner suggestions!
>The attached url is on a system without mysql while using autounmask=y on
>portage 2.1.10.3.
> The attached url 
Please don't use pastbins on bugzilla as they expire.

> is on a system without mysql while using autounmask=y on
> portage 2.1.10.3.

Your past is missing the command. Hard to tell without it if it makes sense what it tells you. What suggestion do you expect?

> 
> Moreover, in my opinion it would be wiser to advise user to use auto-unmask in
> case portage runs into mask issues while emerging packages, than first
> auto-unmasking and then informing user if issues arise.

Without --autounmask users have to solve one conflict after another, autounmask is much better in that regard.
Comment 3 Zac Medico gentoo-dev 2011-09-18 19:49:06 UTC

*** This bug has been marked as a duplicate of bug 372485 ***