Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 376455 - sys-devel/gdb build broken by CFLAGS='-finline-functions -ftracer'
Summary: sys-devel/gdb build broken by CFLAGS='-finline-functions -ftracer'
Status: RESOLVED DUPLICATE of bug 660836
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal minor (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
: 445132 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-07-26 09:24 UTC by Nick Wallingford
Modified: 2019-01-27 11:25 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Complete build log (sys-devel_gdb-7.2_build.log,342.08 KB, text/plain)
2011-07-26 11:06 UTC, Nick Wallingford
Details
emerge --info (emerge_info.txt,5.23 KB, text/plain)
2011-07-26 11:08 UTC, Nick Wallingford
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Wallingford 2011-07-26 09:24:07 UTC
Using both '-finline-functions' and '-ftracer' at the same time prevents sys-devel/gdb-7.2 from compiling; disabling either CFLAG will enable gdb to compile.

Reproducible: Always

Steps to Reproduce:
1. Enable both -finline-functions and -ftracer CFLAGS in either /etc/make.conf or /etc/portage/env/sys-devel/gdb
2. 'emerge =sys-devel/gdb-7.2'

Actual Results:  
error messages:

x86_64-pc-linux-gnu-gcc -c  -Wall -O3 -march=native -ftracer -pipe -ggdb    -I. -I. -
I./../common -I./../regformats -I./../../include linux-low.c -DUSE_THREAD_DB
x86_64-pc-linux-gnu-gcc -c -Wall -O3 -march=native -ftracer -pipe -ggdb    -I. -I. -I
./../common -I./../regformats -I./../../include linux-x86-low.c
linux-low.c: In function 'sigchld_handler':
linux-low.c:4757:11: warning: ignoring return value of 'write', declared with attribu
te warn_unused_result
linux-x86-low.c: Assembler messages:
linux-x86-low.c:2225: Error: symbol `start_i386_goto' is already defined
linux-x86-low.c:2227: Error: symbol `end_i386_goto' is already defined
linux-x86-low.c:2207: Error: symbol `start_i386_if_goto' is already defined
linux-x86-low.c:2214: Error: symbol `end_i386_if_goto' is already defined
linux-x86-low.c:1935: Error: symbol `start_amd64_void_call_2_a' is already defined
linux-x86-low.c:1937: Error: symbol `end_amd64_void_call_2_a' is already defined
linux-x86-low.c:1739: Error: symbol `start_amd64_goto' is already defined
linux-x86-low.c:1740: Error: symbol `end_amd64_goto' is already defined
linux-x86-low.c:1725: Error: symbol `start_amd64_if_goto' is already defined
linux-x86-low.c:1729: Error: symbol `end_amd64_if_goto' is already defined
x86_64-pc-linux-gnu-gcc -c -Wall -O3 -march=native -ftracer -pipe -ggdb    -I. -I. -I
./../common -I./../regformats -I./../../include i386-low.c
make[4]: *** [linux-x86-low.o] Error 1
make[4]: *** Waiting for unfinished jobs....


Expected Results:  
Compilation succeeds.

build log: http://pastebin.com/GHiYjGEr
emerge --info: http://pastebin.com/xXDp6kcv

Note that in this case, -finline-functions is enabled by -O3.
-ftracer is not enabled by any -O level.

Compilation succeeds with '-O3 -fno-inline-functions -ftracer'.
Comment 1 Pacho Ramos gentoo-dev 2011-07-26 11:01:41 UTC
Please attach that files directly to the bug report instead of using external resources that can disappear in the future.
Comment 2 Nick Wallingford 2011-07-26 11:06:55 UTC
Created attachment 281039 [details]
Complete build log
Comment 3 Nick Wallingford 2011-07-26 11:08:30 UTC
Created attachment 281041 [details]
emerge --info
Comment 4 Pacho Ramos gentoo-dev 2011-07-26 17:59:11 UTC
OK, thanks, anyway, you shouldn't use so aggressive CFLAGS as it can cause problems with many other apps
Comment 5 Ryan Hill (RETIRED) gentoo-dev 2013-08-12 16:51:03 UTC
*** Bug 445132 has been marked as a duplicate of this bug. ***
Comment 6 SpanKY gentoo-dev 2013-09-05 09:20:28 UTC
more in-depth analysis can be found in the duped bug 445132
Comment 7 Sergei Trofimovich gentoo-dev 2019-01-27 11:25:16 UTC

*** This bug has been marked as a duplicate of bug 660836 ***