Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 376169 - app-backup/amanda-3.2.[12] EXTRA_ECONF=--with-dump-honor-nodump - /usr/sbin/dump 9Sf /dev/null /dev/null/invalid/fs : sandbox violation for /etc/blkid.tab
Summary: app-backup/amanda-3.2.[12] EXTRA_ECONF=--with-dump-honor-nodump - /usr/sbin/d...
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-24 08:45 UTC by Christopher Head
Modified: 2013-02-27 08:00 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
The requested build log (build.log,50.33 KB, text/plain)
2011-07-26 03:50 UTC, Christopher Head
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Head 2011-07-24 08:45:40 UTC
After configure finishes, there are deny-write sandbox violations for /etc/blkid.tab. I will post the sandbox log below.

Reproducible: Always

Steps to Reproduce:
# emerge app-backup/amanda with USE +nls, +readline, -everything else, and with:
# cat /etc/portage/env/app-backup/amanda 
EXTRA_ECONF=--with-dump-honor-nodump




# cat /var/log/sandbox/sandbox-9953.log
VERSION 1.0
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9Sf /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9Sf /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9Sf /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9Sf /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9Sf /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9Sf /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9f /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9f /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9f /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9f /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9f /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9f /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9hf 0 /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9hf 0 /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9hf 0 /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9hf 0 /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9hf 0 /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9hf 0 /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9f /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9f /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9f /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9f /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9f /dev/null /dev/null/invalid/fs 

F: open_wr
S: deny
P: /etc/blkid.tab
A: /etc/blkid.tab
R: /etc/blkid.tab
C: /usr/sbin/dump 9f /dev/null /dev/null/invalid/fs

# emerge --info
Portage 2.1.10.3 (default/linux/amd64/10.0, gcc-4.4.5, glibc-2.12.2-r0, 2.6.39-gentoo-r3 x86_64)
=================================================================
System uname: Linux-2.6.39-gentoo-r3-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5200+-with-gentoo-2.0.2
Timestamp of tree: Sun, 24 Jul 2011 06:15:01 +0000
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.1.3-r1
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.2
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.4.5
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.2.10
sys-devel/make:           3.82
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo sunrise bitcoin
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 sun-bcla-java-vm AdobeFlash-10.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/var/cache/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://gentoo.chem.wisc.edu/gentoo ftp://gentoo.arcticnetwork.ca/pub/gentoo ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo"
LANG="en_CA.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_CA"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/bitcoin"
SYNC="rsync://rsync.ca.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acpi aio alsa amd64 archive bzip2 cairo caps cdda cddb cdinstall cdio cli css cups custom-optimization cvs cxx dbus dillo double-precision dri dvd faac faad fat ffmpeg fftw flac fontconfig fortran gcrypt gif gimp glade glibc-omitfp gmp gnutls gtk hou hpn idn imap iphone java java6 jce joystick jpeg libnotify libsamplerate mercurial mikmod mmx modules mp3 mpeg multilib multiuser ncurses nls nntp nowin nptl nptlonly ntfs ntp offensive ogg opengl openmp pam pdf plotutils png ppds pppd readline scanner sdl session sou sparse spell sse sse2 startup-notification stream subversion svg symlink sysfs taglib theora thunar timidity truetype unicode usb vdpau videos vim-syntax vorbis xattr xinerama xorg xscreensaver xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_CA" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" SANE_BACKENDS="plustek" USERLAND="GNU" VIDEO_CARDS="nvidia" XFCE_PLUGINS="logout menu" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Pacho Ramos gentoo-dev 2011-07-25 15:59:16 UTC
Attach full build.log please
Comment 2 Christopher Head 2011-07-26 03:50:26 UTC
Created attachment 280975 [details]
The requested build log
Comment 3 Christopher Head 2011-07-26 03:53:21 UTC
By the way, I commented out the EXTRA_ECONF assignment and tried again and the sandbox violation still occurs.
Comment 4 Dustin J. Mitchell 2011-07-26 04:04:48 UTC
Presumably this is a config/data file for /usr/sbin/dump.  Probably the easiest fix for Amanda is just to remove the check invoking it, and replace it with a fixed result.
Comment 5 Christopher Head 2011-09-23 06:01:03 UTC
As a workaround, I just ran a dump of /dev/null to /dev/null to get blkid.tab kicked into place; after that was done, the install worked fine.
Comment 6 Joe Breuer 2012-10-09 11:39:29 UTC
A similar thing [still] happens with app-backup/amanda-3.3.1; but now it fails with mkdir of /run/blkid (for /run/blkid/blkid.tab, apparently the now location for this file).

As Christopher said, running '/usr/sbin/dump 9Sf /dev/null /dev/null/invalid/fs' once (as root) is a workaround, since it creates the required files and allows a subsequent amanda build to continue.

To reproduce the bug in a development scenario, remove the /run/blkid directory or the /etc/blkid.tab file (whichever is used on your system), this will immediately trigger the sandbox violation when trying to emerge amanda.
Comment 7 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2013-02-27 00:09:26 UTC
amanda now has addpredict calls for this.
Comment 8 Christopher Head 2013-02-27 08:00:06 UTC
Appears to work, thank you!