Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 375837 - mail-filter/spamassassin-3.3.2 fails to build (Sandbox violation)
Summary: mail-filter/spamassassin-3.3.2 fails to build (Sandbox violation)
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-21 07:44 UTC by Oleg Gawriloff
Modified: 2013-07-08 10:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info output (emerge-info.txt,4.28 KB, text/plain)
2011-07-21 07:47 UTC, Oleg Gawriloff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oleg Gawriloff 2011-07-21 07:44:13 UTC
martin-cl2 ~ # emerge -va spamassassin

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] mail-filter/spamassassin-3.3.2 [3.3.1-r4] USE="berkdb ssl -doc -ipv6 -ldap -mysql -postgres -qmail -sqlite" 0 kB

Total: 1 package (1 upgrade), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] y

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) mail-filter/spamassassin-3.3.2
 * Mail-SpamAssassin-3.3.2.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                                               [ ok ]
 * Package:    mail-filter/spamassassin-3.3.2
 * Repository: gentoo
 * Maintainer: perl@gentoo.org
 * USE:        amd64 berkdb elibc_glibc kernel_linux ssl userland_GNU
 * FEATURES:   ccache sandbox
>>> Unpacking source...
>>> Unpacking Mail-SpamAssassin-3.3.2.tar.bz2 to /var/tmp/portage/mail-filter/spamassassin-3.3.2/work
>>> Source unpacked in /var/tmp/portage/mail-filter/spamassassin-3.3.2/work
>>> Preparing source in /var/tmp/portage/mail-filter/spamassassin-3.3.2/work/Mail-SpamAssassin-3.3.2 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/mail-filter/spamassassin-3.3.2/work/Mail-SpamAssassin-3.3.2 ...
 * Using ExtUtils::MakeMaker
 * perl Makefile.PL PREFIX=/usr INSTALLDIRS=vendor INSTALLMAN3DIR=none DESTDIR=/var/tmp/portage/mail-filter/spamassassin-3.3.2/image/ SYSCONFDIR=/etc DATADIR=/usr/share/spamassassin ENABLE_SSL=yes PERL_BIN=/usr/bin/perl
What email address or URL should be used in the suspected-spam report
text for users who want more information on your filter installation?
(In particular, ISPs should change this to a local Postmaster contact)
default text: [the administrator of that system] the administrator of that system

NOTE: settings for "make test" are now controlled using "t/config.dist".
See that file if you wish to customise what tests are run, and how.

checking module dependencies and their versions...
ACCESS DENIED  open_wr:      /var/db/protocols.db
/var/db/protocols.db: Отказано в доступе
ACCESS DENIED  open_wr:      /var/db/services.db
/var/db/services.db: Отказано в доступе
Checking if your kit is complete...
Looks good
'DATADIR' is not a known MakeMaker parameter name.
'ENABLE_SSL' is not a known MakeMaker parameter name.
'PERL_BIN' is not a known MakeMaker parameter name.
'SYSCONFDIR' is not a known MakeMaker parameter name.
Writing Makefile for Mail::SpamAssassin
Makefile written by ExtUtils::MakeMaker 6.56
make CC=x86_64-pc-linux-gnu-gcc 'LDFLAGS=-Wl,-O1 -Wl,--as-needed' spamc/Makefile
/usr/bin/perl spamc/configure.pl --prefix="/usr" --sysconfdir="/etc/mail/spamassassin" --datadir="/usr/share/spamassassin" --enable-ssl="yes"
cd spamc
/usr/bin/perl version.h.pl
version.h.pl: creating version.h
./configure --prefix=/usr --sysconfdir=/etc/mail/spamassassin --datadir=/usr/share/spamassassin --enable-ssl=yes
checking for gcc... x86_64-pc-linux-gnu-gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether x86_64-pc-linux-gnu-gcc accepts -g... yes
checking for x86_64-pc-linux-gnu-gcc option to accept ANSI C... none needed
checking how to run the C preprocessor... x86_64-pc-linux-gnu-gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking sys/time.h usability... yes
checking sys/time.h presence... yes
checking for sys/time.h... yes
checking syslog.h usability... yes
checking syslog.h presence... yes
checking for syslog.h... yes
checking for unistd.h... (cached) yes
checking errno.h usability... yes
checking errno.h presence... yes
checking for errno.h... yes
checking sys/errno.h usability... yes
checking sys/errno.h presence... yes
checking for sys/errno.h... yes
checking time.h usability... yes
checking time.h presence... yes
checking for time.h... yes
checking sysexits.h usability... yes
checking sysexits.h presence... yes
checking for sysexits.h... yes
checking sys/socket.h usability... yes
checking sys/socket.h presence... yes
checking for sys/socket.h... yes
checking netdb.h usability... yes
checking netdb.h presence... yes
checking for netdb.h... yes
checking netinet/in.h usability... yes
checking netinet/in.h presence... yes
checking for netinet/in.h... yes
checking pwd.h usability... yes
checking pwd.h presence... yes
checking for pwd.h... yes
checking signal.h usability... yes
checking signal.h presence... yes
checking for signal.h... yes
checking openssl/crypto.h usability... yes
checking openssl/crypto.h presence... yes
checking for openssl/crypto.h... yes
checking zlib.h usability... yes
checking zlib.h presence... yes
checking for zlib.h... yes
checking for an ANSI C-conforming const... yes
checking for off_t... yes
checking for pid_t... yes
checking for uid_t in sys/types.h... yes
checking for size_t... yes
checking for SHUT_RD... yes
checking for socket in -lsocket... no
checking for CRYPTO_lock in -lcrypto... yes
checking for SSL_CTX_free in -lssl... yes
checking for connect in -linet... no
checking for t_accept in -lnsl... no
checking for deflate in -lz... yes
checking for dlopen in -ldl... yes
checking for socket... yes
checking for strdup... yes
checking for strtod... yes
checking for strtol... yes
checking for snprintf... yes
checking for shutdown... yes
checking for h_errno... yes
checking for in_addr_t... yes
checking for INADDR_NONE... yes
checking for EX__MAX... yes
checking for EAI_ADDRFAMILY... no
checking for EAI_SYSTEM... (cached) no
checking for EAI_NODATA... (cached) no
configure: creating ./config.status
config.status: creating Makefile
config.status: creating spamc.h
config.status: creating config.h
>>> Source configured.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE "/var/log/sandbox/sandbox-24404.log"

VERSION 1.0
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: open_wr
S: deny
P: /var/db/protocols.db
A: /var/db/protocols.db
R: /var/db/protocols.db
C: perl Makefile.PL PREFIX=/usr INSTALLDIRS=vendor INSTALLMAN3DIR=none DESTDIR=/var/tmp/portage/mail-filter/spamassassin-3.3.2/image/ SYSCONFDIR=/etc DATADIR=/usr/share/spamassassin ENABLE_SSL=yes PERL_BIN=/usr/bin/perl

F: open_wr
S: deny
P: /var/db/services.db
A: /var/db/services.db
R: /var/db/services.db
C: perl Makefile.PL PREFIX=/usr INSTALLDIRS=vendor INSTALLMAN3DIR=none DESTDIR=/var/tmp/portage/mail-filter/spamassassin-3.3.2/image/ SYSCONFDIR=/etc DATADIR=/usr/share/spamassassin ENABLE_SSL=yes PERL_BIN=/usr/bin/perl
--------------------------------------------------------------------------------

>>> Failed to emerge mail-filter/spamassassin-3.3.2, Log file:

>>>  '/var/tmp/portage/mail-filter/spamassassin-3.3.2/temp/build.log'


Reproducible: Always
Comment 1 Oleg Gawriloff 2011-07-21 07:47:11 UTC
Created attachment 280505 [details]
emerge --info output
Comment 2 Agostino Sarubbo gentoo-dev 2011-07-21 11:07:24 UTC
in next time please add your log as attachment.TIA
Comment 3 Oleg Gawriloff 2011-08-26 13:55:22 UTC
Any news on this?
Comment 4 Oleg Gawriloff 2011-10-11 15:56:38 UTC
After rewriting /etc/nsswitch.conf from
services:    db files
protocols:   db files
to
services:    files
protocols:   files
all goes well. Any suggestions?
Comment 5 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2013-07-08 10:27:00 UTC
Looks like problem in your installation, i can't reproduce it.