Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 375483 - media-sound/squeezeboxserver requires modern dev-perl/XML-Parser
Summary: media-sound/squeezeboxserver requires modern dev-perl/XML-Parser
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Joe Peterson (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-17 19:45 UTC by Dirkjan Ochtman
Modified: 2014-04-09 07:03 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirkjan Ochtman gentoo-dev 2011-07-17 19:45:28 UTC
I had XML-Parser-2.36 installed, which led Squeezebox Server to complain about not being able to find XML::Parser::Expat; updating XML-Parser-2.410 (or something) made it work.
Comment 1 Joe Peterson (RETIRED) gentoo-dev 2011-07-18 04:00:30 UTC
Stuart, does this fix (bumping dependency to XML-Parser-2.410) seem correct to you?  Looks reasonable, but I wanted to double-check.
Comment 2 Stuart Hickinbottom 2011-07-18 15:39:53 UTC
I'm not sure that should be required. SBS requires XML::Parser-2.36 (a stated dependency in modules.conf within the source tarball), and includes that same version bundled (which we strip out and rely on the Portage version instead). XML::Parser::Expat is part of XML::Parser and is therefore also 2.36 and bundled with SBS.

Therefore, I think it should be working OK with 2.36.

I've just updated my test VM to the current Portage tree and SBS 7.5.4-r1, with dev-perl/XML-Parser-2.36-r1 and it appears to be working fine to me. At least, I can't see any mention of XML::Parser::Expat in the log files and the server seems to basically work OK.

I wonder whether something else odd happened with XML-Parser and if simply re-emerging 2.36 might have also fixed this issue?
Comment 3 Joe Peterson (RETIRED) gentoo-dev 2011-07-18 18:05:28 UTC
Stuart, very good point.  Since this package only requires version 2.36, our ebuild should, indeed, only specify that version.

If there is some loop caused by *not* requiring a higher version, the cause of that particular problem must exist in another package, not squeezeboxserver.
Comment 4 Joe Peterson (RETIRED) gentoo-dev 2012-04-12 06:11:31 UTC
New media-sound/logitechmediaserver-bin has been added, which is a binary package, resolving these issues.
Comment 5 Joe Peterson (RETIRED) gentoo-dev 2012-04-12 14:24:27 UTC
Note: please open a new bug on media-sound/logitechmediaserver-bin if a similar problem exists in this new package.
Comment 6 Samuli Suominen gentoo-dev 2014-04-09 07:03:19 UTC

*** This bug has been marked as a duplicate of bug 41124 ***