Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 375397 - net-print/foo2zjs-99999999: firmware not loaded into printers
Summary: net-print/foo2zjs-99999999: firmware not loaded into printers
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Printing Team
Keywords: PullRequest
Depends on:
Reported: 2011-07-16 18:55 UTC by Dimitrije Zivkovic
Modified: 2023-11-06 17:52 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---

build log (net-print:foo2zjs-99999999:20110724-024122.log,115.25 KB, text/plain)
2011-07-24 02:50 UTC, boxcars
build log (net-print:foo2zjs-99999999:20110808-014632.log,81.19 KB, text/x-log)
2011-08-08 02:01 UTC, boxcars

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitrije Zivkovic 2011-07-16 18:55:33 UTC
Ebuild file is working and everything gets installed OK. When printer gets installed, e.g. HP LaserJet P1005, it is not recieving print jobs that are sent.

As I used to install this software by hand and did some debuging, I noticed that after printer is set, it does not say "firmware loaded" in /var/log/everything/current which led me to believe that firmware is not loaded automatically. As I know how this software works, it was obvious that 
make-hotplug step was missed during instalation. 
After adding udev rules file and hotplug script, firmware was automatically loaded and everithing was working as it should.

My gentoo system is pure udev. After

I used to install foo2zjs by hand for CentOS5 and I remem

Reproducible: Always

Steps to Reproduce:
1. emerge foo2zjs live ebuild
2. configure any printer for printing
3. Print test page
Actual Results:  
The print job is sent to printer but it is not printing. Logs indicate that the job was generated and sent to printer but no page is ever printed.

Expected Results:  
It should print the page.

I will post udev.rules file and the hotplug script as I get to them. In fact, they are copied from centos.
Udev rules file was modified for bus->subsstem(s) and sysfs->attr(s) modifications.
Hotplug script was placed at exactly same dir as it was on centos. After that, everything was working as expected.
Comment 1 boxcars 2011-07-23 02:22:34 UTC
This affects HP LaserJet 1000/1005/1018/1020 and P1005/P1006/P1007/P1008/P1505 models.  (Mine is a 1020.)

The build needs `make install-hotplug` for the printers that have to have their firmware sent to them when they are connected.  Maybe this could be a use flag?  Or bring back the old FOO2ZJS_DEVICES variable?
Comment 2 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2011-07-23 23:38:52 UTC
Please try syncing the portage tree and re-emerging foo2zjs. I have made some changes to the ebuild that should help but don't have the affected printers to test.
Comment 3 boxcars 2011-07-24 02:50:35 UTC
Created attachment 280795 [details]
build log

The build failed for me.  I'm attaching a log, will give you more info if it will help (but i'm in an extreme hurry now.)  Thanks for working on this!
Comment 4 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2011-07-24 03:24:41 UTC
(In reply to comment #3)
> The build failed for me.  I'm attaching a log, will give you more info if it
> will help (but i'm in an extreme hurry now.)  Thanks for working on this!

Ah, I updated dependencies. Should work now.
Comment 5 boxcars 2011-07-24 03:55:03 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > The build failed for me.  
> Ah, I updated dependencies. Should work now.

After installing vim, building foo2zjs worked - I guess this is the dependency you updated.  I just reinstalled foo2zjs after your latest update to test.

I have the what look like the right /etc/hotplug/usb/hplj* script and symlinks, but I don't see the udev rules that should call them. I will post back tomorrow after I get the chance to plug the printer in.
Comment 6 boxcars 2011-08-08 02:01:31 UTC
Created attachment 282491 [details]
build log
Comment 7 boxcars 2011-08-08 02:04:18 UTC
(In reply to comment #5)

Sorry it's taken me so long to get back -- I was unexpectedly AFK for a while.

I did test back then (2011-07-24) and found the firmware wasn't being loaded.

I tried to re-emerge foo2zjs today, and the build failed.  I've just attached a build log, will post more info if wanted.
Comment 8 Nathaniel Taylor 2011-09-11 11:24:20 UTC
I've had this problem of no firmware loading for an HP lj 1018, since about a month ago (not sure exactly what change caused it -- a cups upgrade?).

Ok -- first thing for a successful compilation of foo2zjs was to follow the advice about removing an "alternative" incompatible printer-related file from /lib/udev/rules.d/*-printers.rules (part of system-config-printer-udev).
(This warning comes from the foo2zjs Makefile, not the ebuild.)

Having compiled and merged the ebuild, attempts at printing showed that the processing and removal from queue happened as usual, but nothing came out.
No error in the logs or the CUPS interface.  On connecting the printer's usb cable (after turning the printer off then on again to lose uploaded firmware) there was not the usual sound from the printer (a brief whirring and click).

Manual loading of the firmware:
   cat /usr/share/foo2zjs/firmware/sihp1018.dl  >/dev/usblp0
did give this sound from the printer, and printing then worked.

I don't understand enough of udev to see how the foo2zjs firmware upload scripts (e.g. /etc/hotplug/usb/hplj1018 ) would get run in the default Gentoo ebuild.   I suspect it doesn't, and that another file is needed in the ebuild.

When I added a file 
with a line as suggested in e.g. :

SUBSYSTEM=="usb", ATTR{dev}=="180:0", RUN+="/etc/hotplug/usb/hplj1018"

then it worked to turn off the printer, turn on and get the firmware automatically.

Would anyone care to confirm whether this helps, or whether there is any clear way in which the current ebuild and its dependencies would cause the firmware to be correctly uploaded?
Comment 9 Jack 2020-07-17 23:37:26 UTC
I was trying this from the source tarball, and finally gave up on that and installed from the ebuild.  I still needed to use the udev rules from the tarball (with further modification) but it does seem to work now.