Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 375293 - app-portage/gentoolkit-0.3.0.4: equery changes wine gives "Invalid CPV error"
Summary: app-portage/gentoolkit-0.3.0.4: equery changes wine gives "Invalid CPV error"
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Tools (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage Tools Team
URL: http://forums.gentoo.org/viewtopic-t-...
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: 346443
  Show dependency tree
 
Reported: 2011-07-15 15:06 UTC by Paul Varner (RETIRED)
Modified: 2011-12-02 06:33 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Varner (RETIRED) gentoo-dev 2011-07-15 15:06:13 UTC
# equery --debug changes wine
Traceback (most recent call last):
  File "/usr/bin/equery", line 38, in <module>
    equery.main()
  File "/usr/lib64/python2.6/site-packages/gentoolkit/equery/__init__.py", line 352, in main
    loaded_module.main(module_args)
  File "/usr/lib64/python2.6/site-packages/gentoolkit/equery/changes.py", line 155, in main
    changelog = ChangeLog(changelog_path)
  File "/usr/lib64/python2.6/site-packages/gentoolkit/helpers.py", line 78, in __init__
    self.indexed_entries = self._index_changelog()
  File "/usr/lib64/python2.6/site-packages/gentoolkit/helpers.py", line 184, in _index_changelog
    result.append((VersionMatch(entry_ver, op='='), entry))
  File "/usr/lib64/python2.6/site-packages/gentoolkit/versionmatch.py", line 52, in __init__
    self.version = cpv.version
  File "/usr/lib64/python2.6/site-packages/gentoolkit/cpv.py", line 89, in version
    self._set_cpv_chunks()
  File "/usr/lib64/python2.6/site-packages/gentoolkit/cpv.py", line 113, in _set_cpv_chunks
    chunks = split_cpv(self.cpv, validate=self.validate)
  File "/usr/lib64/python2.6/site-packages/gentoolkit/cpv.py", line 234, in split_cpv
    raise errors.GentoolkitInvalidCPV(cpv)
gentoolkit.errors.GentoolkitInvalidCPV: Invalid CPV: 'wine-*'


Error is caused by this entry in the ChangeLog:
*wine-* (11 Apr 2003) 


11 Apr 2002; Tilman Klar <phoenix@gentoo.org> wine-2002*, 
files/digest-wine-2002*, files/wine-2002* : 
Removed all wine versions prior to Jan 2003 from the tree. 

11 Apr 2002; Tilman Klar <phoenix@gentoo.org> wine-20030115.ebuild, 
wine-20030219.ebuild, wine-20030318.ebuild, wine-20030408.ebuild : 
Updated DEPEND. There were major problems with the new version of 
binutils, that's why i made wine depend on <=binutils-2.13.90.0.18-r1. 
For further information check bug #19106.

Since the ChangeLog entries are not always generated by a machine, the changes module needs to ignore InvalidCPV errors and just continue with what it can parse.
Comment 2 Paul Varner (RETIRED) gentoo-dev 2011-08-24 17:54:43 UTC
This will also be included in gentoolkit-0.3.0.4-r2
Comment 3 Brian Dolbec gentoo-dev 2011-12-02 06:33:19 UTC
released in >=app-portage/gentoolkit-0.3.0-r2