Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 374287 - sys-apps/portage needs to update it's logrotate file
Summary: sys-apps/portage needs to update it's logrotate file
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
: 378037 (view as bug list)
Depends on:
Blocks: 375169 373933
  Show dependency tree
 
Reported: 2011-07-06 22:50 UTC by Daniel Gryniewicz (RETIRED)
Modified: 2011-08-09 10:48 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Gryniewicz (RETIRED) gentoo-dev 2011-07-06 22:50:13 UTC
As of logrotate-3.8.0, there is a new option in conf files to allow rotating of files in parent directories that are writable by a group other than group root.  Since elog-save-summary rotates a files that is writable by group portage, it needs to be modified or logrotate-3.8.0 will refuse to rotate it.  The following line needs to be added:

su portage portage

This makes the actual rotation run as user/group portage.
Comment 1 Zac Medico gentoo-dev 2011-07-07 04:43:54 UTC
(In reply to comment #0)
> su portage portage

I don't see any mention of this option in the logrotate-3.7.9 man page. Do you know if older versions support it? If not, I suppose that we can use has_version to conditionally apply a patch.
Comment 2 Daniel Gryniewicz (RETIRED) gentoo-dev 2011-07-07 13:19:50 UTC
Good question.  2.7.9 will print a warning and ignore the line, but still rotate the file.

Since 2.8.0 is a security update, it's likely to go stable soon, and 2.7.9 will be removed, so it won't be an issue for very long, I believe.
Comment 4 Zac Medico gentoo-dev 2011-07-13 00:28:15 UTC
This is fixed in 2.1.10.5 and 2.2.0_alpha44.
Comment 5 Zac Medico gentoo-dev 2011-08-06 23:45:01 UTC
*** Bug 378037 has been marked as a duplicate of this bug. ***
Comment 6 Zac Medico gentoo-dev 2011-08-09 10:48:49 UTC
*** Bug 378451 has been marked as a duplicate of this bug. ***