Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 373865 - net-analyzer/tcptraceroute - checking for Solaris... configure: error: cannot run test program while cross compiling
Summary: net-analyzer/tcptraceroute - checking for Solaris... configure: error: cannot...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-03 00:48 UTC by Bertrand Jacquin
Modified: 2014-07-17 19:47 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
files/tcptraceroute-1.5_beta7-BJA-cross.diff (tcptraceroute-1.5_beta7-BJA-cross.diff,2.62 KB, patch)
2011-07-03 00:49 UTC, Bertrand Jacquin
Details | Diff
tcptraceroute-1.5_beta7-r1.ebuild.diff (tcptraceroute-1.5_beta7-r1.ebuild.diff,752 bytes, patch)
2011-07-03 00:49 UTC, Bertrand Jacquin
Details | Diff
files/tcptraceroute-1.5_beta7-BJA-cross.diff (tcptraceroute-1.5_beta7-BJA-cross.diff,1.92 KB, patch)
2011-07-05 00:10 UTC, Bertrand Jacquin
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bertrand Jacquin 2011-07-03 00:48:27 UTC
configure.ac use AC_RUN_IFELSE to determine if the system is Solaris,
BSDi .. but AC_RUN_IFELSE always fail when cross-compiling cause code is
building to TARGET and so can't be executed on BUILD host. And we can't
set a default value if this is a cross compiling build.

So here is a patch to make possible to cache if system is Solaris & so
on and assume that the system is not if cross-compiling, but let users
define ac_cv_os_solaris=yes if they want to.

Patch also reported to developer

>>> Compiling source in /usr/i586-geode-linux-gnu/tmp/portage/net-analyzer/tcptraceroute-1.5_beta7-r1/work/tcptraceroute-1.5beta7 ...
 * econf: updating tcptraceroute-1.5beta7/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating tcptraceroute-1.5beta7/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=i586-geode-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --dat
adir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib
configure: loading site script /usr/share/config.site
configure: loading site script /usr/share/crossdev/include/site/linux
...
checking for memset... yes
checking for select... yes
checking for socket... (cached) yes
checking for strchr... yes
checking for Solaris... configure: error: cannot run test program while cross compiling
See `config.log' for more details.


Reproducible: Always

Steps to Reproduce:
1. i586-geode-linux-gnu-emerge -vat tcptraceroute
2.
3.
Comment 1 Bertrand Jacquin 2011-07-03 00:49:12 UTC
Created attachment 278895 [details, diff]
files/tcptraceroute-1.5_beta7-BJA-cross.diff
Comment 2 Bertrand Jacquin 2011-07-03 00:49:59 UTC
Created attachment 278897 [details, diff]
tcptraceroute-1.5_beta7-r1.ebuild.diff
Comment 3 SpanKY gentoo-dev 2011-07-03 16:19:31 UTC
the cross-compile fallback case should look at $host_os to guess a good value

the rest of the patch looks pretty good and should go upstream
Comment 4 Bertrand Jacquin 2011-07-03 16:28:44 UTC
(In reply to comment #3)
> the cross-compile fallback case should look at $host_os to guess a good value
> 
> the rest of the patch looks pretty good and should go upstream

You made a point but I don't known those os $host_os :/ Do you have some kind of list ? This could make to configure really more simple

patch have been reported upstream to main developer as mailing list seems to be down
Comment 5 Bertrand Jacquin 2011-07-05 00:10:15 UTC
Created attachment 279117 [details, diff]
files/tcptraceroute-1.5_beta7-BJA-cross.diff

Here is a refresh patch to use $host
Comment 6 Jeroen Roovers (RETIRED) gentoo-dev 2014-07-06 22:59:42 UTC
*tcptrace-6.6.7-r1 (09 Jun 2013)
 
  09 Jun 2013; Jeroen Roovers <jer@gentoo.org> +tcptrace-6.6.7-r1.ebuild,
  +files/tcptrace-6.6.7-cross-compile.patch:
  Fix cross-compiling by Bertrand Jacquin (bug #374085). Set RDEPEND. Show
  notes only on first install.

So that was a different cross-compile bug? Any progress on this one?
Comment 7 Bertrand Jacquin 2014-07-07 08:43:56 UTC
(In reply to Jeroen Roovers from comment #6)
> *tcptrace-6.6.7-r1 (09 Jun 2013)
>  
>   09 Jun 2013; Jeroen Roovers <jer@gentoo.org> +tcptrace-6.6.7-r1.ebuild,
>   +files/tcptrace-6.6.7-cross-compile.patch:
>   Fix cross-compiling by Bertrand Jacquin (bug #374085). Set RDEPEND. Show
>   notes only on first install.

Thank you for this.

> So that was a different cross-compile bug? Any progress on this one?

I don't get it, sorry. Could you precise your thought ?
Comment 8 Jeroen Roovers (RETIRED) gentoo-dev 2014-07-07 10:05:59 UTC
(In reply to Bertrand Jacquin from comment #7)
> (In reply to Jeroen Roovers from comment #6)
> > *tcptrace-6.6.7-r1 (09 Jun 2013)
> >  
> >   09 Jun 2013; Jeroen Roovers <jer@gentoo.org> +tcptrace-6.6.7-r1.ebuild,
> >   +files/tcptrace-6.6.7-cross-compile.patch:
> >   Fix cross-compiling by Bertrand Jacquin (bug #374085). Set RDEPEND. Show
> >   notes only on first install.
> 
> Thank you for this.
> 
> > So that was a different cross-compile bug? Any progress on this one?
> 
> I don't get it, sorry. Could you precise your thought ?

I couldn't have been more precise. You filed bug #374085 after this one, but this bug is not fixed yet while that one is.
Comment 9 Jeroen Roovers (RETIRED) gentoo-dev 2014-07-07 10:07:15 UTC
(In reply to Jeroen Roovers from comment #8)
> I couldn't have been more precise. You filed bug #374085 after this one, but
> this bug is not fixed yet while that one is.

ah, wrong package. sry
Comment 10 Jeroen Roovers (RETIRED) gentoo-dev 2014-07-17 19:47:04 UTC
Fixed in tcptraceroute-1.5_beta7-r2.