Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 373809 - New package: sci-geosciences/osmgpsmap and its python bindings for app-misc/gramps
Summary: New package: sci-geosciences/osmgpsmap and its python bindings for app-misc/g...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 371324 462526
  Show dependency tree
 
Reported: 2011-07-02 13:19 UTC by Bob Deblier
Modified: 2013-04-02 20:27 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Deblier 2011-07-02 13:19:59 UTC
The gramps 'geography' feature depends on osm-gps-map (http://nzjrs.github.com/osm-gps-map/). An ebuild (sci-geosciences/osm-gps-map) is available in overlay jmbsvicetto, but the python bindings are not provided by that package.
Comment 1 Christian Faulhammer (RETIRED) gentoo-dev 2011-07-10 07:55:46 UTC
I am aware of that dependency, but I lack resources and time to maintain that package.
Comment 2 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-07-10 17:33:40 UTC
I need to work more on that package or better yet to get some help from anyone good with python.
Comment 3 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-03-28 18:57:42 UTC
+  28 Mar 2013; Tom Wijsman <TomWij@gentoo.org>
+  +files/osm-gps-map-0.7.3-disable-compiler-warnings.patch,
+  +files/osm-gps-map-0.7.3-fix-docs-location.patch, +metadata.xml,
+  +osm-gps-map-0.7.3.ebuild:
+  New ebuild for osm-gps-map. Made by Jorge Manuel B. S. Vicetto aka
+  jmbsvicetto, corrected by Aaron Bauman aka B-Man. Partially fixes bug #373809
+  which still awaits Python bindings.

If you want to maintain this package as well or want to be main maintainer, feel free to add yourself and optionally kick me from the metadata.xml. I'm adding this package for subsurface.

Leaving this bug open as it appears there is still python bindings work to do.
Comment 4 Nikoli 2013-03-28 23:33:22 UTC
Why '>=x11-libs/gtk+-2.14.0' does not have slot? If package supports both gtk2 and gtk3, gtk2 should be disabled. Else it will be broken.
Comment 5 Maxim Koltsov (RETIRED) gentoo-dev 2013-04-02 20:27:31 UTC
I commited introspection fix and python bindings support. Enjoy.