Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 37375 - hotplug-20040105 - error msg on hotplug start
Summary: hotplug-20040105 - error msg on hotplug start
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
: 37695 42726 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-01-06 00:42 UTC by Carsten Lohrke (RETIRED)
Modified: 2004-03-20 11:19 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
.config (.config,29.52 KB, text/plain)
2004-01-06 08:21 UTC, Carsten Lohrke (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carsten Lohrke (RETIRED) gentoo-dev 2004-01-06 00:42:05 UTC
* Starting USB and PCI hotplugging...
** can't synthesize input events - /proc/bus/input/devices missing

Reproducible: Always
Steps to Reproduce:
1.
2.
3.




Portage 2.0.49-r20 (default-x86-1.4, gcc-3.2.3, glibc-2.2.5-r2,2.3.2-r3,
2.4.20-gentoo-r9)
=================================================================
System uname: 2.4.20-gentoo-r9 i686 AMD Duron(tm) Processor
Gentoo Base System version 1.4.3.10p1
distcc 2.11.1 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=athlon-xp -pipe -foptimize-sibling-calls -fomit-frame-pointer
-fforce-addr -fprefetch-loop-arrays -fmove-all-movables -mfpmath=sse,387"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.1/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config
/usr/share/config /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe -foptimize-sibling-calls
-fomit-frame-pointer -fforce-addr -fprefetch-loop-arrays -fmove-all-movables
-mfpmath=sse,387"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache fixpackages keeptemp keepwork noclean sandbox userpriv"
GENTOO_MIRRORS="ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo
ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo
ftp://ftp.berlios.de/pub/gentoo-deutsch
http://www.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow X X509 Xaw3d aalib acl acpi acpi4linux alsa apm arts artswrappersuid
auctex avi berkdb bonobo cdr clisp cmucl crypt cscope cups curl dga directfb dnd
doc dvb dvd dvdr emacs encode ext-png ext-zlib faad fbcon firebird foomaticdb
gcl gd gdbm ggi gif glut gphoto2 gpm gstreamer gtk gtk2 hbci imagemagick imap
imlib innodb jack jack-caps jack-tmpfs java javascript jdepend jikes jpeg junit
jython ladcca lcms ldap libg++ libwww lirc ltsp mad maildir matroska mbox md5sum
mikmod mmx mng motif mozilla moznocompose moznoirc moznomail mozsvg mpeg
mupad-noscilab mysql nas ncurses nls oav odbc oggvorbis openal opengl oss pam
pcap pdflib perl pg-hier php physfs plotutils png pnp postgres ppds python qt
quicktime readline regexp ruby samba sasl scanner sdl skey slang slp snmp speex
spell sse ssl svga tcltk tcpd tetex tiff transcode truetype unicode usb
vim-with-x wmf x86 xml xml2 xmms xv xvid zeo zlib"
Comment 1 Tim Yamin (RETIRED) gentoo-dev 2004-01-06 07:45:15 UTC
Can we please have your kernel .config?
Comment 2 Carsten Lohrke (RETIRED) gentoo-dev 2004-01-06 08:21:26 UTC
Created attachment 23239 [details]
.config

sure :)
Comment 3 merwan kashouty 2004-01-06 09:37:38 UTC
i have two boxen with hotplug one ~x86 and ~ppc the ~x86 is running 2.4.23-ck1 and it gets this error... the ~ppc powerbook is running 2.6.2_rc1-benh1 and UDEV and does not... after looking at /etc/hotplug/usb.rc i didnt takee the output on the 2.4 to be so much an error but maybe there could be a supression of the output or coded to check for the existance of the kernel being used and search/run what would be appropriate? 
Comment 4 Axel Reimann 2004-01-07 06:02:19 UTC
With a recent 2.4.24 kernel, this problem also shows up.
Comment 5 Axel Reimann 2004-01-07 06:04:26 UTC
Using google to search for this particular error message
it appears as though right about any Linux distro is having trouble
with the current hotplug version.
Comment 6 Tim Yamin (RETIRED) gentoo-dev 2004-01-10 06:11:49 UTC
Can we please have a dmesg from anybody getting this - Carlo, can you see what happens if you set all those "Input Core" options that are as modules to be compiled into the kernel?
Comment 7 Carsten Lohrke (RETIRED) gentoo-dev 2004-01-10 08:21:20 UTC
plasmaroo: Compiling them into the kernel doesn't help.
Comment 8 Martin Schlemmer (RETIRED) gentoo-dev 2004-01-11 11:20:10 UTC
Uhm, is /proc/bus/input/devices actually there ?  I know 2.6 works fine,
and I do have that ...
Comment 9 Martin Schlemmer (RETIRED) gentoo-dev 2004-01-11 11:21:44 UTC
*** Bug 37695 has been marked as a duplicate of this bug. ***
Comment 10 Mauricio L. Pilla gentoo-dev 2004-01-11 17:29:21 UTC
Jumping as a "me too", vanilla 2.4.22 with cpufreq and ck2 patches

I've also started to have some weird problems with xfree not being able to cleaning finish sometimes and then locking the machine, and I think that it may be related because of the timing of events. Not sure yet.

Anyway, I am trying to emerge a previous version of hotplug that used to work to see what happens.
Comment 11 Mauricio L. Pilla gentoo-dev 2004-01-11 17:47:37 UTC
OK, emerged sys-apps/hotplug-20030501-r2 but it doesn't help. 

I tried booting with an older 2.4.20-wolk-pre10 and the problem remains.

There is no /proc/bus/input/devices in both.

The Input Core options are set as compile inside the kernel.

Attaching my dmesg, as asked. The ICH soundcard and eepro100 errors are likelly to be from hotplug, as I've put the soundcard and ethernet mods in the autoload file.
Comment 12 Don Seiler (RETIRED) gentoo-dev 2004-01-24 08:04:21 UTC
Me too.  hotplug-20040105 with vanilla-sources-2.4.24 on two different x86 machines.
Comment 13 Tim Yamin (RETIRED) gentoo-dev 2004-01-24 08:36:28 UTC
Try this [ for hotplug-20040105 ]:

--- /etc/hotplug/input.rc       2004-01-24 16:35:24.000000000 +0000
+++ etc..hotplug..input.rc.plasmaroo    2004-01-24 16:34:00.000000000 +0000
@@ -51,7 +51,9 @@
 input_boot_events ()
 {
     if [ ! -r $PROCDIR/devices ]; then
-           echo $"** can't synthesize input events - $PROCDIR/devices missing"
+           if [ `uname -r | grep 2\.[56]\.` ]; then
+               echo $"** can't synthesize input events - $PROCDIR/devices missing"
+           fi
            return
     fi
Comment 14 Abdul-Wahid Paterson 2004-02-21 09:31:39 UTC
I can confirm that the patch fixed the problems that I was having using hotplug-20040105 under 2.4.22-gentoo-r7

Thanks Tim.
Comment 15 Tim Yamin (RETIRED) gentoo-dev 2004-02-24 10:01:47 UTC
*** Bug 42726 has been marked as a duplicate of this bug. ***
Comment 16 Florian Effenberger 2004-02-24 15:39:23 UTC
root # patch -p0 < patch
patching file /etc/hotplug/input.rc
Hunk #1 FAILED at 51.
1 out of 1 hunk FAILED -- saving rejects to file /etc/hotplug/input.rc.rej

Whats wrong? :-(


Portage 2.0.50-r1 (default-x86-1.4, gcc-3.3.2, glibc-2.3.2-r9, 2.4.25)
=================================================================
System uname: 2.4.25 i586 AMD-K6(tm) 3D processor
Gentoo Base System version 1.4.3.13
Autoconf: sys-devel/autoconf-2.58-r1
Automake: sys-devel/automake-1.7.7
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -mcpu=k6-2 -march=k6-2 -funroll-loops -pipe"
CHOST="i586-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-O3 -mcpu=k6-2 -march=k6-2 -funroll-loops -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox"
GENTOO_MIRRORS="http://gentoo.seren.com/gentoo ftp://cs.ubishops.ca/pub/gentoo ftp://sunsite.ualberta.ca/pub/unix/Linux/gentoo/ http://adelie.polymtl.ca/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X Xaw3d aalib acl acpi alsa apm arts avi berkdb bonobo cdr crypt cups curl dga directfb doc dvd dvdr encode esd ethereal fbcon flash foomaticdb gb gd gdbm gif gnome gphoto2 gpm gtk gtk2 gtkhtml imap imlib jack java jpeg kde lcms libg++ libwww mad mbox mcal memlimit mikmod mmx motif mozilla mpeg mysql nas ncurses nls nocd oggvorbis opengl oss pam pdflib perl png ppds python qt quicktime readline samba sasl sdl slang slp spell sse ssl svga tcltk tcpd tetex tiff truetype usb videos wmf x86 xface xinerama xml xml2 xmms xosd xv zlib"
Comment 17 Tim Yamin (RETIRED) gentoo-dev 2004-02-25 06:08:36 UTC
Hmm, what hotplug are you trying that against? Also, ensure that there's an extra linebreak at the end of the patch.
Comment 18 Florian Effenberger 2004-02-25 06:30:40 UTC
*  sys-apps/hotplug
      Latest version available: 20040105
      Latest version installed: 20040105
      Size of downloaded files: 56 kB
      Homepage:    http://linux-hotplug.sourceforge.net
      Description: USB and PCI hotplug scripts
      License:     GPL-2

Is patch -p0 the correct syntax?
Maybe you could attach the patch as file to this bug report?
Thanks!
Comment 19 Florian Effenberger 2004-02-25 23:16:38 UTC
Also, do you plan to include this option in the standard emerge tool?
Would be great to have something like

emerge --use-make-build-continuation package_with_long_compile_time
Comment 20 Florian Effenberger 2004-02-25 23:17:00 UTC
Ah, sorry, that comment wasn't meant for this issue ;)
Comment 21 Tim Yamin (RETIRED) gentoo-dev 2004-03-14 13:28:39 UTC
Reassigning; the patch is in comment #13.
Comment 22 Greg Kroah-Hartman (RETIRED) gentoo-dev 2004-03-20 11:19:45 UTC
This should be fixed in the newest release.

If not, please let me know.