Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 373679 - [Science] Please add MGLTools 1.5.6 Release Candidate 2 to the tree or science overlay
Summary: [Science] Please add MGLTools 1.5.6 Release Candidate 2 to the tree or scienc...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo Science Related Packages
URL: http://mgltools.scripps.edu/downloads...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-01 08:09 UTC by urcindalo
Modified: 2012-01-09 08:54 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description urcindalo 2011-07-01 08:09:45 UTC
Please add the new MGLTools 1.5.6 Release Candidate 2 to the tree or science overlay.

Current stable v1.5.4 has apparently an upstream bug with AutodockTools not launching with the newest stable nvidia-drivers-270.41.06. Downgrading to v260.19.44 is not an option for me because xorg-server would be downgraded too from 1.10.2 to 1.9.5.

Reproducible: Always
Comment 1 Justin Lecher gentoo-dev 2011-07-01 08:29:03 UTC
Thanks for that report.

My time is currently limited. My plan is to fix the common functions from the ebuild into an eclass with the bump. So it will take some little time. I will give my best.
Comment 2 urcindalo 2011-07-01 08:42:56 UTC
Absolutely, Justin.

Thanks for all your efforts. Scientific Gentoo wouldn't be the same without you.
Comment 3 urcindalo 2011-09-30 11:22:59 UTC
Just a little remimnder for this version bump when you got the time :)

Thanks in advance for your time and efforts.
Comment 4 Justin Lecher gentoo-dev 2011-11-21 16:36:24 UTC
I am quite busy. hopefully I will make it soon. Any release date for 1.6?
Comment 5 urcindalo 2011-11-22 08:48:30 UTC
(In reply to comment #4)
> I am quite busy. hopefully I will make it soon. Any release date for 1.6?

No, I can see no release date for 1.6 in their site. In fact, 1.5.6 still appears as rc2.
Thanks.
Comment 6 Justin Lecher gentoo-dev 2012-01-06 17:06:58 UTC
Could you please report this to upstream?


 * Compilation and optimization of Python modules for CPython 2.6 ...                                                              [ !! ]
 *     /usr/lib64/python2.6/site-packages/Pmv/hostappInterface/Template/helperTemplate.py:619: SyntaxWarning: import * only allowed at module level
 *     def createDejaVuColorMat():
 *     /usr/lib64/python2.6/site-packages/Pmv/hostappInterface/Template/helperTemplate.py:647: SyntaxWarning: import * only allowed at module level
 *     def retrieveColorMat(color):
 *     /usr/lib64/python2.6/site-packages/Pmv/hostappInterface/autodeskmaya/helperMaya.py:420: SyntaxWarning: import * only allowed at module level
 *     def retrieveColorMat(color):
 *     /usr/lib64/python2.6/site-packages/Pmv/hostappInterface/blender/blenderHelper.py:433: SyntaxWarning: import * only allowed at module level
 *     def createDejaVuColorMat():
 *     /usr/lib64/python2.6/site-packages/Pmv/hostappInterface/blender/blenderHelper.py:440: SyntaxWarning: import * only allowed at module level
 *     def retrieveColorMat(color):
 *     /usr/lib64/python2.6/site-packages/Pmv/hostappInterface/cinema4d/helperC4D.py:536: SyntaxWarning: import * only allowed at module level
 *     def createDejaVuColorMat():
 *     /usr/lib64/python2.6/site-packages/Pmv/hostappInterface/cinema4d/helperC4D.py:543: SyntaxWarning: import * only allowed at module level
 *     def retrieveColorMat(color):
 *     /usr/lib64/python2.6/site-packages/Pmv/hostappInterface/houdini/houdiniHelper.py:626: SyntaxWarning: import * only allowed at module level
 *     def createDejaVuColorMat():
 *     /usr/lib64/python2.6/site-packages/Pmv/hostappInterface/houdini/houdiniHelper.py:639: SyntaxWarning: import * only allowed at module level
 *     def retrieveColorMat(color):
 *     /usr/lib64/python2.6/site-packages/Pmv/hostappInterface/pdb_blender.py:492: SyntaxWarning: import * only allowed at module level
 *     def createDejaVuColorMat():
 *     /usr/lib64/python2.6/site-packages/Pmv/hostappInterface/pdb_blender.py:499: SyntaxWarning: import * only allowed at module level
 *     def retrieveColorMat(color):
 *     /usr/lib64/python2.6/site-packages/Pmv/hostappInterface/pdb_c4d.py:490: SyntaxWarning: import * only allowed at module level
 *     def createDejaVuColorMat():
 *     /usr/lib64/python2.6/site-packages/Pmv/hostappInterface/pdb_c4d.py:497: SyntaxWarning: import * only allowed at module level
 *     def retrieveColorMat(color):
 *     Compiling /usr/lib64/python2.6/site-packages/Pmv/hostappInterface/blender/plugin/blenderPmvClientGUI.py ...
 *     SyntaxError: ('invalid syntax', ('/usr/lib64/python2.6/site-packages/Pmv/hostappInterface/blender/plugin/blenderPmvClientGUI.py', 49, 43, "MGL_ROOT=   #'/Library/MGLTools/1.5.6.csv'n"))
 *     
 *     Compiling /usr/lib64/python2.6/site-packages/Pmv/hostappInterface/cinema4d/plugin/epmv_c4d_plugin.py ...
 *     SyntaxError: ('invalid syntax', ('/usr/lib64/python2.6/site-packages/Pmv/hostappInterface/cinema4d/plugin/epmv_c4d_plugin.py', 41, 10, 'MGL_ROOT=n'))
 *     
 *     Compiling /usr/lib64/python2.6/site-packages/Pmv/hostappInterface/cinema4d/test/energy_test.py ...
 *     SyntaxError: ('invalid syntax', ('/usr/lib64/python2.6/site-packages/Pmv/hostappInterface/cinema4d/test/energy_test.py', 59, 45, "thread.start_new(c,('mdtest5', 349, callback=1, filename='0', log=0, callback_freq=10))n"))
 *     
 *     Compiling /usr/lib64/python2.6/site-packages/Pmv/styles/sessionToStyle.py ...
 *     SyntaxError: ('invalid syntax', ('/usr/lib64/python2.6/site-packages/Pmv/styles/sessionToStyle.py', 17, 30, 'f.write("__doc__ = """Style_01: Applies to X molecules. It displays ..n'))
 * Compilation and optimization of Python modules for CPython 2.7 ...                                                              [ !! ]
 *     /usr/lib64/python2.7/site-packages/Pmv/hostappInterface/Template/helperTemplate.py:619: SyntaxWarning: import * only allowed at module level
 *     def createDejaVuColorMat():
 *     /usr/lib64/python2.7/site-packages/Pmv/hostappInterface/Template/helperTemplate.py:647: SyntaxWarning: import * only allowed at module level
 *     def retrieveColorMat(color):
 *     /usr/lib64/python2.7/site-packages/Pmv/hostappInterface/autodeskmaya/helperMaya.py:420: SyntaxWarning: import * only allowed at module level
 *     def retrieveColorMat(color):
 *     /usr/lib64/python2.7/site-packages/Pmv/hostappInterface/blender/blenderHelper.py:433: SyntaxWarning: import * only allowed at module level
 *     def createDejaVuColorMat():
 *     /usr/lib64/python2.7/site-packages/Pmv/hostappInterface/blender/blenderHelper.py:440: SyntaxWarning: import * only allowed at module level
 *     def retrieveColorMat(color):
 *     /usr/lib64/python2.7/site-packages/Pmv/hostappInterface/cinema4d/helperC4D.py:536: SyntaxWarning: import * only allowed at module level
 *     def createDejaVuColorMat():
 *     /usr/lib64/python2.7/site-packages/Pmv/hostappInterface/cinema4d/helperC4D.py:543: SyntaxWarning: import * only allowed at module level
 *     def retrieveColorMat(color):
 *     /usr/lib64/python2.7/site-packages/Pmv/hostappInterface/houdini/houdiniHelper.py:626: SyntaxWarning: import * only allowed at module level
 *     def createDejaVuColorMat():
 *     /usr/lib64/python2.7/site-packages/Pmv/hostappInterface/houdini/houdiniHelper.py:639: SyntaxWarning: import * only allowed at module level
 *     def retrieveColorMat(color):
 *     /usr/lib64/python2.7/site-packages/Pmv/hostappInterface/pdb_blender.py:492: SyntaxWarning: import * only allowed at module level
 *     def createDejaVuColorMat():
 *     /usr/lib64/python2.7/site-packages/Pmv/hostappInterface/pdb_blender.py:499: SyntaxWarning: import * only allowed at module level
 *     def retrieveColorMat(color):
 *     /usr/lib64/python2.7/site-packages/Pmv/hostappInterface/pdb_c4d.py:490: SyntaxWarning: import * only allowed at module level
 *     def createDejaVuColorMat():
 *     /usr/lib64/python2.7/site-packages/Pmv/hostappInterface/pdb_c4d.py:497: SyntaxWarning: import * only allowed at module level
 *     def retrieveColorMat(color):
 *     Compiling /usr/lib64/python2.7/site-packages/Pmv/hostappInterface/blender/plugin/blenderPmvClientGUI.py ...
 *     SyntaxError: ('invalid syntax', ('/usr/lib64/python2.7/site-packages/Pmv/hostappInterface/blender/plugin/blenderPmvClientGUI.py', 49, 43, "MGL_ROOT=   #'/Library/MGLTools/1.5.6.csv'n"))
 *     
 *     Compiling /usr/lib64/python2.7/site-packages/Pmv/hostappInterface/cinema4d/plugin/epmv_c4d_plugin.py ...
 *     SyntaxError: ('invalid syntax', ('/usr/lib64/python2.7/site-packages/Pmv/hostappInterface/cinema4d/plugin/epmv_c4d_plugin.py', 41, 10, 'MGL_ROOT=n'))
 *     
 *     Compiling /usr/lib64/python2.7/site-packages/Pmv/hostappInterface/cinema4d/test/energy_test.py ...
 *     SyntaxError: ('invalid syntax', ('/usr/lib64/python2.7/site-packages/Pmv/hostappInterface/cinema4d/test/energy_test.py', 59, 45, "thread.start_new(c,('mdtest5', 349, callback=1, filename='0', log=0, callback_freq=10))n"))
 *     
 *     Compiling /usr/lib64/python2.7/site-packages/Pmv/styles/sessionToStyle.py ...
 *     SyntaxError: ('invalid syntax', ('/usr/lib64/python2.7/site-packages/Pmv/styles/sessionToStyle.py', 17, 30, 'f.write("__doc__ = """Style_01: Applies to X molecules. It displays ..n'))
Comment 7 Justin Lecher gentoo-dev 2012-01-08 14:55:49 UTC
Finally found time to bump. Please test and report errors.
Comment 8 urcindalo 2012-01-09 08:54:11 UTC
Thanks, Justin. I just found the update today at work (it's been Holidays in Spain since Jan. the 6th: the Three Kings). This makes a pretty good Christmas present :)

After compilation it launches without errors, so definitely an improvement.
I will report any errors or misbehaviors I find.

Thanks again for your time. I hope the New Year will bring happiness for you and your family.