Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 373061 - x11-libs/qt-core-4.7.3 install_mkspecs
Summary: x11-libs/qt-core-4.7.3 install_mkspecs
Status: RESOLVED FIXED
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: x86 OS X
: Normal normal (vote)
Assignee: Gentoo Prefix
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-25 23:40 UTC by shawnleblanc
Modified: 2012-11-12 02:09 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,610.94 KB, text/plain)
2011-06-25 23:42 UTC, shawnleblanc
Details
emerge info (emerge-info,3.33 KB, text/plain)
2011-06-25 23:43 UTC, shawnleblanc
Details
emerge --info (emerge-info-20111119,3.53 KB, text/plain)
2011-11-19 02:27 UTC, MATSUI Tetsushi
Details
emerge --info (info.txt,11.66 KB, text/plain)
2011-12-15 21:32 UTC, Naohiro Aota
Details

Note You need to log in before you can comment on or make changes to this bug.
Description shawnleblanc 2011-06-25 23:40:43 UTC
make -j3 INSTALL_ROOT=/Users/shawn2/Gentoo/var/tmp/portage/x11-libs/qt-core-4.7.3/image/ install_mkspecs 
make: *** No rule to make target `install_mkspecs'.  Stop

Reproducible: Always
Comment 1 shawnleblanc 2011-06-25 23:42:38 UTC
Created attachment 278173 [details]
build log
Comment 2 shawnleblanc 2011-06-25 23:43:05 UTC
Created attachment 278175 [details]
emerge info
Comment 3 Fabian Groffen gentoo-dev 2011-08-27 18:06:44 UTC
hmmm, this just installs for me.
Comment 4 MATSUI Tetsushi 2011-11-19 02:22:37 UTC
I have the same problem. The versions I tried are 4.7.3-r1 and 4.7.4.
Comment 5 MATSUI Tetsushi 2011-11-19 02:27:57 UTC
Created attachment 293065 [details]
emerge --info
Comment 6 Naohiro Aota gentoo-dev 2011-11-22 12:17:13 UTC
This is because we are using different OS version, I think.

On my environment (System uname: Darwin-10.8.0-i386-32bit), qmake died while creating Makefile and that cause incomplete Makefile which lack install_mkspecs rule.

Steps to reproduce:
% emerge -1 qt-core
(failed with install_mkspec error)
% cd ~/Gentoo/var/tmp/portage/x11-libs/qt-core-4.7.4/work/qt-everywhere-opensource-src-4.7.4
% ./bin/qmake -spec mkspecs/macx-g++ -o Makefile projects.pro
WARNING: /Users/naota/Gentoo/var/tmp/portage/x11-libs/qt-core-4.7.4/work/qt-everywhere-opensource-src-4.7.4/src/src.pro:12: Unable to find file for inclusion tools/tools.pro
WARNING: /Users/naota/Gentoo/var/tmp/portage/x11-libs/qt-core-4.7.4/work/qt-everywhere-opensource-src-4.7.4/src/gui/image/qpnghandler.pri:9: Unable to find file for inclusion /Users/naota/Gentoo/var/tmp/portage/x11-libs/qt-core-4.7.4/work/qt-everywhere-opensource-src-4.7.4/src/3rdparty/libpng.pri
WARNING: /Users/naota/Gentoo/var/tmp/portage/x11-libs/qt-core-4.7.4/work/qt-everywhere-opensource-src-4.7.4/projects.pro:46: Unable to find file for inclusion doc/doc.pri
zsh: bus error  ./bin/qmake -spec mkspecs/macx-g++ -o Makefile projects.pro

above build.log is also showing the same error:

./configure: line 8438: 50739 Segmentation fault      QTDIR="$outpath" "$outpath/bin/qmake" -spec "$XQMAKESPEC" "${relpath}/projects.pro" -o "$mkfile"

I've changed

        if [[ ${CHOST} == *86*-apple-darwin* ]] ; then
                # qmake bus errors with -O2 but -O3 works
                replace-flags -O2 -O3
        fi

to

        if [[ ${CHOST} == *86*-apple-darwin* ]] ; then
                # qmake bus errors with -O2 and -O3
                replace-flags -O3 -O2
                replace-flags -O2 -O1
        fi


and it get built well. Please confirm this with your environment.
Comment 7 Naohiro Aota gentoo-dev 2011-11-22 13:33:12 UTC
ah, this code snipet is in eclass/qt4-build.eclass

> I've changed
> 
>         if [[ ${CHOST} == *86*-apple-darwin* ]] ; then
>                 # qmake bus errors with -O2 but -O3 works
>                 replace-flags -O2 -O3
>         fi
> 
> to
> 
>         if [[ ${CHOST} == *86*-apple-darwin* ]] ; then
>                 # qmake bus errors with -O2 and -O3
>                 replace-flags -O3 -O2
>                 replace-flags -O2 -O1
>         fi
> 
> 
> and it get built well. Please confirm this with your environment.
Comment 8 Naohiro Aota gentoo-dev 2011-12-02 23:01:48 UTC
Reopen to get comments from prefix team.
Comment 9 MATSUI Tetsushi 2011-12-03 03:52:25 UTC
With naota's solution, I can emerge qt-core-4.7.4 and 4.7.4-r1.
Comment 10 Fabian Groffen gentoo-dev 2011-12-04 19:54:57 UTC
I'm on Lion, using a 64-bits prefix.  Compiler/linker should be the same for us.
Comment 11 Naohiro Aota gentoo-dev 2011-12-15 21:32:23 UTC
Created attachment 295961 [details]
emerge --info

Still have

./configure: line 8403: 21222 Segmentation fault      QTDIR="$outpath" "$outpath/bin/qmake" -spec "$XQMAKESPEC" "${relpath}/projects.pro" -o "$mkfile"

and result to install_mkspec not available

Pasting emerge --info output to work on it.
Comment 12 Christoph Junghans gentoo-dev 2012-01-31 18:21:41 UTC
I can confirm, it fails with -O2, but builds with -O1 on both of my x86-macos (10.6).
Comment 13 Naohiro Aota gentoo-dev 2012-11-12 02:09:22 UTC
The fix is already included in the Portage tree.

http://tinderbox.dev.gentoo.org/portage-prefix/eclass/qt4-build.eclass