Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 372949 - app-admin/python-updater should depend on sys-apps/openrc
Summary: app-admin/python-updater should depend on sys-apps/openrc
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
: 480602 (view as bug list)
Depends on: 373219
Blocks:
  Show dependency tree
 
Reported: 2011-06-25 09:03 UTC by Christoph Brill (egore) (RESIGNED)
Modified: 2018-02-14 15:58 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Brill (egore) (RESIGNED) 2011-06-25 09:03:28 UTC
Calling "python-updater" on a system without openrc and sysvinit (systemd enabled) it spits out something like

/etc/init.d/functions.sh: No such file or directory
einfo: command not found

So there is an implicit dependency from python-updater 0.9 to openrc.

Reproducible: Always
Comment 1 William Hubbs gentoo-dev 2011-06-28 20:48:17 UTC
See the bug blocking this one for work that is moving toward a
minimalist version of openrc that will be used on all gentoo systems
regardless of the init system in use.

My plan is to set it up so that you can just depend on sys-apps/openrc
as requested in the previous comment.
Comment 2 Richard Yao gentoo-dev 2012-07-05 04:02:35 UTC
Depending on OpenRC would cause problems for Gentoo Prefix. The Gentoo Prefix developers currently do their own patches, but it would be nice to see the main tree version of python-updater become usable in Gentoo Prefix.
Comment 3 Mike Gilbert gentoo-dev 2012-07-05 13:59:19 UTC
(In reply to comment #2)

Do you have a link to said patches?
Comment 4 Samuli Suominen gentoo-dev 2013-08-11 12:06:46 UTC
*** Bug 480602 has been marked as a duplicate of this bug. ***
Comment 5 David Heidelberg (okias) 2014-03-10 20:14:03 UTC
No longer blocked! Can we depend on new gentoo-functions now? :)
Comment 6 Nikoli 2015-04-21 19:33:41 UTC
>=app-admin/python-updater-0.12 has sys-apps/gentoo-functions in deps, so may be this bug is fixed?
Comment 8 Pacho Ramos gentoo-dev 2018-02-14 15:58:58 UTC
removed from the tree