Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 37224 - "emerge -p rsync" replies with: "emerge: the "sync" action does not support "--pretend.""
Summary: "emerge -p rsync" replies with: "emerge: the "sync" action does not support "...
Status: RESOLVED DUPLICATE of bug 2365
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-01-04 13:00 UTC by Everette
Modified: 2005-07-17 13:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Everette 2004-01-04 13:00:14 UTC
"emerge -p rsync" replies with: "emerge: the "sync" action does not support "--pretend.""

...portage is apparently not using strict pattern matching when looking for the "sync" option, in order to give the diagnostic message above.

Additionally, "emerge rsync" just results in an "emerge sync" being run.

I'm using portage-2.0.49-r20

Reproducible: Always
Steps to Reproduce:
1. "emerge -p rsync"
2. "emerge rsync"
3. (both fail to do anything recognize the option as "rsynch" rather than "sync"

Actual Results:  
an "emerge sync" was run

Expected Results:  
Upgraded the "rsync" package.
Comment 1 FieldySnuts 2004-01-04 13:02:43 UTC
rsync happens to do the same thing as sync, so you must call it in full, like so:

emerge -p net-misc/rsync-2.6.0
Comment 2 FieldySnuts 2004-01-04 13:03:23 UTC
Sorry, emerge -p net-misc/rsync .

The former will work, but get you specifically version 2.6.0 .
Comment 3 Marius Mauch (RETIRED) gentoo-dev 2004-01-04 13:27:45 UTC

*** This bug has been marked as a duplicate of 2365 ***