Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 372183 - PORTAGE_COMPRESS_FLAGS set to "-k9e" breaks libdca
Summary: PORTAGE_COMPRESS_FLAGS set to "-k9e" breaks libdca
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Portage team
URL: http://forums.gentoo.org/viewtopic-t-...
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: 373933
  Show dependency tree
 
Reported: 2011-06-18 13:46 UTC by Alec Wright
Modified: 2011-07-03 17:33 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Wright 2011-06-18 13:46:32 UTC
When I try to emerge libdca, i get this output. It turns out that this is resolved by un-setting PORTAGE_COMPRESS in make.conf
 
make[2]: Nothing to be done for `install-exec-am'.
test -z "/usr/include" || /bin/mkdir -p "/var/tmp/portage/media-libs/libdca-0.0.5-r2/image//usr/include"
 /usr/bin/install -c -m 644 dca.h dts.h '/var/tmp/portage/media-libs/libdca-0.0.5-r2/image//usr/include'
make[2]: Leaving directory `/var/tmp/portage/media-libs/libdca-0.0.5-r2/work/libdca-0.0.5/include'
make[1]: Leaving directory `/var/tmp/portage/media-libs/libdca-0.0.5-r2/work/libdca-0.0.5/include'
make[1]: Entering directory `/var/tmp/portage/media-libs/libdca-0.0.5-r2/work/libdca-0.0.5'
make[2]: Entering directory `/var/tmp/portage/media-libs/libdca-0.0.5-r2/work/libdca-0.0.5'
make[2]: Nothing to be done for `install-exec-am'.
make[2]: Nothing to be done for `install-data-am'.
make[2]: Leaving directory `/var/tmp/portage/media-libs/libdca-0.0.5-r2/work/libdca-0.0.5'
make[1]: Leaving directory `/var/tmp/portage/media-libs/libdca-0.0.5-r2/work/libdca-0.0.5'
>>> Completed installing libdca-0.0.5-r2 into /var/tmp/portage/media-libs/libdca-0.0.5-r2/image/

strip: x86_64-pc-linux-gnu-strip --strip-unneeded -R .comment
   usr/bin/dcadec
   usr/bin/extract_dca
   usr/lib64/libdca.so.0.0.0
ecompressdir: xz -k9e /usr/share/man
find: paths must precede expression: compressme.xz
Usage: find [-H] [-L] [-P] [-Olevel] [-D help|tree|search|stat|rates|opt|exec] [path...] [expression]

>>> Installing (2 of 28) media-libs/libdca-0.0.5-r2
 * This package installs one or more files containing a newline (\n) character:
 * 
 * 	/usr/share/man/man1/dtsdec.1\ncompressme.xz
 * 	/usr/share/man/man1/extract_dts.1\ncompressme.xz
 * 
 * package media-libs/libdca-0.0.5-r2 NOT merged
 * 

>>> Failed to install media-libs/libdca-0.0.5-r2, Log file:

>>>  '/var/tmp/portage/media-libs/libdca-0.0.5-r2/temp/build.log'

 * Messages for package media-libs/libdca-0.0.5-r2:

 * This package installs one or more files containing a newline (\n) character:
 * 
 * 	/usr/share/man/man1/dtsdec.1\ncompressme.xz
 * 	/usr/share/man/man1/extract_dts.1\ncompressme.xz
 * 
 * package media-libs/libdca-0.0.5-r2 NOT merged
 * 

 * GNU info directory index is up-to-date.

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

 * After world updates, it is important to remove obsolete packages with
 * emerge --depclean. Refer to `man emerge` for more information.





Reproducible: Always

Steps to Reproduce:
Set PORTAGE_COMPRESS="xz" and PORTAGE_COMPRESS_FLAGS="-k9e" in /etc/make.conf

emerge -av1 libdca



emerge --info:

Portage 2.1.9.42 (default/linux/amd64/10.0, gcc-4.4.5, libc-0-r0, 2.6.38-gentoo-r6 x86_64)
=================================================================
System uname: Linux-2.6.38-gentoo-r6-x86_64-Intel-R-_Core-TM-_i3_CPU_M_350_@_2.27GHz-with-gentoo-2.0.2
Timestamp of tree: Sat, 18 Jun 2011 09:45:01 +0000
app-shells/bash:     4.1_p9
dev-lang/python:     2.7.1-r1, 3.1.3-r1
dev-util/cmake:      2.8.4-r1
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.8.2-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5
sys-devel/gcc-config: 1.4.1-r1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.82
sys-kernel/linux-headers: 2.6.36.1
sys-libs/glibc:      2.12.2
virtual/os-headers:  0
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=core2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=core2"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://gentoo.virginmedia.com/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_GB eo en"
MAKEOPTS="-j6"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_COMPRESS_FLAGS="-k9e"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.uk.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 amr apng berkdb branding bzip2 cairo cdda cddb cli consolekit cracklib crypt cups cxx dbus device-mapper dirac dri dvd exif extras faac ffmpeg flac fortran gdbm gdu gpm gtk iconv id3tag ipv6 jpeg libsamplerate lock mad matroska mmx mng modules mp3 mpeg mudflap multilib ncurses networkmanager nls nptl nptlonly nsplugin ogg openmp pam pcre pdf perl png policykit pppd python readline schroedinger session speex sse sse2 ssl ssse3 startup-notification svg sysfs tcpd theora threads thunar tiff udev unicode v4l2 vorbis wavpack x264 xft xorg xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB eo en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Zac Medico gentoo-dev 2011-06-30 07:54:07 UTC
Did you put the xz -k option in PORTAGE_COMPRESS_FLAGS because you want both compressed and uncompressed copies of files, or what?
Comment 3 Zac Medico gentoo-dev 2011-07-01 05:08:17 UTC
This is in 2.2.0_alpha42, but I'll leave this bug open until it's in an unmasked release.
Comment 4 Alec Wright 2011-07-01 08:54:28 UTC
Sorry, you're right: -k was a stupid flag to use, I want rid of the original. I suppose i just used it instinctively without much thought: -k9e is my usual archiving flags for xz.
Comment 5 Zac Medico gentoo-dev 2011-07-03 17:33:49 UTC
This is fixed in 2.1.10.4.