Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 371909 - sys-apps/portage-2.1.9.42: Adjusting permissions for FEATURES=ccache: '/tmp/tmpcS_jLR/ccache'
Summary: sys-apps/portage-2.1.9.42: Adjusting permissions for FEATURES=ccache: '/tmp/t...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: 373933
  Show dependency tree
 
Reported: 2011-06-16 09:44 UTC by Toralf Förster
Modified: 2011-07-03 17:33 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
skip CCACHE_DIR for pkg_info (pkg_info_ccache.patch,1.09 KB, patch)
2011-06-16 19:29 UTC, Zac Medico
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2011-06-16 09:44:33 UTC
I've a dozen packages where i get this error message which looks bogus, isn't it ? :

n22 /etc/portage/package.keywords # emerge --info =app-admin/eselect-xvmc-0.1 1>/dev/null
 * Adjusting permissions for FEATURES=ccache: '/tmp/tmpcS_jLR/ccache'



Reproducible: Always




n22 /etc/portage/package.keywords # emerge --info
Portage 2.1.9.42 (default/linux/x86/10.0/desktop/kde, gcc-4.4.5, libc-0-r0, 2.6.39.1 i686)
=================================================================
System uname: Linux-2.6.39.1-i686-Intel-R-_Core-TM-2_Duo_CPU_P8600_@_2.40GHz-with-gentoo-2.0.2
Timestamp of tree: Thu, 16 Jun 2011 08:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.7.1-r1, 3.1.3-r1
dev-util/ccache:     2.4-r9
dev-util/cmake:      2.8.4-r1
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.8.2-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5
sys-devel/gcc-config: 1.4.1-r1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.82
sys-kernel/linux-headers: 2.6.36.1
sys-libs/glibc:      2.12.2
virtual/os-headers:  0
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache compress-build-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.leaseweb.com/gentoo/ http://gentoo.mirror.dkm.cz/pub/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://gentoo.mneisen.org/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_GB"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://linux.rz.ruhr-uni-bochum.de/gentoo-portage"
USE="X a52 aac acl acpi alsa apache2 berkdb bluetooth branding bzip2 cairo cdda cdr classic cli consolekit cracklib crypt css cups cxx dbus declarative dri dts dvb dvd dvdr emboss encode exif fam fastbuild fat ffmpeg firefox flac fortran gdbm gdu gif git gmp gphoto2 gpm gtk hyphenation iconv ipv6 java jpeg kde kipi kqemu lastfm lcms ldap libnotify logrotate mad mbox mmx mng modules mp3 mp4 mpeg mudflap mysql mysqli ncurses nls nptl nptlonly nsplugin ntfs ogg opengl openmp pam pango pcre pdf perl phonon plasma png policykit ppds pppd python qt3support qt4 rdesktop readline sdl semantic-desktop session sieve spell sse sse2 sse3 ssl ssse3 startup-notification svg sysfs tcpd test thinkpad tiff tk truetype udev unicode usb vaapi vim-syntax vorbis wmf x264 x86 xcb xcomposite xinerama xml xorg xpm xscreensaver xulrunner xv xvfb xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB" LIRC_DEVICES="devinput inputlirc" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386" QEMU_USER_TARGETS="i386" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jeroen Roovers gentoo-dev 2011-06-16 16:12:05 UTC
It's emerge informing you that it's doing something to help you use ccache. The real problem seems to be that your CCACHE_DIR isn't set or wrongly set.
Comment 2 Toralf Förster gentoo-dev 2011-06-16 17:54:38 UTC
But only for few packages :

tfoerste@n22 ~ $ time equery l '*' | cut -f1 -d: | sed 's/^/=/' | while read p; do echo $p; emerge --info $p 2>&1 1>/dev/null; done | grep -B 1 'Adjusting' | grep '^='
=app-admin/eselect-xvmc-0.1
=app-cdr/dvd+rw-tools-7.1-r1
=app-dicts/aspell-en-6.0.0
=app-editors/hexcurse-1.55
=app-text/libpaper-1.1.23
=app-text/sloccount-2.26-r1
=app-vim/info-1.7-r1
=dev-util/splint-3.1.2
=kde-base/kdebase-pam-7
=media-libs/ftgl-2.1.3_rc5
=media-libs/libdv-1.0.0-r2
=media-libs/libmpeg2-0.5.1
=net-mail/mailbase-1
=net-misc/netkit-telnetd-0.17-r8
=sys-devel/autoconf-2.13
=sys-process/cronbase-0.3.2-r1
=sys-process/vixie-cron-4.1-r10
=virtual/cdrtools-0
=virtual/httpd-cgi-0
=virtual/libstdc++-3.3


and these settings looks ok :

tfoerste@n22 ~ $ grep -i cca /etc/make.conf
CCACHE_SIZE="2G"
FEATURES="parallel-fetch ccache compress-build-logs"
Comment 3 Rafał Mużyło 2011-06-16 17:56:43 UTC
I've seen that message for a few packages too.
ccache itself seems to work fine.

I'm not setting CCACHE_DIR for portage, relying on the default values.

That message seems to appear only before src_compile phase - probably one of eclasses circumvents silencing.
Comment 4 Zac Medico gentoo-dev 2011-06-16 19:29:36 UTC
Created attachment 277283 [details, diff]
skip CCACHE_DIR for pkg_info

Save as /tmp/pkg_info_ccache.patch and apply as follows:

  patch /usr/lib/portage/pym/portage/package/ebuild/prepare_build_dirs.py /tmp/pkg_info_ccache.patch
Comment 5 Toralf Förster gentoo-dev 2011-06-16 19:47:46 UTC
patch works
Comment 6 Zac Medico gentoo-dev 2011-07-01 05:07:45 UTC
Thanks for testing. This is in 2.2.0_alpha42, but I'll leave this bug open until it's in an unmasked release.
Comment 7 Zac Medico gentoo-dev 2011-07-03 17:33:01 UTC
This is fixed in 2.1.10.4.