Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 37146 - sys-libs/db-4.0.14-r2 Fails to Compile....looking for
Summary: sys-libs/db-4.0.14-r2 Fails to Compile....looking for
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Java team
Depends on:
Reported: 2004-01-03 15:05 UTC by Charles Becker
Modified: 2004-07-16 04:33 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Charles Becker 2004-01-03 15:05:00 UTC
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking whether -lc should be explicitly linked in... no
creating libtool
checking SOSUFFIX from libtool... so
checking if javac works... configure: error: The Java compiler javac failed
 config.log, check the CLASSPATH?)

!!! ERROR: sys-libs/db-4.0.14-r2 failed.
!!! Function src_compile, Line 67, Exitcode 1
!!! (no error message)

from config.log

configure:8781: result: so
configure:8943: checking if javac works
configure:8957: javac
Error: failed /opt/blackdown-jdk-1.4.1/jre/lib/i386/client/, because cannot open shared object file: No such file or directory
configure:8960: $? = 6
configure:8964: error: The Java compiler javac failed (see config.log, check the CLASSPATH?)

Reproducible: Always
Steps to Reproduce:
1.emerge db

As I understand it the libary that it is looking for is part of
gcc. Possibly a different version that I have?? I have 2.95.3-r8. At any rate
because of this I can not update my system.
Comment 1 SpanKY gentoo-dev 2004-01-03 15:08:52 UTC
what if you emerge lib-compat ?
Comment 2 Paul de Vrieze (RETIRED) gentoo-dev 2004-01-04 06:06:53 UTC
Yes, with this version of blackdown you need to have >gcc-3 preferably 3.2 or later. Another option is to use the sun jdk's (they don't depend on gcc directly, except for the mozilla plugin) or an older blackdown jdk that was built with gcc-2.95.3

In any case you probably will not be using java in sys-libs/db anyway, as there are no portage packages actually using this. (so it's only nice for development). You can merge db with "USE=-java emerge \<sys-libs/db-4.1"
Comment 3 Thomas Matthijs (RETIRED) gentoo-dev 2004-07-16 04:33:25 UTC
upgrade or use a diffrend jdk or reopen with more info