Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 370767 - net-misc/nx-3.5.0.32 fails to build with sys-libs/glibc-2.26
Summary: net-misc/nx-3.5.0.32 fails to build with sys-libs/glibc-2.26
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Bernard Cafarelli
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-rpc
  Show dependency tree
 
Reported: 2011-06-09 09:30 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2017-11-13 12:18 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (nx-3.5.0:20110609-073127.log,738.54 KB, text/plain)
2011-06-09 09:30 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2011-06-09 09:30:36 UTC
Created attachment 276343 [details]
Build log

Portage 2.1.10 (default/linux/x86/10.0, gcc-4.6.0-asneeded, glibc-2.14-r0, 2.6.39 i686)
=================================================================
System uname: Linux-2.6.39-i686-Quad-Core_AMD_Opteron-tm-_Processor_2350-with-gentoo-2.0.2
Timestamp of tree: Mon, 06 Jun 2011 20:30:01 +0000
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.2
dev-util/cmake:           2.8.4-r1
sys-apps/baselayout:      2.0.2
sys-apps/openrc:          0.8.2-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21
sys-devel/gcc:            4.6.0
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82
sys-kernel/linux-headers: 2.6.38 (virtual/os-headers)
sys-libs/glibc:           2.14
Repositories: gentoo
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/tomoyo/conf /usr/share/bufrtables /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.0/conf /usr/share/openvpn/easy-rsa /usr/share/qpsmtpd/plugins /var/lib/hsqldb /var/phxd /var/qmail/alias /var/qmail/control /var/yp/Makefile"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/games/angband/edit/ /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/var/cache/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms split-log strict test test-fail-continue unknown-features-warn unmerge-orphans userfetch userpriv usersandbox"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.wheel.sk/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j14"
PKGDIR="/var/spool/portage/packages"
PORTAGE_COMPRESS=""
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/cache/portage/tree"
PORTDIR_OVERLAY=""
SYNC="rsync://yamato.home.flameeyes.eu/gentoo-portage"
USE="acl berkdb bzip2 cli cracklib crypt cups cxx dri fortran gdbm gpm iconv ipv6 java5 java6 modules mudflap mysql ncurses nls nostatic nptl nptlonly openmp pam pcre pcsc-lite perl postgres pppd python qt3support readline ruby semantic-desktop session ssl sysfs tcpd unicode vhosts x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias auth_digest cgi" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18 jruby ruby19 ree18" USERLAND="GNU" VIDEO_CARDS="intel radeon nouveau vmware" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Bernard Cafarelli gentoo-dev 2011-06-10 11:36:33 UTC
> ConnDis.c:826:21: fatal error: rpc/rpc.h: No such file or directory

I guess we'll have to patch nx-X11 lib/X11/Imakefile to point to libtirpc headers/libs...
Comment 2 fkater 2015-03-27 10:46:24 UTC
I doubt we need the dependency to glibc-2.14.

We ran nx for months against glibc-2.19, now glibc-2.20 without
issues.

However, we always have to ignore that dependency again and again
when compiling portage stuff.

Please verify if we can drop that old dependency.
Comment 3 Bernard Cafarelli gentoo-dev 2015-03-27 14:46:50 UTC
Hmm the "elibc_glibc? ( || ( net-libs/libtirpc <sys-libs/glibc-2.14 ) )" was only supposed to go in the ebuild when migrated to libtirpc, but it looks like I committed it accidentally a long time ago.

Dropped from the current ebuilds, thanks for the report!
Comment 4 Andreas K. Hüttel gentoo-dev 2017-09-16 18:42:29 UTC
OK this now becomes important again.

ConnDis.c:826:21: fatal error: rpc/rpc.h: No such file or directory
 #include <rpc/rpc.h>

I have no clue about IMake. However, what you need to do is (ideally only for libc >= 2.26): find include paths and library names of libtirpc, and add one to the CFLAGS, the other to the libraries to link.

See https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d57c699afeb1df34ac362f360473ea81258df3ab for a simple (and therefore very much imperfect) autoconf example.
Comment 6 Bernard Cafarelli gentoo-dev 2017-11-08 11:35:22 UTC
Sorry for the delay, I am working on a version bump that will also fix this problem.

After checking the related NX parts, SunRPC is not needed (code is here as it is based on old xorg), so I will disable it entirely.

net-misc/nx-3.5.0.33 will be the first version to have this setting (with a few other changes), if all goes well, I'll send it for a stabilization round after usual waiting time
Comment 7 Larry the Git Cow gentoo-dev 2017-11-08 12:58:01 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b7f4405d0aad895d17346e9ab22eb9538f12e3d2

commit b7f4405d0aad895d17346e9ab22eb9538f12e3d2
Author:     Bernard Cafarelli <voyageur@gentoo.org>
AuthorDate: 2017-11-08 12:55:53 +0000
Commit:     Bernard Cafarelli <voyageur@gentoo.org>
CommitDate: 2017-11-08 12:57:51 +0000

    net-misc/nx: 3.5.0.33 bump
    
    Update ebuild EAPI, safe directory changes
    Follow upstream compilation steps
    Limit X11 elements build list
    Drop obsolete patches and warning
    Disable SunRPC build, not used for NX and not supporting libtirpc
    
    Bug: https://bugs.gentoo.org/370767
    Bug: https://bugs.gentoo.org/630492
    Package-Manager: Portage-2.3.13, Repoman-2.3.4

 net-misc/nx/Manifest           |   1 +
 net-misc/nx/nx-3.5.0.33.ebuild | 102 +++++++++++++++++++++++++++++++++++++++++
 2 files changed, 103 insertions(+)}
Comment 8 Bernard Cafarelli gentoo-dev 2017-11-13 12:18:22 UTC
Confirmed 3.5.0.33 works fine on my setup with unmasked glibc-2.26-r3