Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 370191 - =www-apps/viewvc-1.1.11 problem with =webapp-config-1.50.18
Summary: =www-apps/viewvc-1.1.11 problem with =webapp-config-1.50.18
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Web Application Packages Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-05 21:10 UTC by Kobboi
Modified: 2013-08-03 14:23 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kobboi 2011-06-05 21:10:21 UTC
Running amd64, I upgraded webapp-config to the latest unstable version, because of the /sbin/functions.sh issue (see other bug dating back to 2008 but still not fixed). Unfortunately, this again leads to problems:

>>> Installing (2 of 2) www-apps/viewvc-1.1.11
Usage: webapp-config [-ICU] [-dghus] <APPLICATION VERSION>

Options:
  --version             show program's version number and exit

  APPLICATION VERSION:
    The name and version number of the web application to install e.g.
    phpmyadmin 2.5.4. TheAPPLICATION must have already been installed into
    the /usr/share/webapps directory tree using emerge

  <Main Options>:
    -I, --install       Install a web application
    -C, --clean         Remove a web application
    -U, --upgrade       Upgrade a web application

  <Installation Location>:
    -h HOST, --host=HOST
                        The hostname to configure this application to serve.
                        Also affects where some files go. If you get this
                        setting wrong, you may need to re-install the
                        application to correct the problem! Default is HOST =
                        localhost. To change the default, change the value of
                        "vhost_hostname" in /etc/vhosts/webapp-config <NOTE>:
                        if the default value is currently "localhost", that
                        probably means that this computer's /etc/hosts file is
                        not correctly configured
    -d DIR, --dir=DIR   Install <application> into DIR under the htdocs dir.
                        The default is /
    -s SERVER, --server=SERVER
                        Specify which web SERVER to install the application to
                        run under. Use webapp-config --list-servers to see
                        supported web servers. The default is -s apache. To
                        change the default, change the value of VHOST_SERVER
                        in /etc/vhosts/webapp-config
    --secure            Install, upgrade, or clean files in htdocs-secure
                        rather than in the htdocs directory.

  <Installation Options>:
    -u USER, --user=USER
                        Install config files so that they can be edited by
                        USER. USER can be a username.Numerical user ids are
                        NOT supported. Default is USER = 0 To change the
                        default, change the value of VHOST_CONFIG_UID in
                        /etc/vhosts/webapp-config
    -g GROUP, --group=GROUP
                        Install config files so that they can be edited by
                        GROUP. GROUP can be a group name. Numerical group ids
                        are NOT supported.Default is GROUP = 0To change the
                        default, change the value of VHOST_CONFIG_GID in
                        /etc/vhosts/webapp-config
    --soft              Use symbolic links instead of hard links when creating
                        virtual files. <NOTE>: some packages will not work if
                        you use this option
    --virtual-files=VIRTUAL_FILES, --vf=VIRTUAL_FILES
                        Decide what happens when we're installing a file that
                        could be shared (ie, one we wouldn't normally create a
                        local copy of). VIRTUAL_FILES must be one of: "server-
                        owned" [files are owned by the user and group thatthe
                        web-server runs under], "config-owned" [files are
                        owned by the user and group specified by the -u and -g
                        switches to this script],"virtual" [files are shared;
                        a local copy is not created]. Default is virtual. To
                        change these defaults, change the value of
                        VHOST_CONFIG_VIRTUAL_FILES in /etc/vhosts/webapp-
                        config <NOTE>: Some -s <server> options may not
                        support all values of VIRTUAL_FILES and will report an
                        error
    --default-dirs=DEFAULT_DIRS, --dd=DEFAULT_DIRS
                        Decide what happens when we're installing a directory
                        that could be shared (ie, one we wouldn't normally
                        create a local copy of). DEFAULT_DIRS must be one of:
                        "server-owned" [dirs are owned by the user and group
                        thatthe web-server runs under], "config-owned" [dirs
                        are owned by the user and group specified by the -u
                        and -g switches to this script],"default-owned" [dirs
                        are owned by the user specified in
                        VHOST_DEFAULT_UID:VHOST_DEFAULT_GID]. Default is
                        default-owned. To change these defaults, change the
                        value of VHOST_CONFIG_DEFAULT_DIRS in /etc/vhosts
                        /webapp-config <NOTE>: Some -s <server> options may
                        not support all values of DEFAULT_DIRS and will report
                        an error

  <Information Options>:
    --pretend           Output information about what webapp-config would do,
                        then quit without actually doing it
    -V, --verbose       Output even more information than normal
    --list-servers, --ls
                        List all web servers currently supported by webapp-
                        config
    --list-installs, --li
                        List all current virtual installs for <application>.
                        Use * for the package name and/or version number to
                        list more thanone package / version of a package.
                        Remember to include the * in single quotes to stop
                        your shell from expanding it first!!
    --list-unused-installs, --lui
                        List all master images which currently are not used.
                        Use * for the package name and/or version number to
                        list more than one package / version of a package.
                        Remember to include the * in single quotes to stop
                        your shell from expanding it first!!
    --show-installed, --si
                        Show what application is installed in DIR
    --show-postinst, --spi
                        Show the post-installation instructions for
                        <application>. Very handy if you've lost the
                        instructions when they were shown to you ;-)
    --show-postupgrade, --spu
    --query             

  <Other Options>:
    -D DEFINE, --define=DEFINE
                        Allows to name a <KEY>=<VALUE> pair thatwill be
                        imported into the configuration variables of webapp-
                        config. This allows you to provide customized
                        variables which can be used in the configuration file.
                        This can also be used to temporarily overwrite
                        variables from the configuration file.
    -E ENVVAR, --envvar=ENVVAR
                        Allows to name single environment variable that will
                        be imported by webapp-config. This allows you to
                        provide customized variables which can be used in the
                        configuration file. This can also be used to
                        temporarily overwrite variables from the configuration
                        file.
    --envall            Imports all environment variables and overwrites
                        configurations read from the configuration file.
                        Setting this switch is not recommended since you might
                        have environment variables set to values that cannot
                        be parsed.
    -?, --help          Show this help

  <Debugging options>:
    Control the debugging features of webapp-config

    --debug             Activates debugging features.
    --debug-level=DEBUG_LEVEL
                        A value between 0 and 10. 0 means no debugging
                        messages will be selected, 10 selects all debugging
                        messages. Default is "4".
    --debug-verbose=DEBUG_VERBOSE
                        A value between 1 and 3. Lower values yield less
                        verbose debugging output. Default is "2".
    --debug-methods=DEBUG_METHODS
                        Limits the methods that will return debugging output.
                        The function name is sufficient and there is
                        nodifference between class methods or general
                        functions. Several methods can be specified by
                        seperating them w with a comma. Default is "*" which
                        specifies all methods.
    --debug-classes=DEBUG_CLASSES
                        Limits the classes that will return debugging output.
                        Specify only the class name not including the modules
                        in which the class is defined (e.g. MyModule.main.Main
                        should only be represented by "Main"). Severalclasses
                        can be specified by seperating them with a comma.
                        Default is "*" which specifies all classes.
    --debug-variables=DEBUG_VARIABLES
                        Limits the variables that will return debugging
                        output. Several variables can be specified by
                        seperating them with a comma. Default is "*" which
                        specifies all variables.
    --debug-class-vars  In default mode the debugging code will only return
                        information on the local variable which does not
                        include the class variables. Use this switch to add
                        all values that are provided by "self".
    --debug-nocolor     Deactivates colors in the debugging output.

  <Reporting Bugs>:
    To report bugs about webapp-config, please go to
    http://bugs.gentoo.org/. Include the output of webapp-config --bug-
    report <your parameters here> to help us to help you

    --bug-report        
* Fatal error: You need to specify at least the application you would like to handle!
* Fatal error(s) - aborting
 * Compilation and optimization of Python modules for CPython 2.7 ...                                                       [ ok ]

 * vhosts USE flag not set - auto-installing using webapp-config
 * This is a re-installation
 * viewvc-1.1.11 is already installed - replacing
 * Running /usr/sbin/webapp-config -I -h localhost -u root -d /viewvc viewvc 1.1.11
* Fatal error: Package viewvc-1.1.11 is already installed here.
* Fatal error: Use webapp-config -C to uninstall it first.
* Fatal error: Install directory already contains a web application!
* Fatal error(s) - aborting

 * Running /usr/sbin/webapp-cleaner -p -C viewvc
 * Package name must be in the form CATEGORY/PN
 * Now read INSTALL in /usr/share/doc/viewvc-1.1.11 to configure viewvc


Reproducible: Always
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2012-02-21 14:00:57 UTC
From what I can tell, this is a problem with webapp.eclass
Comment 2 Devan Franchini (RETIRED) gentoo-dev 2013-05-25 02:43:32 UTC
The latest viewvc (1.1.17) installs correctly using the latest webapp-config from the git HEAD.
Comment 3 Anthony Basile gentoo-dev 2013-08-03 14:23:57 UTC
(In reply to Devan Franchini from comment #2)
> The latest viewvc (1.1.17) installs correctly using the latest webapp-config
> from the git HEAD.

thanks