Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 369305 - media-gfx/cellwriter fails because of underlinking
Summary: media-gfx/cellwriter fails because of underlinking
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords:
: 505560 (view as bug list)
Depends on: 457080
Blocks: underlinking
  Show dependency tree
 
Reported: 2011-05-30 10:42 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2014-03-30 17:51 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (cellwriter-1.3.4:20110530-021611.log,14.38 KB, text/plain)
2011-05-30 10:42 UTC, Diego Elio Pettenò (RETIRED)
Details
Ebuild patch (cellwriter-1.3.4.ebuild.patch,630 bytes, patch)
2014-02-08 17:03 UTC, Guenther Brunthaler
Details | Diff
Adds a check for adding the missing library to configure.ac (cellwriter-1.3.4-underlinking.patch,402 bytes, patch)
2014-02-08 17:05 UTC, Guenther Brunthaler
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2011-05-30 10:42:19 UTC
Created attachment 275149 [details]
Build log

Hello there!

You're getting this bug because the package in Summary failed to build in my tinderbox using the gold link editor from binutils. Before closing the bug as INVALID let me explain why this is still important!

The gold link editor does not support underlinking of shared objects, which is something I have described in my blog post:

http://blog.flameeyes.eu/2010/11/26/it-s-not-all-gold-that-shines-why-underlinking-is-a-bad-thing

Even the basic link editor (ld.bfd) has an option to support this but it is a heck to enable and get passed, so linking with gold is simply quicker.

Fixing underlinking provides optimized --as-needed builds (because the "softer" version no longer need to recover libraries that are underlinked), so it is a Good Thing To Do.

Thank you very much for the attention!
Comment 1 Berthold Humkamp 2014-01-06 09:14:43 UTC
I had a few packages with similar errors in the last 2 weeks, seems as if they occure since I use gcc-4.7.3.

In one of them the solution was, to avoid underlinking:

LDFLAGS="-lm" emerge gnome-alsamixer

Worked for me without errors, but this is just a workaround, not the solution, because underlinking will be the default in the future, to avoid unneeded package dependencies. 

The package, better the source, has to be fixed in the way, giving explicitly the needed libs in the right order to the linker command, so that underlinking will work in the future.
Comment 2 Guenther Brunthaler 2014-02-08 17:03:07 UTC
Created attachment 369896 [details, diff]
Ebuild patch

autoreconfigs before ./configure in order to make use of the configure.ac patch.
Comment 3 Guenther Brunthaler 2014-02-08 17:05:22 UTC
Created attachment 369898 [details, diff]
Adds a check for adding the missing library to configure.ac

Put this patch in ${FILESDIR} after applying the ebuild patch. Together, they fix the underlinking problem.
Comment 4 Samuli Suominen gentoo-dev 2014-03-30 17:42:35 UTC
*** Bug 505560 has been marked as a duplicate of this bug. ***
Comment 5 Samuli Suominen gentoo-dev 2014-03-30 17:51:29 UTC
Fixed in 1.3.5 by upstream