Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 368835 - app-admin/sysklogd - no way to disable startup of klogd when sysklogd is used in a vserver
Summary: app-admin/sysklogd - no way to disable startup of klogd when sysklogd is used...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-27 01:52 UTC by R. David Murray
Modified: 2015-08-24 11:31 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info from vserver instance (temp,6.45 KB, text/plain)
2011-05-31 23:48 UTC, R. David Murray
Details

Note You need to log in before you can comment on or make changes to this bug.
Description R. David Murray 2011-05-27 01:52:08 UTC
I upgraded one of my vserver instances to baselayout-2.0.2 and sysklogd 1.5-r1 (previously it was running stable), and during startup it hung trying to start klogd.  There appears to be no way to prevent the init script from trying to start klogd (it isn't needed when run inside a vserver).

Reproducible: Always
Comment 1 R. David Murray 2011-05-27 01:53:38 UTC
Ah, when I said "no way", I meant from /etc/conf.d/sysklogd.  Obviously I edited the init script directly to get my vserver instance to boot.
Comment 2 Jeroen Roovers gentoo-dev 2011-05-31 20:19:39 UTC
That must be because it has "provide logger" and because something else has "need logger" or similar.
Comment 3 Jeroen Roovers gentoo-dev 2011-05-31 20:20:00 UTC
Oh, and please post your `emerge --info' output too.
Comment 4 R. David Murray 2011-05-31 23:42:27 UTC
No, the issue that sysklogd has two deamons: the regular logger, and the kernel logger.  On a vserver, the kernel logger fails.  It used to be that that was fine, it just failed, and initialization continued with only the regular deamon running.  Now, however, initialization hangs when the kernel logger fails to start.

What is needed is a change to the /etc/init.d/sysklogd script so that it will accept a variable in /etc/conf.d/sysklogd that controls whether or not an attempt to start the kernel logger is even made.  The regular logger should continue to be influenced by requires/provides as it is now.

I'll attach my emerge --info but only so you can see which version I'm on where startup hangs.
Comment 5 R. David Murray 2011-05-31 23:48:08 UTC
Created attachment 275417 [details]
emerge --info from vserver instance
Comment 6 Patrice Clement gentoo-dev 2015-08-24 11:31:02 UTC
I haven't been able to reproduce this issue. I use sysklogd in a vserver guest and unless I specifically add it manually to the boot sequence with rc-update, it doesn't start automatically. Please reopen and give us with more info.