Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 368473 - sci-biology/hmmer-3.0 fails to build with "mpi.c:27:23: error: impl_dummy.: No such file or directory"
Summary: sci-biology/hmmer-3.0 fails to build with "mpi.c:27:23: error: impl_dummy.: N...
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Science Biology related packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-23 15:57 UTC by Willard Dawson
Modified: 2014-03-30 07:17 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Emerge info (emerge-info,5.39 KB, text/plain)
2011-05-23 15:58 UTC, Willard Dawson
Details
Emerge -pqv (emerge-pqv,71 bytes, text/plain)
2011-05-23 15:58 UTC, Willard Dawson
Details
Build log (build.log,15.04 KB, text/plain)
2011-05-23 15:58 UTC, Willard Dawson
Details
Ebuild environment (environment,81.75 KB, text/plain)
2011-05-23 15:58 UTC, Willard Dawson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Willard Dawson 2011-05-23 15:57:37 UTC
I'm attempting to convert to hardened / selinux using the instructions at http://www.gentoo.org/proj/en/hardened/selinux/selinux-handbook.xml?part=2&chap=1. At "Code Listing 2.3: Update your Gentoo Linux system," `emerge -uDN world`:

mpicc -std=gnu99 -march=native -O2 -pipe -pthread   -DHAVE_CONFIG_H  -I../../easel -I../../easel -I. -I.. -I. -I../../src -c p7_oprofile.c
mpicc -std=gnu99 -march=native -O2 -pipe -pthread   -DHAVE_CONFIG_H  -I../../easel -I../../easel -I. -I.. -I. -I../../src -c mpi.c
mpi.c:27:23: error: impl_dummy.: No such file or directory
mpi.c: In function 'p7_oprofile_MPIRecv':
mpi.c:133: warning: passing argument 4 of 'p7_profile_MPIRecv' from incompatible pointer type
../hmmer.h:931: note: expected 'const struct ESL_ALPHABET *' but argument is of type 'struct ESL_ALPHABET **'
make[1]: *** [mpi.o] Error 1
make[1]: Leaving directory `/var/tmp/portage/sci-biology/hmmer-3.0/work/hmmer-3.0/src/impl_dummy'
make: *** [impl_lib] Error 2
emake failed


Reproducible: Always

Steps to Reproduce:
1.emerge -uDN world
2.
3.



See attachments.
Comment 1 Willard Dawson 2011-05-23 15:58:00 UTC
Created attachment 274403 [details]
Emerge info
Comment 2 Willard Dawson 2011-05-23 15:58:17 UTC
Created attachment 274405 [details]
Emerge -pqv
Comment 3 Willard Dawson 2011-05-23 15:58:33 UTC
Created attachment 274407 [details]
Build log
Comment 4 Willard Dawson 2011-05-23 15:58:52 UTC
Created attachment 274409 [details]
Ebuild environment
Comment 5 Willard Dawson 2011-06-21 09:31:43 UTC
I gave up on making hardened profile work as a Virtualbox guest... too many
issues and not enough time on my part.
Comment 6 Willard Dawson 2014-03-29 14:45:19 UTC
OMG this is an old bug.  Close it, please, unless someone has it as a problem still...
Comment 7 Justin Lecher gentoo-dev 2014-03-30 07:17:50 UTC
cannot reproduce it here.