Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 36839 - gvim-6.2-r5: When opening a new file, the file dialog is empty
Summary: gvim-6.2-r5: When opening a new file, the file dialog is empty
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High minor (vote)
Assignee: Vim Maintainers
Depends on:
Reported: 2003-12-30 13:10 UTC by Christopher Eineke
Modified: 2004-01-05 14:56 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Eineke 2003-12-30 13:10:17 UTC
When I open a file in gvim the "Edit File" dialog correctly shows the "Directories" and "Files" list. But when I want to open another file, the "Files" list is empty.

Reproducible: Always
Steps to Reproduce:
1. Open a file in gvim.
2. Open another file.

Actual Results:  
The list containing the files is empty although there are files in the current
directory. One can fix that by cycling through the widgets.

Expected Results:  
Show the files contained in the directory.

Gentoo Base System version
Portage 2.0.49-r18 (default-x86-1.4, gcc-3.3.2, glibc-2.3.3_pre20031222-r0, 2.6.0)
System uname: 2.6.0 i686 AMD Athlon(tm) XP 1800+
CFLAGS="-march=athlon-xp -Os -pipe -fomit-frame-pointer -mfpmath=sse -msse -mmmx
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3/share/config /usr/share/config /usr/share/texmf/dvipdfm/config/
/usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-march=athlon-xp -Os -pipe -fomit-frame-pointer -mfpmath=sse -msse
-mmmx -m3dnow"
FEATURES="autoaddcvs ccache sandbox"
USE="3dnow S3TC X Xaw3d aalib aavm alsa amd apache2 apm autofs avi bindist caps
cdr crypt cscope cups curl dedicated diet directfb dv dvd encode esd evms2
ext-png ext-zlib faad fbcon ffmpeg fftw flac flash fltk fluidsynth foomaticdb
fusion gd gd-external gif glut gphoto2 gpm gstreamer gtk gtk2 guile hbci hyriand
imagemagick imlib imlib2 jack jack-caps jack-tmpfs java jikes joystick jpeg
ladcca lcms libwww lufsusermount mad matroska md5sum mikmod mmx mng motif mpeg
mpeg4 mpi nas ncurses nls nocardbus nvidia nviz objc offensive oggvorbis opengl
openssh oss pam parse-clocks pdflib perl physfs pic png psyco python qt
quicktime readline regexp rplay samba sasl sdl slang slp snmp speex spell sse
ssl stencil-buffer svga tcpd tetex tiff transcode truetype usb wmf wxwin
wxwindows x86 xchattext xfs xml xml2 xmms xv xvid zlib"
Comment 1 Ryan Phillips (RETIRED) gentoo-dev 2003-12-30 16:39:25 UTC
I do not have this problem with -r5 on a similar setup.  Can anyone replicate the behavior?

Christopher: Have you tried the 'stock' CFLAGS? atleast: -O2 -pipe -fomit-frame-pointer
Comment 2 Christopher Eineke 2003-12-30 20:32:12 UTC
Hi Ryan,

I just tried with stock flags and it works. But I would like to add on a sidenote, that both, directories and files, didn't show up.

So is this a case of too aggressive compiler optimization?
Comment 3 Christopher Eineke 2003-12-30 20:44:02 UTC
I dropped "-mfpmath=sse -msse -mmmx -m3dnow" from my CFLAGS and it works now. So it may be a compiler issue...
Comment 4 Ryan Phillips (RETIRED) gentoo-dev 2004-01-05 14:56:04 UTC
I'm guessing it is is a compiler issue due to the CFLAGS, and am closing this bug.