Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 368315 - media-libs/lensfun-0.2.5-r1 with libpng-1.5 - libs/auxfun/image.cpp:97: error: invalid use of incomplete type 'struct png_struct_def'
Summary: media-libs/lensfun-0.2.5-r1 with libpng-1.5 - libs/auxfun/image.cpp:97: error...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Graphics Project
URL: https://developer.berlios.de/bugs/?fu...
Whiteboard:
Keywords: Bug
Depends on:
Blocks: libpng-1.5
  Show dependency tree
 
Reported: 2011-05-22 08:41 UTC by renato gallo
Modified: 2011-08-07 09:10 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,6.36 KB, text/plain)
2011-05-22 08:41 UTC, renato gallo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description renato gallo 2011-05-22 08:41:43 UTC
Created attachment 274249 [details]
build.log

>>> Compiling source in /var/tmp/portage/media-libs/lensfun-0.2.5-r1/work/lensfun-0.2.5 ...
make all V=1 
mkdir -p out/posix.x86_64/release
mkdir -p out/posix.x86_64/release/docs
mkdir -p out/posix.x86_64/release/include/lensfun
mkdir -p out/posix.x86_64/release/libs/auxfun
mkdir -p out/posix.x86_64/release/libs/lensfun
mkdir -p out/posix.x86_64/release/tests/example
mkdir -p out/posix.x86_64/release/tests/tfun
mkdir -p out/posix.x86_64/release/tests/tmod
mkdir -p out/posix.x86_64/release/tests/trwxml
mkdir -p out/posix.x86_64/release/tools/makedep
g++ -c -o out/posix.x86_64/release/libs/auxfun/image.o -pipe -Wall -Iinclude -Iinclude/auxfun -Iinclude/lensfun -O2 -pipe -march=native -O2 -pipe -march=native -fvisibility=hidden -Wno-non-virtual-dtor -I/usr/include/libpng15 libs/auxfun/image.cpp
libs/auxfun/image.cpp: In member function 'bool Image::LoadPNG()':
libs/auxfun/image.cpp:97: error: invalid use of incomplete type 'struct png_struct_def'
/usr/include/libpng15/png.h:811: error: forward declaration of 'struct png_struct_def'
libs/auxfun/image.cpp:160: error: invalid use of incomplete type 'struct png_struct_def'
/usr/include/libpng15/png.h:811: error: forward declaration of 'struct png_struct_def'
libs/auxfun/image.cpp: In member function 'bool Image::SavePNG(const char*)':
libs/auxfun/image.cpp:217: error: invalid use of incomplete type 'struct png_struct_def'
/usr/include/libpng15/png.h:811: error: forward declaration of 'struct png_struct_def'
libs/auxfun/image.cpp:277: error: invalid use of incomplete type 'struct png_info_def'
/usr/include/libpng15/png.h:678: error: forward declaration of 'struct png_info_def'
libs/auxfun/image.cpp:278: error: invalid use of incomplete type 'struct png_info_def'
/usr/include/libpng15/png.h:678: error: forward declaration of 'struct png_info_def'
make: *** [out/posix.x86_64/release/libs/auxfun/image.o] Error 1
emake failed
 * ERROR: media-libs/lensfun-0.2.5-r1 failed (compile phase):
Comment 1 renato gallo 2011-05-22 08:42:17 UTC
emerge --info
Portage 2.1.9.42 (default/linux/amd64/10.0, gcc-4.4.5, libc-0-r0, 2.6.38-gentoo-r3 x86_64)
=================================================================
System uname: Linux-2.6.38-gentoo-r3-x86_64-Intel-R-_Core-TM-_i5_CPU_760_@_2.80GHz-with-gentoo-2.0.2
Timestamp of tree: Sat, 21 May 2011 16:15:01 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.7.1-r1, 3.1.3-r1
dev-util/cmake:      2.8.4-r1
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.8.2-r1::poly-c
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5
sys-devel/gcc-config: 1.4.1-r1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
sys-kernel/linux-headers: 2.6.36.1
sys-libs/glibc:      2.11.3
virtual/os-headers:  0
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.switch.ch/ftp/mirror/gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="nb"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/luksans-arduino /var/lib/layman /var/lib/layman/vmware /var/lib/layman/zugaina /var/lib/layman/wirelay /var/lib/layman/stuff /var/lib/layman/sabayon /var/lib/layman/nikai /var/lib/layman/dev-zero /var/lib/layman/pentoo /var/lib/layman/damex-overlay /var/lib/layman/nelchael /var/lib/layman/pcsx2 /var/lib/layman/poly-c /var/lib/layman/sunrise /var/lib/layman/amielke-overlay /var/lib/layman/benf"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac aacs aalib acl alsa amd64 apng ares atmo auto-hinter bash-completion berkdb bidi bittorrent bl bluetooth bluray bs2b bzip2 cairo cdda cddb cdparanoia cdr cjk cli cracklib crypt cups curl cxx dbus dc1394 desktopglobe devfs-compat device-mapper dga dirac directfb dri dts dv dvb dvd dvdr eds encode examples exif expat extras faac fbcon ffmpeg flac fluidsynth fontconfig fontforge foomaticdb fortran frei0r ftp gd gdbm gdu ggi gif gimp gles glsl gme gnome gnome-keyring gphoto2 gpm gsm gstreamer gtk httpd iconv id3tag ieee1394 imagemagick ipod ipv6 java jce jpeg jpeg2k kate kde kdrive ladspa lame lapack lcms ldap libass libcaca libmpeg2 libnotify libproxy libtiger libv4l2 lirc live lua lzma lzo mad matroska md5sum metalink mjpeg mmx mng modplug modules mp3 mpeg mpg123 mtp mudflap multilib musepack musicbrainz nas nautilus ncurses network nls nptl nptlonly nsplugin nspluginwrapper nut nuv odbc odk ogg openexr opengl openmp openvg optimisememory oss pam pango pasteafter pcre pdf perl phonon php plasma playlist png pnm postproc ppds pppd projectm ps pvr python qalculate qt-faststart qt4 quicktime qwt radio raw readline reiserfs remoteosd rtmp rtsp run-as-root samba schroedinger scim screensaver script scripts sdk sdl sdl-image semantic-desktop session shine shout skins smp sqlite sse sse2 ssl ssse3 startup-notification stream svg sysfs system-libvncserver taglib tcpd templates tga theora threads tiff tilepath tk tools truetype truetype-debugger twolame type3 udev unicode upnp usb utils v4l2 vaapi vcdx vdpau vix vlm vmware_guest_freebsd vmware_guest_linux vmware_guest_netware vmware_guest_solaris vmware_guest_winPre2k vmware_guest_windows vorbis vpx webkit wma-fixed wmf x264 xanim xcb xine xinerama xml xmlrpc xmp xorg xosd xv xvid xvmc yv12 zlib zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2 adc65 agfa_cl20 aox ax203 barbie canon casio_qv clicksmart310 digigr8 digita dimagev dimera3500 directory enigma13 fuji gsmart300 hp215 iclick jamcam jd11 jl2005a kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 konica konica_qm150 largan lg_gsm mars mustek panasonic_coolshot panasonic_dc1000 panasonic_dc1580 panasonic_l859 pccam300 pccam600 polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ricoh ricoh_g3 samsung sierra sipix_blink sipix_blink2 sipix_web2 smal sonix sony_dscf1 sony_dscf55 soundvision spca50x sq905 st2205 stv0674 stv0680 sx330z template topfield toshiba_pdrm11" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="nb" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 renato gallo 2011-05-22 09:09:05 UTC
this blocks media-gfx/ufraw-0.17 and media-gfx/ufraw-0.18
Comment 3 Alessandro Surace 2011-06-29 20:13:25 UTC
Same problem here.

It builds correctly with media-libs/libpng-1.4.7.
Comment 4 renato gallo 2011-06-30 22:31:42 UTC
(In reply to comment #3)
> Same problem here.
> 
> It builds correctly with media-libs/libpng-1.4.7.

the problem is with libpng-1.5
Comment 5 Samuli Suominen gentoo-dev 2011-08-07 09:10:22 UTC
+*lensfun-0.2.5-r2 (07 Aug 2011)
+
+  07 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> +lensfun-0.2.5-r2.ebuild,
+  +files/lensfun-0.2.5-libpng15.patch:
+  Fix building with libpng15 wrt #368315 with NetBSD patch.