Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 367975 - app-misc/tracker links against installed libs instead of the one it builds
Summary: app-misc/tracker links against installed libs instead of the one it builds
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Freedesktop bugs
URL:
Whiteboard: Possible workaround in comment #44
Keywords:
: 416899 440890 441568 449022 465464 467990 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-19 01:36 UTC by Harris Landgarten
Modified: 2013-05-02 08:03 UTC (History)
18 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
tracker-0.10.12 build log (1305767549-install-app-misc_tracker-0.10.12:0::gentoo.out,70.03 KB, application/x-extension-out)
2011-05-19 01:38 UTC, Harris Landgarten
Details
emerge --info (emerge__info.out,13.19 KB, application/x-extension-out)
2011-05-20 11:04 UTC, Attila Stehr
Details
tracker build log (build.log,57.06 KB, text/x-log)
2011-06-08 04:13 UTC, Alex
Details
app-misc/tracker-0.14.3 build log (build.log,74.54 KB, text/plain)
2012-10-31 16:49 UTC, Attila Stehr
Details
USE flags (file_367975.txt,1.06 KB, text/plain)
2012-10-31 16:51 UTC, Attila Stehr
Details
emerge w/ --debug (app-misc:tracker-0.14.3:20121031-190725.log.xz,66.89 KB, text/plain)
2012-10-31 19:17 UTC, Attila Stehr
Details
xz archive of emerge w/ --debug (app-misc:tracker-0.14.3:20121031-190725.log.xz,66.89 KB, application/x-xz)
2012-10-31 19:18 UTC, Attila Stehr
Details
sudo V=1 emerge tracker -vD1 (build.log,199.39 KB, text/x-log)
2012-10-31 23:37 UTC, Attila Stehr
Details
build fix for 0.14.3 (fix.patch,858 bytes, patch)
2012-11-08 16:46 UTC, Shunichi Fuji
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Harris Landgarten 2011-05-19 01:36:45 UTC
Tracker fails to build and fails to run with missing libicuuc.so.46

See build log

Reproducible: Always
Comment 1 Harris Landgarten 2011-05-19 01:38:17 UTC
Created attachment 273899 [details]
tracker-0.10.12 build log

build log
Comment 2 Attila Stehr 2011-05-20 11:04:51 UTC
Created attachment 274095 [details]
emerge --info

same here
Comment 3 Attila Stehr 2011-05-20 16:59:33 UTC
I just made some tests. Even tracker-1.10.10 doesn't compile and shows the same errors now. 
But, I used tracker-1.10.10 for some month now. I just did a world update with a lot of new, updated or reemerged packages and some altered use flags. I hope tracker does not need python or perl somehow since I set USE="-python -perl" in make.conf prior world update (with --newuse flag). I did a revdep-rebuild -vi as well, which unsuccessfully tries to emerge tracker...
Comment 4 Attila Stehr 2011-05-20 19:01:53 UTC
Well an emerge --unmerge tracker followed by emerge tracker did it for me. So 0.10.12 is emerged and - AFAICS - working.
Any idea why?
Comment 5 Alex 2011-06-08 04:13:26 UTC
Created attachment 276243 [details]
tracker build log

I have tracker build fault too, but error is different
Comment 6 Alex 2011-06-08 04:14:29 UTC
here is my emerge --info:

Portage 2.1.10 (default/linux/x86/10.0/desktop, gcc-4.5.2, glibc-2.13-r2, 2.6.38-gentoo-r4nr i686)
=================================================================
System uname: Linux-2.6.38-gentoo-r4nr-i686-Intel-R-_Core-TM-2_CPU_6300_@_1.86GHz-with-gentoo-2.0.2
Timestamp of tree: Tue, 07 Jun 2011 04:00:01 +0000
ccache version 3.1.5 [enabled]
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.1.3-r1, 3.2
dev-util/ccache:          3.1.5
dev-util/cmake:           2.8.4-r1
sys-apps/baselayout:      2.0.2
sys-apps/openrc:          0.8.2-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21
sys-devel/gcc:            4.4.5, 4.5.2
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82
sys-kernel/linux-headers: 2.6.38 (virtual/os-headers)
sys-libs/glibc:           2.13-r2
Repositories: gentoo sunrise wish pure-funtoo geki-overlay lisp
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/var/calculate/share/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=2 --keep-going"
FEATURES="assume-digests binpkg-logs ccache distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://gentoo.telcom.net.ua/ http://ftp6.uni-erlangen.de/pub/mirrors/gentoo http://ftp.snt.ipv6.utwente.nl/pub/os/linux/gentoo/"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US ru ru_RU"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/calculate/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/wish /var/lib/layman/pure-funtoo /var/lib/layman/openoffice-geki /var/lib/layman/lisp"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa bash-completion berkdb branding bzip2 cairo ccache cdr cjk cli consolekit cracklib crypt cups cxx dbus djvu dri dts dvd dvdr emacs emboss encode exif fam ffmpeg firefox flac fortran gdbm gdu gif gmp gnutls gpm gstreamer gtk iconv icu jack jpeg jpeg2k kvm lcms ldap libnotify mad mdnsresponder-compat mmx mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png ppds pppd pulseaudio python qt3support qt4 readline sasl sdl session smp spell sse sse2 sse3 ssl startup-notification svg sysfs system-sqlite tcpd threads tiff truetype udev unicode usb vim-syntax vorbis x264 x86 xcb xinetd xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" FOO2ZJS_DEVICES="hp1018 hp1020" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US ru ru_RU" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 7 Alex 2011-06-08 04:20:00 UTC
I has successfully built tracker without "strigi" flag.
Comment 8 Gilles Dartiguelongue gentoo-dev 2012-10-31 15:00:33 UTC
*** Bug 416899 has been marked as a duplicate of this bug. ***
Comment 9 Gilles Dartiguelongue gentoo-dev 2012-10-31 15:01:53 UTC
For some reason I did not hit this problem in a while.
Comment 10 Rafał Mużyło 2012-10-31 16:13:39 UTC
So does anyone from all of those duplicate bugs plans to attach a verbose log ?
Comment 11 Attila Stehr 2012-10-31 16:49:35 UTC
Created attachment 327870 [details]
app-misc/tracker-0.14.3 build log
Comment 12 Attila Stehr 2012-10-31 16:51:59 UTC
Created attachment 327872 [details]
USE flags
Comment 13 Rafał Mużyło 2012-10-31 18:39:10 UTC
(In reply to comment #11)
> Created attachment 327870 [details]
> app-misc/tracker-0.14.3 build log

Note the word *verbose*.
Comment 14 Attila Stehr 2012-10-31 19:17:01 UTC
Created attachment 327880 [details]
emerge w/ --debug

Got no idea what "*verbose*" means (--verbose is set in my make.conf) and if I did it right this time.
Some instructions would be helpful. ;)
Comment 15 Attila Stehr 2012-10-31 19:18:14 UTC
Created attachment 327882 [details]
xz archive of emerge w/ --debug
Comment 16 Rafał Mużyło 2012-10-31 20:11:33 UTC
(In reply to comment #15)
> Created attachment 327882 [details]
> xz archive of emerge w/ --debug

OK, I though I wouldn't need to explain that detail.
I didn't mean debug log of portage activity, I just meant turning off silent automake - emerging with V=1, in this case.
But nice of you to take the time...
Comment 17 Attila Stehr 2012-10-31 23:37:00 UTC
Created attachment 327894 [details]
sudo V=1 emerge tracker -vD1

Hope it's right this time since the following fails.

$ sudo emerge tracker -vD1 -V=1
Usage: emerge [options]

emerge: error: no such option: -=
$
Comment 18 Rafał Mużyło 2012-11-01 03:00:10 UTC
(In reply to comment #17)
> Created attachment 327894 [details]
> sudo V=1 emerge tracker -vD1
> 
> Hope it's right this time since the following fails.
> 
> $ sudo emerge tracker -vD1 -V=1
> Usage: emerge [options]
> 
> emerge: error: no such option: -=
> $

Well, not quite (I've meant something like 'V=1 emerge -1 tracker' - not sure if that would work with sudo), but good enough - var got passed.

libtool: link: x86_64-pc-linux-gnu-gcc -shared  -fPIC -DPIC  .libs/tracker-sparql-expression.o .libs/tracker-sparql-pattern.o .libs/tracker-sparql-query.o .libs/tracker-sparql-scanner.o .libs/tracker-turtle-reader.o .libs/tracker-class.o .libs/tracker-collation.o .libs/tracker-data-backup.o .libs/tracker-data-manager.o .libs/tracker-data-query.o .libs/tracker-data-update.o .libs/tracker-db-config.o .libs/tracker-db-interface.o .libs/tracker-db-interface-sqlite.o .libs/tracker-db-manager.o .libs/tracker-db-journal.o .libs/tracker-db-backup.o .libs/tracker-namespace.o .libs/tracker-ontology.o .libs/tracker-ontologies.o .libs/tracker-property.o  -Wl,--whole-archive ../../src/gvdb/.libs/libgvdb.a ../../src/libtracker-fts/.libs/libtracker-fts.a -Wl,--no-whole-archive  -Wl,-rpath -Wl,/var/tmp/portage/app-misc/tracker-0.14.3/work/tracker-0.14.3/src/libtracker-common/.libs -Wl,-rpath -Wl,/usr/lib64/tracker-0.14 -Wl,--as-needed ../../src/libtracker-common/.libs/libtracker-common.so -luuid -lz /var/tmp/portage/app-misc/tracker-0.14.3/work/tracker-0.14.3/src/libtracker-common/.libs/libtracker-common.so -lm -lgio-2.0 -lgobject-2.0 -lglib-2.0 -lsqlite3 -licuuc -licui18n  -O1 -march=core2 -Wl,-O1   -Wl,-soname -Wl,libtracker-data.so.0 -o .libs/libtracker-data.so.0.1400.3

Initial theory: changing in src/libtracker-common/Makefile.am
libtracker_common_la_LIBADD += $(top_builddir)/src/libstemmer/libstemmer.la
to
libtracker_common_la_LIBADD = $(top_builddir)/src/libstemmer/libstemmer.la $(libtracker_common_la_LIBADD)

+ the joy of eautoreconf (likely that whole block under 'if [[ ${PV} = 9999 ]];') might help. I'm not sure whether bit more verbose change would be needed as '$(top_builddir)/src/libstemmer/libstemmer.la' might need to come after '$(top_builddir)/src/libtracker-common/libtracker-common.la'.
Comment 19 Rafał Mużyło 2012-11-01 03:02:43 UTC
...ignore the first line of my last comment - I've missed the attachment's description.
Comment 20 Rafał Mużyło 2012-11-02 04:16:09 UTC
*** Bug 440890 has been marked as a duplicate of this bug. ***
Comment 21 renato gallo 2012-11-02 12:55:44 UTC
same problem here
Comment 22 Rafał Mużyło 2012-11-03 13:42:46 UTC
*** Bug 441568 has been marked as a duplicate of this bug. ***
Comment 23 Ilias 2012-11-07 09:14:25 UTC
(In reply to comment #4)
> Well an emerge --unmerge tracker followed by emerge tracker did it for me.
> So 0.10.12 is emerged and - AFAICS - working.
> Any idea why?

Same here. 
http://forums.gentoo.org/viewtopic-p-7178338.html#7178338

Got it emerged after unmerging it first.
Comment 24 Shunichi Fuji 2012-11-08 16:46:58 UTC
Created attachment 328830 [details, diff]
build fix for 0.14.3

add eautoreconf to src_prepare() to fix build.
Comment 25 Rafał Mużyło 2012-11-08 18:51:09 UTC
(In reply to comment #24)
> Created attachment 328830 [details, diff] [details, diff]
> build fix for 0.14.3
> 
> add eautoreconf to src_prepare() to fix build.

That's very unlikely to fix this problem.
Comment 26 Shunichi Fuji 2012-11-09 14:24:05 UTC
(In reply to comment #25)
DId you try patch?
I reproduce this bug and confirmed fix this build failure.

To reproduce:
1,emerge tracker with icu-49.x.
2,unmask icu-50.x and emerge it.
3,emerge tracker then you'll see this bug.
Comment 27 Rafał Mużyło 2012-11-09 16:04:13 UTC
(In reply to comment #26)
> (In reply to comment #25)
> DId you try patch?
> I reproduce this bug and confirmed fix this build failure.
> 
> To reproduce:
> 1,emerge tracker with icu-49.x.
> 2,unmask icu-50.x and emerge it.
> 3,emerge tracker then you'll see this bug.

:roll:
Unless upstream *really* messed up, euautoreconf on its own is more or less a no-op (a few technicalities aside), despite the time it takes.
Comment 28 Harris Landgarten 2012-12-12 17:20:08 UTC
if you uninstall tracker-14.4 and then reinstall it, it will build with icu-50.1-r2
Comment 29 Attila Stehr 2012-12-14 00:02:31 UTC
(In reply to comment #28)
> if you uninstall tracker-14.4 and then reinstall it, it will build with
> icu-50.1-r2

I can not confirm this.

/bin/sh ../../libtool  --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc  -O1 -pipe -march=core2 -ggdb  -Wl,-O1 -Wl,--as-needed -o tracker-info tracker-info.o ../../src/libtracker-sparql-backend/libtracker-sparql-0.14.la ../../src/libtracker-miner/libtracker-miner-0.14.la ../../src/libtracker-common/libtracker-common.la  -lgio-2.0 -lgobject-2.0 -lglib-2.0   
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../x86_64-pc-linux-gnu/bin/ld: warning: libicuuc.so.49, needed by /usr/lib64/tracker-0.14/libtracker-data.so.0, not found (try using -rpath or -rpath-link)
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../x86_64-pc-linux-gnu/bin/ld: warning: libicui18n.so.49, needed by /usr/lib64/tracker-0.14/libtracker-data.so.0, not found (try using -rpath or -rpath-link)
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ucnv_fromUChars_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ubrk_open_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ucol_close_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `u_strToLower_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `uiter_next32_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ubrk_previous_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ucol_open_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `uiter_setUTF8_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `u_errorName_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ucol_strcollIter_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ubrk_close_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ucnv_open_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ubrk_next_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `uiter_current32_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ubrk_first_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ucnv_close_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `u_charType_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `unorm_normalize_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `u_strFoldCase_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `uiter_setString_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ucnv_toUnicode_49'
collect2: ld returned 1 exit status
make[3]: *** [tracker-import] Error 1
make[3]: *** Waiting for unfinished jobs....
libtool: link: x86_64-pc-linux-gnu-gcc -O1 -pipe -march=core2 -ggdb -Wl,-O1 -o .libs/tracker-info tracker-info.o  -Wl,--as-needed ../../src/libtracker-sparql-backend/.libs/libtracker-sparql-0.14.so ../../src/libtracker-miner/.libs/libtracker-miner-0.14.so ../../src/libtracker-common/.libs/libtracker-common.so -lgio-2.0 -lgobject-2.0 -lglib-2.0 -Wl,-rpath -Wl,/usr/lib64/tracker-0.14
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../x86_64-pc-linux-gnu/bin/ld: warning: libicuuc.so.49, needed by /usr/lib64/tracker-0.14/libtracker-data.so.0, not found (try using -rpath or -rpath-link)
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../x86_64-pc-linux-gnu/bin/ld: warning: libicui18n.so.49, needed by /usr/lib64/tracker-0.14/libtracker-data.so.0, not found (try using -rpath or -rpath-link)
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ucnv_fromUChars_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ubrk_open_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ucol_close_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `u_strToLower_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `uiter_next32_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ubrk_previous_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ucol_open_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `uiter_setUTF8_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `u_errorName_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ucol_strcollIter_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ubrk_close_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ucnv_open_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ubrk_next_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `uiter_current32_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ubrk_first_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ucnv_close_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `u_charType_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `unorm_normalize_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `u_strFoldCase_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `uiter_setString_49'
/usr/lib64/tracker-0.14/libtracker-data.so.0: undefined reference to `ucnv_toUnicode_49'
collect2: ld returned 1 exit status
make[3]: *** [tracker-info] Error 1
make[3]: Leaving directory `/var/tmp/portage/app-misc/tracker-0.14.4/work/tracker-0.14.4/src/tracker-utils'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/app-misc/tracker-0.14.4/work/tracker-0.14.4/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-misc/tracker-0.14.4/work/tracker-0.14.4'
make: *** [all] Error 2
 * ERROR: app-misc/tracker-0.14.4 failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=app-misc/tracker-0.14.4'`,
 * the complete build log and the output of `emerge -pqv '=app-misc/tracker-0.14.4'`.
 * The complete build log is located at '/var/log/portage/app-misc:tracker-0.14.4:20121213-234726.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/app-misc/tracker-0.14.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-misc/tracker-0.14.4/temp/environment'.
 * Working directory: '/var/tmp/portage/app-misc/tracker-0.14.4/work/tracker-0.14.4'
 * S: '/var/tmp/portage/app-misc/tracker-0.14.4/work/tracker-0.14.4'

>>> Failed to emerge app-misc/tracker-0.14.4, Log file:

$ eix dev-libs/icu
* dev-libs/icu
[...]
     Installed versions:  Version:   50.1-r2
                          Date:      19:26:56 12.12.2012
                          USE:       -debug -doc -examples -static-libs
Comment 30 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-12-15 17:59:03 UTC
(In reply to comment #29)

You probably forgot to first rebuild some of tracker's dependencies that themselves link to icu. For example, libxml2 and/or sqlite.

This situation should be automatically handled by running revdep-rebuild, or, if you are using portage-2.2, by "emerge @preserved-rebuild".
Comment 31 Rafał Mużyło 2012-12-15 18:30:20 UTC
(In reply to comment #30)
> (In reply to comment #29)
> 
> You probably forgot to first rebuild some of tracker's dependencies that
> themselves link to icu. For example, libxml2 and/or sqlite.
> 
> This situation should be automatically handled by running revdep-rebuild,
> or, if you are using portage-2.2, by "emerge @preserved-rebuild".

No, the bug does exist, but comment 29 shows actually a *failure* to unmerge the installed version of tracker.
Comment 32 Attila Stehr 2012-12-15 23:45:53 UTC
I did a revdep-rebuild which did rebuild all packages except tracker. Anyways, uninstalling tracker and (re)istalling worked now. 
I do updates dayly. Is it possible that an other package interfered here?
Comment 33 Rafał Mużyło 2012-12-16 17:25:16 UTC
While comment 18 doesn't provide a solution, only hints were it may lie, it describes the problem in detail.
Comment 34 Reinis Danne 2012-12-20 19:59:35 UTC
I can confirm that adding eautoreconf fixes the issue.
Comment 35 Rafał Mużyło 2012-12-28 17:59:25 UTC
*** Bug 449022 has been marked as a duplicate of this bug. ***
Comment 36 Gilles Dartiguelongue gentoo-dev 2012-12-28 20:00:44 UTC
btw, I have again, update two machines since the icu-50 unmask and I have, again, not met this problem. emerge @preserved-libs or revdep-rebuild should get you through this.

If someone still has problems with this, please you please add:
 * your emerge -pv tracker
 * what arch you are running on
 * if adding eautoreconf or just elibtoolize to the ebuild in src_prepare does anything to make it work ? (like the proposed patch)
Comment 37 Alexandre Hannud Abdo 2012-12-28 20:11:15 UTC
(In reply to comment #36)
> btw, I have again, update two machines since the icu-50 unmask and I have,
> again, not met this problem. emerge @preserved-libs or revdep-rebuild should
> get you through this.

I just had the issue again yesterday, like before it compiled fine after first unmerging tracker. Revdep-rebuild did nothing to fix it.

> If someone still has problems with this, please you please add:
>  * your emerge -pv tracker
>  * what arch you are running on
>  * if adding eautoreconf or just elibtoolize to the ebuild in src_prepare
> does anything to make it work ? (like the proposed patch)

# emerge -pv tracker
[ebuild   R    ] app-misc/tracker-0.14.4  USE="exif flac gif gnome-keyring gstreamer gtk iso jpeg miner-fs mp3 nautilus pdf tiff vorbis xml (-applet) -cue -doc (-eds) -firefox-bookmarks -flickr -gsf -iptc -laptop -networkmanager -playlist -rss {-test} -thunderbird -upnp-av -xine -xmp -xps" 0 kB

Running ~amd64

I've just applied the unmerge workaround and can't revert everything just to test it right now, but the issue was still there yesterday.
Comment 38 Harris Landgarten 2012-12-28 21:44:43 UTC
I rebuilt world last weekend and tracker built fine so the problem is machine specific. I am also on amd64 ~arch
Comment 39 David 2013-01-02 21:13:29 UTC
I've been having trouble reinstalling tracker for the past couple weeks.  Just found this thread today.

emerge -pv tracker:
[ebuild   R    ] app-misc/tracker-0.14.4  USE="exif flac gif gnome-keyring gstreamer gtk iso jpeg miner-fs mp3 nautilus pdf tiff vorbis xml (-applet) -cue -doc (-eds*) -firefox-bookmarks -flickr -gsf -iptc -laptop -networkmanager -playlist -rss {-test} -thunderbird -upnp-av% -xine -xmp -xps (-upnp%)" 0 kB

arch: ~amd64

Adding eautoreconf produced the following error:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-misc/tracker:0

  (app-misc/tracker-0.14.3::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-misc/tracker-0.14.4::gentoo, installed) pulled in by
    >=app-misc/tracker-0.14.4 required by (gnome-extra/nautilus-tracker-tags-0.14.4::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

After unmerging tracker-0.14.4 (which was already installed, but required re-emerge according to portage), the emerge -pv tracker looks like this:
[ebuild  N     ] app-misc/tracker-0.14.4  USE="exif flac gif gnome-keyring gstreamer gtk iso jpeg miner-fs mp3 nautilus pdf tiff vorbis xml (-applet) -cue -doc (-eds) -firefox-bookmarks -flickr -gsf -iptc -laptop -networkmanager -playlist -rss {-test} -thunderbird -upnp-av -xine -xmp -xps" 0 kB

emerging tracker again, after having unmerged it and without the eautoreconf fix, resulted in a successful emerge.

Hope this helps.
Comment 40 Micah Shennum 2013-01-10 22:37:39 UTC
I was also having the exact same problem, trying to run revdep-rebuild. Uninstall and install solved it.

[ebuild  N     ] app-misc/tracker-0.14.4  USE="exif flac gif gnome-keyring gstreamer gtk iso jpeg miner-fs mp3 nautilus networkmanager pdf tiff vorbis xml (-applet) -cue -doc (-eds) -firefox-bookmarks -flickr -gsf -iptc -laptop -playlist -rss {-test} -thunderbird -upnp-av -xine -xmp -xps" 0 kB
Comment 41 Reinis Danne 2013-04-08 12:43:00 UTC
It is still broken in traker 0.14.5.
Comment 42 Harris Landgarten 2013-04-08 13:15:28 UTC
just went through the same with tracker-0.16 and the icu-0.51 upgrade this weekend.

Tracker would not rebuild without uninstalling it first. After the uninstall it did build.
Comment 43 Rafał Mużyło 2013-04-11 11:25:17 UTC
*** Bug 465464 has been marked as a duplicate of this bug. ***
Comment 44 Rafał Mużyło 2013-04-11 23:24:45 UTC
So,...

The problem here is a bit more silly than I initially expected.

I've just filed it upstream.

It's simply that comment 34 was in a way right.

It's not incorrect use of automake, that I suspect, that the problem.
It's that upstream uses libtol patched by Debian (Debian-2.4.2-ubuntu2).

If the changes in ltmain.sh are reverted to vanilla libtool, tracker gets built correctly. That's why simply adding eautoreconf worked.
Comment 45 Pacho Ramos gentoo-dev 2013-04-28 14:27:41 UTC
+  28 Apr 2013; Pacho Ramos <pacho@gentoo.org> tracker-0.16.0.ebuild:
+  Add an eautoreconf call to prevent compilation problems caused by upstream
+  refusing to use upstream libtool and using patched Debian one instead
+  (#367975)
+
Comment 46 Rafał Mużyło 2013-04-28 15:16:07 UTC
(In reply to comment #45)
> +  28 Apr 2013; Pacho Ramos <pacho@gentoo.org> tracker-0.16.0.ebuild:
> +  Add an eautoreconf call to prevent compilation problems caused by upstream
> +  refusing to use upstream libtool and using patched Debian one instead
> +  (#367975)
> +

Just a thought here: given this might not be the only package with such problem, perhaps an addition to ELT-patches should be considered - after all, it seems reversing debian patch for ltmain.sh seems sufficient.
Comment 47 Carter Young 2013-04-30 14:02:50 UTC
added myself here for tracking
Comment 48 Pacho Ramos gentoo-dev 2013-05-01 09:18:47 UTC
*** Bug 467990 has been marked as a duplicate of this bug. ***
Comment 49 Ferenc Erki 2013-05-02 07:55:58 UTC
(In reply to comment #45)
> +  28 Apr 2013; Pacho Ramos <pacho@gentoo.org> tracker-0.16.0.ebuild:
> +  Add an eautoreconf call to prevent compilation problems caused by upstream
> +  refusing to use upstream libtool and using patched Debian one instead
> +  (#367975)
> +

Applying this to tracker-0.14.5 also seems to work, thanks!
Comment 50 Pacho Ramos gentoo-dev 2013-05-02 08:03:55 UTC
+  02 May 2013; Pacho Ramos <pacho@gentoo.org> tracker-0.14.5.ebuild:
+  Run eautoreconf also for 0.14 (#367975#c49)
+