Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 367717 - sys-apps/openrc: services which need net aren't starting on boot
Summary: sys-apps/openrc: services which need net aren't starting on boot
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Hosted Projects
Classification: Unclassified
Component: OpenRC (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: OpenRC Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-17 14:18 UTC by Scott Alfter
Modified: 2013-08-21 17:32 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott Alfter 2011-05-17 14:18:59 UTC
openrc is trying to start ntp-client, nfsmount, and samba before net.eth0 is up. ifplugd is installed, so /etc/init.d/net.eth0 exits before the interface is up, but with baselayout-1, the aforementioned services waited for eth0 to go active before they attempted to start.  With baselayout-2, they try to start and fail...rc-status reports that ntp-client and nfsmount are stopped and samba is crashed.  Manually restarting them once eth0 is up works, but I shouldn't have to do that.  rc-update -u doesn't have any effect.


Reproducible: Always




Portage 2.2.0_alpha30 (default/linux/amd64/10.0, gcc-4.4.5, glibc-2.11.3-r0, 2.6.38-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.38-gentoo-r1-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-gentoo-2.0.2
Timestamp of tree: Mon, 16 May 2011 19:30:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r2, 2.7.1-r1, 3.1.3-r1
dev-util/ccache:     2.4-r9
dev-util/cmake:      2.8.4
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.8.2-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.4_p6-r1, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
sys-kernel/linux-headers: 2.6.36.1
sys-libs/glibc:      2.11.3
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
Repositories: gentoo multimedia sunrise bgo hamsterrific x-portage Mythtv-Ebuilds
Installed sets:
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache distlocks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans"
FFLAGS=""
GENTOO_MIRRORS="http://mirrors.tds.net/gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/multimedia /var/lib/layman/sunrise /var/lib/layman/bgo-overlay /var/lib/layman/hamsterrific /usr/local/portage /usr/local/mythtv-portage/packaging/Gentoo"
SYNC="rsync://mythserver/gentoo-portage"
USE="X a52 aac ac3 acl alsa amd64 apache2 berkdb bluetooth bluray bzip2 cairo cdda cdparanoia cdr cli compressed-lumas consolekit cracklib crypt css cups cupsddk cxx dbus djvu dri dts dv dvb dvd dvdnav dvdr dvdread eac3 ebook encode exif faac faad ffmpeg flac foomaticdb fortran frei0r gd gdbm gif git google-gadgets gpm gtk hpijs iconv id3tag ieee1394 ilbc ipv6 ivtv java javascript jpeg jpeg2k kde lame lcd libsamplerate lirc mad matroska melt mjpeg mmx mmxext mng modules mp2 mp3 mp4 mpeg mudflap multilib musicbrainz mysql ncurses netpbm network nls nptl nptlonly nsplugin nvidia odbc offensive ogg ogm opengl openmp pam pcre pdf perl png pnm policykit posix pppd python qt3support qt4 quicktime readline rplay samba scanner sdl semantic-desktop server session snmp sox speex spell sql sqlite srt sse sse2 sse3 ssl ssse3 subversion svg sysfs system-libvncserver taglib tcpd theora threads threadsafe tiff tk truetype udev unicode usb v4l v4l2 vcd vdpau vorbis webkit wxwidgets x264 xcomposite xinerama xml xorg xterm xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Scott Alfter 2011-05-20 15:27:39 UTC
Might have a fix...looks like rc_depend_strict is commented out in the default /etc/rc.conf.  Uncommenting it and setting it to "YES" fixed a similar problem with a Gentoo VM I built the other day...need to try it now on the system that presented this problem the first time and see if it takes care of it there.
Comment 2 David J Cozatt 2011-06-29 16:45:53 UTC
The other day I rebuilt a kernel and rebooted and all these clients worked as they should. Then I realised I had somehow managed to lose alsa at startup and had to recompile the sound module and as soon as the sound module worked and loaded...these services 'postfix' and 'ntp-client' no longer started properly at boot.

Would you try temporarily removing alsa from your start services and see if you can confirm that it is causing the issue?
Comment 3 William Hubbs gentoo-dev 2013-08-21 17:32:25 UTC
There has been no activity on this for two years, so I am closingit. Please re-open if it is still an issue.