Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 367583 - x11-libs/qt-dbus-4.7.2 - ../../include/QtCore/../../src/corelib/arch/qatomic_generic.h:197: error: invalid conversion from ‘const void*’ to ‘void*’
Summary: x11-libs/qt-dbus-4.7.2 - ../../include/QtCore/../../src/corelib/arch/qatomic_...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: HPPA Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: 354033 qt-4.7.4-stable
  Show dependency tree
 
Reported: 2011-05-16 20:32 UTC by Jeroen Roovers
Modified: 2012-03-30 14:49 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
x11-libs:qt-dbus-4.7.2:20110516-201256.log [hppa,fail] (20110516-201256.log,46.45 KB, text/plain)
2011-05-16 20:32 UTC, Jeroen Roovers
Details
QT parisc-linux patch (qt-parisc-linux.diff,4.16 KB, patch)
2011-10-21 07:09 UTC, Guy Martin (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers gentoo-dev 2011-05-16 20:32:00 UTC
Created attachment 273495 [details]
x11-libs:qt-dbus-4.7.2:20110516-201256.log [hppa,fail]

Mon May 16 22:30:40 CEST 2011
Portage 2.1.9.49 (default/linux/hppa/10.0, gcc-4.4.5, glibc-2.11.3-r0, 2.6.38-gentoo-r2-JeR parisc)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.38-gentoo-r2-JeR-parisc-PA8700_-PCX-W2-with-gentoo-2.0.2
Timestamp of tree: Mon, 16 May 2011 15:15:01 +0000
distcc 3.1 hppa2.0-unknown-linux-gnu [enabled]
ccache version 2.4 [disabled]
app-shells/bash:          4.1_p9
dev-lang/python:          2.6.6-r2, 2.7.1-r1, 3.1.3-r1, 3.2
dev-util/ccache:          2.4-r9
dev-util/cmake:           2.8.4-r1
sys-apps/baselayout:      2.0.2
sys-apps/openrc:          0.8.2-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.65-r1
sys-devel/automake:       1.4_p6-r1, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.4.4-r2, 4.4.5, 4.5.1-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.2.10
sys-devel/make:           3.81-r2
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.11.3
ACCEPT_KEYWORDS="hppa"
ACCEPT_LICENSE="* -@EULA"
CBUILD="hppa2.0-unknown-linux-gnu"
CFLAGS="-mschedule=8000 -march=2.0 -ggdb -pipe -Wall -Wno-comment -O2"
CHOST="hppa2.0-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/distcc/bin /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/bind /var/spool/torque /var/www/localhost/htdocs/wordpress/wp-config.php"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.2/ext-active/ /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.2/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.2/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-mschedule=8000 -march=2.0 -ggdb -pipe -Wall -Wno-comment -O2"
DISTDIR="/aches/distfiles"
FEATURES="assume-digests binpkg-logs buildpkg distcc distlocks fixlafiles fixpackages news notitles parallel-fetch protect-owned sandbox sfperms splitdebug strict test test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv"
FFLAGS="-mschedule=8000 -march=2.0 -ggdb -pipe -Wall -Wno-comment -O2"
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ http://mirror.netcologne.de/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://gentoo.tiscali.nl/ "
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed"
LINGUAS="en nl he"
MAKEOPTS="-j6"
PKGDIR="/keeps/gentoo/packages/elmer"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/mnt/alt"
PORTDIR="/keeps/gentoo/portage"
PORTDIR_OVERLAY="/keeps/gentoo/local"
SYNC="rsync://rsync.nl.gentoo.org/gentoo-portage"
USE="7zip X Xaw3d a52 aac aalib abyss accessibility acl ads agg alsa amr amrnb amrwb ao aoss apis ares artist-screen asf ass assistant async asyncns audiofile audit automount avfs bash-completion berkdb bidi bittorrent bittorrent-external bl bluetooth bzip2 c++ cairo caps captury catalogs cblas cdb cdio cdr chardet cjk clarens cleartype cli colors contrast cpath cracklib crypt cue cups curl custom-cflags custom-cxxflags cxx dbi dbtool dbus designer designer-plugin device-mapper dga dia dirac directfb djbfft djvu domainkeys dri drm dts dv dvd dvdr dvdread ebook edl elf emacs enca encode esd examples exceptions exif expat facebook facedetect fam fame fastbuild fastcgi fbcon ffmpeg filter fits flac fluidsynth fontconfig foomaticdb fortran fpx frei0r ftp fts3 gadu galago games gcrypt gd gdbm geant4 geoip ggi gif gimp gimpprint glep glib glut gmp gnokii gnutls gphoto2 gpm gps graphite gs gsl gsm gtk gtk2 gtkhtml guidexml guile hepmc hesiod hotpixels hppa i18n ical icecast iconv icu idea idn imagemagick imlib indi inotify inquisitio ipmi ipv6 isc ithreads jabber jack javascript jbig jingle jpeg jpeg2k judy kpathsea lame lapack lasi lastfmradio latex lcms ldap leim lensfun libass libcaca libffi libmms libotf libsamplerate libwww live logrotate logwatch lto lua lyrics-screen lzma lzo mad manhole matroska mbrola mem-scramble memcache metis mhash midi mikmod mmap mng modplug modules motif mozbranding mp3 mpg123 mpi mplayer mssql mudflap multislot musepack musicbrainz mysql nagios-dns nagios-game nagios-ntp nagios-ping nagios-ssh nas ncurses netpbm nettle network-cron nfconntrack nfs nls nntp nova nptl nptlonly nsplugin ntlm objc objc++ objc-gc offensive ogg openal openexr opengl openmp openssl optimization oss ots overlays pam pango pbs pch pcre pdf pdo-external perl php pipe plasma plotutils plugins png policykit portage portaudio postgres povray ppds pppd pulseaudio python pyzord qalculate qdbm qt3support qt4 quotas raw readline recode rle romio rpc rrdtool rtc rtmp ruby ruby18 samba sasl scale0tilt scanner scim sdl seamonkey secure-delete server session sid skk slang slp smi sms sndfile snmp soap song-screen soundex speex spell spoof-source sqlite srt srtp ssh ssl startup-notification strong-optimization subtitles subversion suhosin supernodal svg swat sysfs syslog system-sqlite talkfilters tcl tcpd test tftp tga theora threads thumbnail thunar-vfs tidy tiff timezone timidity tk tokyocabinet tools truetype tslib tunepimp twolame udev unicode unzip urandom usb userlocales utempter utf v4l v4l2 vanim vcd vidix vim-syntax vorbis watchdog wavpack webdav webinstall webp wildmidi winbind wlan wma wmf xanim xattr xcb xchattext xcomposite xface xlisten xml xml2 xmp xmpi xorg xpm xrandr xscreensaver xsettings xulrunner xv xvid xvmc zip zip-external zlib" ALSA_CARDS="ad1889 usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev joystick keyboard mouse acecad aiptek calcomp citron digitaledge dmc dynapro elo2300 elographics fpit hyperpen jamstudio magellan microtouch mutouch palmax penmount spaceorb summa tek4957 tslib ur98 wacom void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en nl he" PHP_TARGETS="php5-2 php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="stifb fbdev none dummy" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jeroen Roovers gentoo-dev 2011-05-18 01:04:40 UTC
Found a bit of code putting HPPA in the generic corner, while traditionally anything hppa is normally called parisc. Testing with this patch now (rebuilding all of =x11-libs/qt-*-4.7.2):

Index: qt4-build.eclass
===================================================================
RCS file: /var/cvsroot/gentoo-x86/eclass/qt4-build.eclass,v
retrieving revision 1.90
diff -u -B -r1.90 qt4-build.eclass
--- qt4-build.eclass    10 Mar 2011 23:45:51 -0000      1.90
+++ qt4-build.eclass    18 May 2011 00:56:29 -0000
@@ -460,7 +460,8 @@
                x86-macos) myconf+=" -arch x86" ;;
                x86|x86-*) myconf+=" -arch i386" ;;
                alpha|arm|ia64|mips|s390|sparc) myconf+=" -arch $(tc-arch)" ;;
-               hppa|sh) myconf+=" -arch generic" ;;
+               hppa) myconf+=" -arch parisc" ;;
+               sh) myconf+=" -arch generic" ;;
                *) die "$(tc-arch) is unsupported by this eclass. Please file a bug." ;;
        esac
Comment 2 Jeroen Roovers gentoo-dev 2011-05-18 01:25:43 UTC
(In reply to comment #1)
> Found a bit of code putting HPPA in the generic corner, while traditionally
> anything hppa is normally called parisc. Testing with this patch now
> (rebuilding all of =x11-libs/qt-*-4.7.2):

No, that wasn't it. The assembly code appears to be for the HP-UX assembler. :-\
Comment 3 Guy Martin (RETIRED) gentoo-dev 2011-10-21 07:09:10 UTC
Created attachment 290413 [details, diff]
QT parisc-linux patch

Along with changing the architecture in qt4-build.eclass, the pach qt-parisc-linux.diff 
The tested patch needs to be applied to qt-* (provide they all come from the same source file).

Compiling works fine but I haven't had the opportunity to test the changes yet.
Comment 4 Jeroen Roovers gentoo-dev 2011-11-02 16:18:07 UTC
That patch would need to go into qt-core too, since that installs the actual .h file. Testing right now...
Comment 5 Jeroen Roovers gentoo-dev 2011-11-02 16:53:07 UTC
It requires a change to qt4-build.eclass as well, since HPPA wouldn't be using 
"-arch generic" any longer. One would suspect that SH is also affected by this "generic" bug, then.

Index: qt4-build.eclass
===================================================================
RCS file: /var/cvsroot/gentoo-x86/eclass/qt4-build.eclass,v
retrieving revision 1.96
diff -u -B -r1.96 qt4-build.eclass
--- qt4-build.eclass    30 Oct 2011 14:21:14 -0000      1.96
+++ qt4-build.eclass    2 Nov 2011 16:52:58 -0000
@@ -494,7 +494,8 @@
                x86-macos) myconf+=" -arch x86" ;;
                x86|x86-*) myconf+=" -arch i386" ;;
                alpha|arm|ia64|mips|s390|sparc) myconf+=" -arch $(tc-arch)" ;;
-               hppa|sh) myconf+=" -arch generic" ;;
+               sh) myconf+=" -arch generic" ;;
+               hppa) myconf+=" -arch parisc" ;;
                *) die "$(tc-arch) is unsupported by this eclass. Please file a bug." ;;
        esac
Comment 6 Jeroen Roovers gentoo-dev 2011-11-10 16:37:28 UTC
Qt team: Could you advise how to best include this patch in the tree? It needs to be added to the following packages:

x11-libs/qt-core
x11-libs/qt-dbus
x11-libs/qt-gui
x11-libs/qt-opengl
x11-libs/qt-script
x11-libs/qt-xmlpatterns

and is known to work with 4.7.2 - later versions have not been tested.
Comment 7 Davide Pesavento gentoo-dev 2011-11-10 17:38:06 UTC
I don't follow... isn't that patch against a header file installed by qt-core? If so, patching qt-core should be enough (plus qt4-build.eclass of course).
Comment 8 Jeroen Roovers gentoo-dev 2011-11-10 19:18:06 UTC
As far as I can tell, all x11-libs/qt-* that unpack the corelib directory actually include the headers found there.
Comment 9 Jeroen Roovers gentoo-dev 2012-03-07 17:24:10 UTC
This isn't going anywhere and it's holding up stabilisation for HPPA, which means holding up deprecation of older x11-libs/qt*.

We have a patch, it works, now it needs to be incorporated properly in your ebuilds.
Comment 10 Markos Chandras (RETIRED) gentoo-dev 2012-03-07 18:23:24 UTC
Why this patch is not in the upstream code?
Comment 11 Jeroen Roovers gentoo-dev 2012-03-07 18:42:51 UTC
(In reply to comment #10)
> Why this patch is not in the upstream code?

That's a good question. I suppose someone in qt@ serves as upstream contact.
Comment 12 Markos Chandras (RETIRED) gentoo-dev 2012-03-07 21:04:27 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > Why this patch is not in the upstream code?
> 
> That's a good question. I suppose someone in qt@ serves as upstream contact.

Not quite. I can report it upstream but I wonder why no other disto hit this bug
Comment 13 Jeroen Roovers gentoo-dev 2012-03-07 21:29:35 UTC
(In reply to comment #12)
> Not quite. I can report it upstream

Well, please do.
Comment 14 Markos Chandras (RETIRED) gentoo-dev 2012-03-08 19:14:46 UTC
Is this still reproducible in 4.8?

If so please adjust the title and I will open a bug report upstream
Comment 15 Davide Pesavento gentoo-dev 2012-03-09 00:27:13 UTC
(In reply to comment #14)
> Is this still reproducible in 4.8?

I suppose so, since the code is identical...
Comment 16 Markos Chandras (RETIRED) gentoo-dev 2012-03-09 08:36:53 UTC
https://bugreports.qt-project.org/browse/QTBUG-17962

Seems like it has already been reported but upstream does not care at all. Jer, would it be possible to try this patch?

https://bugreports.qt-project.org/secure/attachment/20844/qt-dbus-const.diff

If it works for you, then we don't need the qt4-build eclass patch that Guy attached
Comment 17 Markos Chandras (RETIRED) gentoo-dev 2012-03-09 08:43:06 UTC
Just to be clear, you must not use Guy's qt4-build.eclass patch when using the patch I attached in my previous comment.
Comment 18 Jeroen Roovers gentoo-dev 2012-03-09 15:08:43 UTC
(In reply to comment #16)
> https://bugreports.qt-project.org/browse/QTBUG-17962
> 
> Seems like it has already been reported but upstream does not care at all.
> Jer, would it be possible to try this patch?

You could very well try it yourself by simply setting `-arch generic'. After all, the bug is in the C code, not anything platform specific.

> https://bugreports.qt-project.org/secure/attachment/20844/qt-dbus-const.diff

I'll give it a go.

> If it works for you, then we don't need the qt4-build eclass patch that Guy
> attached

Guy's patch works fine. What's wrong with it except that upstream is too retarded to pick it up?
Comment 19 Markos Chandras (RETIRED) gentoo-dev 2012-03-09 17:57:47 UTC
(In reply to comment #18)
> (In reply to comment #16)
> > https://bugreports.qt-project.org/browse/QTBUG-17962
> > 
> > Seems like it has already been reported but upstream does not care at all.
> > Jer, would it be possible to try this patch?
> 
> You could very well try it yourself by simply setting `-arch generic'. After
> all, the bug is in the C code, not anything platform specific.
I could but I don't want to because my hardware resources are limited

> 
> > https://bugreports.qt-project.org/secure/attachment/20844/qt-dbus-const.diff
> 
> I'll give it a go.
> 
> > If it works for you, then we don't need the qt4-build eclass patch that Guy
> > attached
> 
> Guy's patch works fine. What's wrong with it except that upstream is too
> retarded to pick it up?

The thing is that we can apply the patch I told you immediately because we know upstream will never accept it. But if we decide to go with Gury's patch then we need to push it upstream and wait for upstream to reply on that
Comment 20 Jeroen Roovers gentoo-dev 2012-03-28 00:51:44 UTC
(In reply to comment #18)
> (In reply to comment #16)
> > https://bugreports.qt-project.org/browse/QTBUG-17962
> > 
> > Seems like it has already been reported but upstream does not care at all.

Then they ought to drop all the Linux/HPPA support files Bitrot set in years ago and every attempt to salvage it is declined.

> > Jer, would it be possible to try this patch?

> I'll give it a go.

It's fine. Looks like both qt-core and qt-dbus need the patch.
Comment 21 Davide Pesavento gentoo-dev 2012-03-29 15:00:02 UTC
This looks interesting: https://bugreports.qt-project.org/browse/QTBUG-22479
Comment 22 Jeroen Roovers gentoo-dev 2012-03-29 15:21:15 UTC
(In reply to comment #21)
> This looks interesting: https://bugreports.qt-project.org/browse/QTBUG-22479

Just another example. Upstream needs to get rid of code they refuse to support.

Now can we please get the generic const patch integrated so we can finally fix bug #354033 (and related bugs)?
Comment 23 Davide Pesavento gentoo-dev 2012-03-30 14:49:27 UTC
Finally fixed in qt-dbus-4.7.4 and 4.8.1. Apologies for the huge delay.