Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 367345 - dev-dotnet/libgdiplus - ../src/.libs/libgdiplus.so: error: undefined reference to 'atan'
Summary: dev-dotnet/libgdiplus - ../src/.libs/libgdiplus.so: error: undefined referenc...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal QA (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords: NeedPatch
: 443604 (view as bug list)
Depends on:
Blocks: underlinking
  Show dependency tree
 
Reported: 2011-05-15 12:08 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2019-06-08 12:59 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (libgdiplus-2.8.1:20110515-112741.log,74.87 KB, text/plain)
2011-05-15 12:08 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2011-05-15 12:08:14 UTC
Created attachment 273253 [details]
Build log

Hello there!

You're getting this bug because the package in Summary failed to build in my tinderbox using the gold link editor from binutils. Before closing the bug as INVALID let me explain why this is still important!

The gold link editor does not support underlinking of shared objects, which is something I have described in my blog post:

http://blog.flameeyes.eu/2010/11/26/it-s-not-all-gold-that-shines-why-underlinking-is-a-bad-thing

Even the basic link editor (ld.bfd) has an option to support this but it is a heck to enable and get passed, so linking with gold is simply quicker.

Fixing underlinking provides optimized --as-needed builds (because the "softer" version no longer need to recover libraries that are underlinked), so it is a Good Thing To Do.

Thank you very much for the attention!
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2014-01-06 21:37:53 UTC
*** Bug 443604 has been marked as a duplicate of this bug. ***
Comment 2 Roman Gruber 2015-08-17 17:14:50 UTC
https://forums.gentoo.org/viewtopic-p-7800218.html#7800218

ERROR: dev-dotnet/libgdiplus-3.12::gentoo failed
because of gold linker.

workaround: binutils-config --linker ld.bfd
 * Setting default linker to ld.bfd for x86_64-pc-linux-gnu-2.25.1 ... 

The ebuild should be changed so it uses this other linker instead of gold.

This is the only ebuild in my box which fails to build because of gold linker.
Comment 3 Justin Lecher (RETIRED) gentoo-dev 2015-08-18 09:35:34 UTC
commit 530f6e7150e1294c662583316d56bc9ac435f4be
Author: Justin Lecher <jlec@gentoo.org>
Date:   Tue Aug 18 11:27:20 2015 +0200

    dev-dotnet/libgdiplus: Fix for ld.gold; enhance various QA problems

    * underlinking fix: https://github.com/mono/libgdiplus/pull/33
    * drop removed configure option --with-cairo
    * call default() functions as often as possible

    Gentoo-Bug: https://bugs.gentoo.org/367345

    Package-Manager: portage-2.2.20.1
    Signed-off-by: Justin Lecher <jlec@gentoo.org>

    https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=530f6e7150e1294c662583316d56bc9ac435f4be
Comment 4 Benedikt Reinartz 2019-06-08 12:59:05 UTC
I have observed an issue like this with libgdiplus-5.6.1 again. It fails to build with gold but works with bfd.